Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX-15 repository - The doublecmd thread

Message
Author
User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1783
Joined: Sat Jan 16, 2016 8:20 pm

Re: MX-15 repository - The doublecmd thread

#11 Post by v3g4n » Wed Aug 24, 2016 10:14 am

Disable the test repo since that is why it is trying to upgrade the other packages. If that is not the reason and you originally had 0.8.0 installed then you may need to uninstall it and install 0.7.4. Not quite sure how apt handles downgrades. FYI, you are installing ubuntu packages, hence the ~xenial. I can look into getting 0.7.4 packaged tonight if mike is busy.

User avatar
Richard
Posts: 1705
Joined: Fri Dec 12, 2008 10:31 am

Re: MX-15 repository - The doublecmd thread

#12 Post by Richard » Wed Aug 24, 2016 11:24 am

No, the test repo is not active.

I originally had 0.7.0>0.7.1>0.7.2>0.7.3>0.7.4> installed;
all from the "Debian" build from the doublecmd repo on OpenSuse builder,
here: https://sourceforge.net/projects/doublecmd/files/
the alfa used to be available here:
deb http://download.opensuse.org/repositori ... ebian_8.0/ /
but it doesn't over-ride the entry for mx-repo.

On update today it was replaced with 8.0 from the mx-repo.
Trying to get back to 7.4 hasn't worked, so far.

Downloaded the deb binary and will try to install that with gdebi.
Up until today, I have used the DC repo without problem.
Wonder if it's a naming/sequencing problem? although, nothing seems apparent.

Thanks. v7.4 is the current stable from here: https://sourceforge.net/p/doublecmd/wiki/Download/
Last edited by Richard on Wed Aug 24, 2016 11:46 am, edited 1 time in total.
MX17.1: T430-2017, 8 GB RAM, 4.15.0-1-amd64, 119 SSD
antiX-/MX-171: AA1/Eee, 1 GB RAM, 4.15.0-1-686-pae, 149 HDD
DoubleCmd, LO604, Dropbox, Slimjet, mPDFed, Py3, CherryT, Vbox

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1783
Joined: Sat Jan 16, 2016 8:20 pm

Re: MX-15 repository - The doublecmd thread

#13 Post by v3g4n » Wed Aug 24, 2016 11:32 am

Well I'm only seeing 0.7.0 in the main repo so I'm not sure how it could upgrade to 0.8.0 if the test repo is not enabled. Have you tried to completely remove doublecmd and then reinstall it from the other repo you are using?

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9255
Joined: Wed Jul 12, 2006 2:26 pm

Re: MX-15 repository - The doublecmd thread

#14 Post by kmathern » Wed Aug 24, 2016 11:35 am

I think this will install the 0.7.4+svn7058~xenial version

Code: Select all

apt-get install doublecmd-common=0.7.4+svn7058~xenial doublecmd-gtk=0.7.4+svn7058~xenial doublecmd-gtk-dbg=0.7.4+svn7058~xenial doublecmd-plugins=0.7.4+svn7058~xenial -s
It's a simulation, if it looks like it will work remove the "-s" and run it again.

If you go ahead with the install you'll probably need to pin them afterwards, I'd do that it in Synaptic.

User avatar
Richard
Posts: 1705
Joined: Fri Dec 12, 2008 10:31 am

Re: MX-15 repository - The doublecmd thread

#15 Post by Richard » Wed Aug 24, 2016 1:04 pm

v3g4n wrote:Well I'm only seeing 0.7.0 in the main repo so I'm not sure how it could upgrade to 0.8.0 if the test repo is not enabled. Have you tried to completely remove doublecmd and then reinstall it from the other repo you are using?
Working on that.
Currently, not seeing anything from the other repo. Maybe it's down?
MX17.1: T430-2017, 8 GB RAM, 4.15.0-1-amd64, 119 SSD
antiX-/MX-171: AA1/Eee, 1 GB RAM, 4.15.0-1-686-pae, 149 HDD
DoubleCmd, LO604, Dropbox, Slimjet, mPDFed, Py3, CherryT, Vbox

User avatar
Richard
Posts: 1705
Joined: Fri Dec 12, 2008 10:31 am

Re: MX-15 repository - The doublecmd thread

#16 Post by Richard » Wed Aug 24, 2016 1:17 pm

Code: Select all

$ inxi -r
deb http://iso.mxrepo.com/antix/jessie/ jessie main
deb http://ftp.us.debian.org/debian/ jessie non-free contrib main
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://download.opensuse.org/repositories/home:/Alexx2000/Debian_8.0/ /
deb http://iso.mxrepo.com/mx/repo/ mx15 non-free main
deb http://download.virtualbox.org/virtualbox/debian/ jessie contrib
richard@h61h2mx15:~
and now it is working:
DC-versions-available-2016-Aug.png
DC-repos-as-expected.png
Sorry for the bother. Maybe the other repo really was down, but it wasn't giving any error message.

I did find that I had two test repos:
deb http://iso.mxrepo.com/mx/testrepo/ mx15 test
deb http://main.mepis-deb.org/mx/testrepo/ mx15 test
Not sure how the second one got there. I thought they were all deactivated?
but, the last time I opened /etc/apt/sources.list.d/, I found them.
Now they are both off.
Sources-List-RH-MX15x64.png
Actually, the first OpenSuse is now off. Was just checking to see if it worked for the Alfa-0.8.

Thanks for all the suggestions.
You do not have the required permissions to view the files attached to this post.
MX17.1: T430-2017, 8 GB RAM, 4.15.0-1-amd64, 119 SSD
antiX-/MX-171: AA1/Eee, 1 GB RAM, 4.15.0-1-686-pae, 149 HDD
DoubleCmd, LO604, Dropbox, Slimjet, mPDFed, Py3, CherryT, Vbox

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1783
Joined: Sat Jan 16, 2016 8:20 pm

Re: MX-15 repository - The doublecmd thread

#17 Post by v3g4n » Wed Aug 24, 2016 2:57 pm

Good to hear that all is good now. ;)

User avatar
Richard
Posts: 1705
Joined: Fri Dec 12, 2008 10:31 am

Re: MX-15 repository - The doublecmd thread

#18 Post by Richard » Wed Aug 24, 2016 3:32 pm

Thanks, it must have been something I did.
After I broke my install trying out different things,
I reinstalled a snapshot from a few weeks ago,
which cumulatively asked for over a 100 updates.
Some better than others.

I will make snapshots only of a stable system! Or at least a fallback.
MX17.1: T430-2017, 8 GB RAM, 4.15.0-1-amd64, 119 SSD
antiX-/MX-171: AA1/Eee, 1 GB RAM, 4.15.0-1-686-pae, 149 HDD
DoubleCmd, LO604, Dropbox, Slimjet, mPDFed, Py3, CherryT, Vbox

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1783
Joined: Sat Jan 16, 2016 8:20 pm

Re: MX-15 repository - The doublecmd thread

#19 Post by v3g4n » Sat Aug 27, 2016 11:52 am

If anyone is interested here are packages for doublecmd_0.7.4 for MX15. Since 0.8 is already in the test repo 0.7.4 cannot go in so I figured I would just post them here in case anyone is interested.
https://drive.google.com/open?id=0B_C2m ... mFyZVBpdkE

User avatar
Richard
Posts: 1705
Joined: Fri Dec 12, 2008 10:31 am

Re: MX-15 repository - The doublecmd thread

#20 Post by Richard » Sun Aug 28, 2016 6:34 am

The 0.7 line is called beta and is the current stable;
while the 0.8 is alpha.
MX17.1: T430-2017, 8 GB RAM, 4.15.0-1-amd64, 119 SSD
antiX-/MX-171: AA1/Eee, 1 GB RAM, 4.15.0-1-686-pae, 149 HDD
DoubleCmd, LO604, Dropbox, Slimjet, mPDFed, Py3, CherryT, Vbox

Post Reply

Return to “Package Requests/Status - MX-15/16”