Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 15/16 Repository: The SMPlayer Thread

Message
Author
number698
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Feb 15, 2016 1:49 pm

Re: MX 15 Repository: The SMPlayer Thread

#21 Post by number698 » Fri Nov 18, 2016 8:50 pm

hi, previous version had this issue, updated to latest version today - I did not change or reset any settings.

going back about maybe 3 ? versions back it was ok, an update broke it and at that time i did play around with resetting/fresh setups ect.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15 Repository: The SMPlayer Thread

#22 Post by Stevo » Sat Nov 19, 2016 4:03 pm

Hmmm...I can't reproduce it. When I set it to that, that's what comes up as the setting for new videos, too. You say you tried renaming the smplayer settings in ~/.config, so does the same thing happen if you create a new user account and try it as that user?

number698
Forum Novice
Forum  Novice
Posts: 18
Joined: Mon Feb 15, 2016 1:49 pm

Re: MX 15 Repository: The SMPlayer Thread

#23 Post by number698 » Sun Nov 20, 2016 10:45 am

so,using right click - looked at the menu while videos are playing and the deinterlace option IS ticked BUT the effect is NOT being applied to the videos (i can see the double edged effect on slowish movements ect).

while the video is still playing, I then select 'deinterlace - NONE' then re-apply the deinterlace ,, , video now plays with the deinterlace effect working.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15 Repository: The SMPlayer Thread

#24 Post by Stevo » Sun Nov 20, 2016 3:48 pm

number698 wrote:so,using right click - looked at the menu while videos are playing and the deinterlace option IS ticked BUT the effect is NOT being applied to the videos (i can see the double edged effect on slowish movements ect).

while the video is still playing, I then select 'deinterlace - NONE' then re-apply the deinterlace ,, , video now plays with the deinterlace effect working.
That should be reported on the SMPlayer forums as a bug, then--I don't know if the developer has a bug tracker set up on sourceforge or something like that.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15 Repository: The SMPlayer Thread

#25 Post by Stevo » Mon Jan 23, 2017 10:15 pm

SMPlayer 17.1.0 is now in the repository. Release notes include:

Code: Select all

Version 17.1

    Experimental support to play videos on Chromecast.
    Support for some of the #EXTVLCOPT options in m3u/m3u8 playlists. This may help to play online streams from playlists intended for VLC.
    New options in the context menu of the playlist: 'copy URL to clipboard', 'open source folder' and 'play on Chromecast'.
    Option to display bitrate information in the status bar.
    Possibility to display the playback time with milliseconds in the status bar.
    The option to add black borders on fullscreen is back (Preferences -> General -> Video).
    The option in the playlist to delete files from the disk has been removed.
A more thorough explanation of the new features is here.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15/16 Repository: The SMPlayer Thread

#26 Post by Stevo » Tue Feb 14, 2017 7:20 pm

The new 17.2.0 releases of SMPlayer and the optional icon package "smplayer-themes" are now in the main repository, along with an SMTube update that fixes VEVO youtube playback.

The themes package updates the themes Papirus and PapirusDark, and add the theme ePapirus, so it's possible to have it now match MX 16's default theme. SMPlayer's changes include:

- Fix for YouTube.

- The option to delete files from the disk in the playlist is back but
it's disabled by default (you can enable it in Preferences -> Playlist
-> Misc.

- On Linux SMPlayer now uses a different web server, included in the
packages, to serve files for Chromecast. If you installed the package
webfs you can uninstall it now since SMPlayer won't use it anymore.

- New translation: Norwegian Bokmål.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15/16 Repository: The SMPlayer Thread

#27 Post by Stevo » Wed Mar 08, 2017 6:24 pm

SMPlayer 17.3.0 is now in the main repository. This update add some support for adding subtitles to ChromeCast videos, more hardware accelerations options for the mpv backend, and a other few miscellaneous bug fixes.

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1783
Joined: Sat Jan 16, 2016 8:20 pm

Re: MX 15/16 Repository: The SMPlayer Thread

#28 Post by v3g4n » Sat Apr 08, 2017 9:17 pm

SMPlayer 17.4.0 is now in the main repository.
The thumbnail generator has been fixed.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15/16 Repository: The SMPlayer Thread

#29 Post by Stevo » Fri Apr 28, 2017 2:54 pm

SMPlayer 17.4.2 has landed in the main repository. This update includes:

- Add play_next and play_prev to the list of actions for the mouse buttons.
- Remember the position of the video when it's opened by drag & drop.
- Fix the audio normalization filter when using mpv > 0.24.
- Fix for the thumbnail generator when using old versions of mpv.
- Add option for the MPlayer ffhevcvdpau decoder.
- Add option View -> OSD -> Show times with milliseconds (requires
mpv >= 0.21).
- Be sure the suboptions for vo and ao aren't used. (mpv only)

We also have a newer mpv 0.25.0 backend in the test repository.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15/16 Repository: The SMPlayer Thread

#30 Post by Stevo » Tue May 09, 2017 2:32 pm

We're pushing the latest 17.5.0 as an update from our main repository to correct a problem with Youtube playback.

Post Reply

Return to “Package Requests/Status - MX-15/16”