Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 15/16 Repository: The SMPlayer Thread

Message
Author
User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16150
Joined: Fri Dec 15, 2006 8:07 pm

MX 15/16 Repository: The SMPlayer Thread

#1 Post by Stevo » Sat Oct 10, 2015 1:10 pm

We now have ver. 15.9.0 version in the test repository, which fixes the "can't get URL" problem when built against qt5, (though this uses qt4), and gets it to work well with the newer mpv 0.11.0 in the test repository. Some audio filter issues with mpv 0.11 are still being worked on by the developer.

The smplayer-translations package is replaced by smplayer-l10n, in accordance with upstream Debian.
Last edited by Stevo on Mon Jan 23, 2017 10:16 pm, edited 1 time in total.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16150
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15 Repository: The SMPlayer Thread

#2 Post by Stevo » Sun Dec 06, 2015 12:06 am

Now updated to 15.11.0 in test repo. This fixes some small issues with the latest mplayer and mpv releases, as well as:


Version 15.11

* Fix for YouTube.
* (Experimental) Support for YouTube live streams.
* The thumbnail generator is much faster now.
* New options to seek to the previous or next subtitle (mpv only).
* New option (Preferences -> General) to select the image format for
screenshots (mpv only).
* Fix a crash when changing the GUI.
* New option (Preferences -> Interface) to center the window
automatically.
* Display a tooltip in the time slider with the corresponding time of
the mouse position.
* Now there's an option in the configuration of the find subtitles window
which allows to specify if the language code should be appended to the
subtitle filename.
* (Fix for Windows) The main window will be centered if it's partially
outside of the desktop after an auto resize.
* When adding files to the playlist the first item is moved to its
correct place in the list.
* (Experimental) New action to start/stop capturing the playback stream.
The captured stream will be saved to the folder specified in
the smplayer.ini option "capture_directory" with the name
capture_NNNN.dump.
It only works correctly with mpeg. With other formats the
dumped stream won't play back.
* Disable the extrastereo and karaoke filters when using mpv.

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2368
Joined: Thu May 01, 2014 10:12 am

Re: MX 15 Repository: The SMPlayer Thread

#3 Post by mmikeinsantarosa » Sun Dec 06, 2015 12:58 am

I installed 15.11 in both 32 & 64 bit jessie VMs and when I opened a mp4 with it, the program crashed. After restarting both VMs the problem was gone on the 32 bit but remained on the 64 bit. Then I installed it on a fully updated 64 bit MX-15 a3 desktop and had the same problem. After restarting the 64 bit desktop the problem was gone. Here's there error and attached error dialog.

Code: Select all

/usr/bin/mplayer -noquiet -slave -identify -nofs -sub-fuzziness 1 -vo xv, -nodr -double -stop-xscreensaver -nomouseinput -input nodefault-bindings:conf=/dev/null -nokeepaspect -wid 31457375 -monitorpixelaspect 1 -subfont-osd-scale 3 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/mandbx/.config/smplayer/styles.ass -subcp ISO-8859-1 -subpos 100 -volume 50 -cache 2048 -osdlevel 0 -vf-add screenshot=/home/mandbx/Pictures/smplayer_screenshots/shot -noslices -channels 2 -af-add scaletempo -af-add equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /home/mandbx/Pictures/movie/DSCF0575.MP4

MPlayer2 2.0-728-g2c378c7-4+b1 (C) 2000-2012 MPlayer Team
Terminal type `unknown' is not defined.

Playing /home/mandbx/Pictures/movie/DSCF0575.MP4.
Cache size set to 2048 KiB

Cache fill:  0.00% (0 bytes)   
Detected file format: QuickTime / MOV (libavformat)
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7fbe1c4f1b40]max_analyze_duration 5000000 reached
ID_VIDEO_ID=0
[lavf] stream 0: video (mpeg4), -vid 0
ID_AUDIO_ID=0
ID_AID_0_LANG=eng
[lavf] stream 1: audio (aac), -aid 0, -alang eng
Clip info:
 major_brand: mp42
ID_CLIP_INFO_NAME0=major_brand
ID_CLIP_INFO_VALUE0=mp42
 minor_version: 0
ID_CLIP_INFO_NAME1=minor_version
ID_CLIP_INFO_VALUE1=0
 compatible_brands: mp42isom
ID_CLIP_INFO_NAME2=compatible_brands
ID_CLIP_INFO_VALUE2=mp42isom
 creation_time: 2010-08-09 17:12:08
ID_CLIP_INFO_NAME3=creation_time
ID_CLIP_INFO_VALUE3=2010-08-09 17:12:08
 comment: FUJIFILM DIGITAL CAMERA
ID_CLIP_INFO_NAME4=comment
ID_CLIP_INFO_VALUE4=FUJIFILM DIGITAL CAMERA
 comment-eng: FUJIFILM DIGITAL CAMERA
ID_CLIP_INFO_NAME5=comment-eng
ID_CLIP_INFO_VALUE5=FUJIFILM DIGITAL CAMERA
ID_CLIP_INFO_N=6
Load subtitles in /home/mandbx/Pictures/movie/
ID_FILENAME=/home/mandbx/Pictures/movie/DSCF0575.MP4
ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=MP4V
ID_VIDEO_BITRATE=3179600
ID_VIDEO_WIDTH=640
ID_VIDEO_HEIGHT=480
ID_VIDEO_FPS=29.970
ID_VIDEO_ASPECT=1.3333
ID_AUDIO_FORMAT=MP4A
ID_AUDIO_BITRATE=127344
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=1
ID_START_TIME=0.00
ID_LENGTH=207.84
ID_SEEKABLE=1
ID_CHAPTERS=0
[VO_XV] It seems there is no Xvideo support for your video card available.
[VO_XV] Run 'xvinfo' to verify its Xv support and read
[VO_XV] DOCS/HTML/en/video.html#xv!
[VO_XV] See 'mplayer -vo help' for other (non-xv) video out drivers.
[VO_XV] Try -vo x11.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1
[VO_XV] It seems there is no Xvideo support for your video card available.
[VO_XV] Run 'xvinfo' to verify its Xv support and read
[VO_XV] DOCS/HTML/en/video.html#xv!
[VO_XV] See 'mplayer -vo help' for other (non-xv) video out drivers.
[VO_XV] Try -vo x11.
libGL error: pci id for fd 8: 80ee:beef, driver (null)
OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
OpenGL Warning: glVertexArrayRangeNV not found in mesa table
OpenGL Warning: glCombinerInputNV not found in mesa table
OpenGL Warning: glCombinerOutputNV not found in mesa table
OpenGL Warning: glCombinerParameterfNV not found in mesa table
OpenGL Warning: glCombinerParameterfvNV not found in mesa table
OpenGL Warning: glCombinerParameteriNV not found in mesa table
OpenGL Warning: glCombinerParameterivNV not found in mesa table
OpenGL Warning: glFinalCombinerInputNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterivNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glDeleteFencesNV not found in mesa table
OpenGL Warning: glFinishFenceNV not found in mesa table
OpenGL Warning: glGenFencesNV not found in mesa table
OpenGL Warning: glGetFenceivNV not found in mesa table
OpenGL Warning: glIsFenceNV not found in mesa table
OpenGL Warning: glSetFenceNV not found in mesa table
OpenGL Warning: glTestFenceNV not found in mesa table
OpenGL Error: Can't patch size is too small.(glXGetProcAddress)
OpenGL Error: Not enough memory.
*** Error in `/usr/bin/mplayer': free(): invalid pointer: 0x00007fbe199b3060 ***


MPlayer interrupted by signal 6 in module: preinit_libvo
ID_SIGNAL=6
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.
 
You do not have the required permissions to view the files attached to this post.
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16150
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15 Repository: The SMPlayer Thread

#4 Post by Stevo » Sun Dec 06, 2015 1:53 am

[VO_XV] It seems there is no Xvideo support for your video card available.
[VO_XV] Run 'xvinfo' to verify its Xv support and read
Gotta set the video output to x11 in VBox...

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16150
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15 Repository: The SMPlayer Thread

#5 Post by Stevo » Sat Jan 16, 2016 11:13 pm

The current 16.1.0 release is now in the test repository. Issues resolved include:

From http://blog.smplayer.info/smplayer-16-1 ... -released/
Version 16.1 is available for download. In this version YouTube has been fixed again.

There’s another fix, now the screenshots work again with older versions of MPlayer or mpv.

Version 16.1 also includes a new feature. Now it’s possible to set bookmarks on a video (for example in a musical movie you can mark the beginning of each song, to quickly seek to them later).

This feature is available in the menu Browser -> Bookmarks. You’ll find there an option to add a new bookmark, an option to edit the current bookmarks and the bookmarks you had set.

There are some key shortcuts:

Ctrl+A: adds a new bookmark
Ctrl+B: seeks to the previous bookmark
Ctrl+N: seeks to the next bookmark

Notice that currently bookmarks only work with “regular” files (so no discs or online streams) and the option to “remember the settings for all files” (Preferences -> General) must be enabled.
For those that miss the extrastereo option when using the mpv backend, it appears a fix is in sight, but it would require a rebuild of mpv to use its internal ffmpeg: http://forum.smplayer.info/viewtopic.php?f=2&t=8307

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5687
Joined: Sat Jul 15, 2006 10:40 am

Re: MX 15 Repository: The SMPlayer Thread

#6 Post by anticapitalista » Sun Feb 28, 2016 8:58 am

Can this be moved to stable/main? It has been working ok.
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16150
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15 Repository: The SMPlayer Thread

#7 Post by Stevo » Sun Feb 28, 2016 7:34 pm

It and SMtube are also solid for me, I'll ask Tim to move them. Has anyone tried the new VLC 2.2.2 in testing?

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1783
Joined: Sat Jan 16, 2016 8:20 pm

Re: MX 15 Repository: The SMPlayer Thread

#8 Post by v3g4n » Sun Feb 28, 2016 8:13 pm

Although I have not tried every format possible I have played videos through smtube, web4 and mp4 audio from youtube-dl, mp3 audio cd and a dvd. All have played without issue. Let me know if you need any further testing or have specific use cases you would like tested and I will be glad to try it. I have also been testing it in both xfce and kde if that helps.

Edit: Sorry maybe this should be moved to the vlc thread?

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16150
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15 Repository: The SMPlayer Thread

#9 Post by Stevo » Sun Feb 28, 2016 8:43 pm

v3g4n wrote:Although I have not tried every format possible I have played videos through smtube, web4 and mp4 audio from youtube-dl, mp3 audio cd and a dvd. All have played without issue. Let me know if you need any further testing or have specific use cases you would like tested and I will be glad to try it. I have also been testing it in both xfce and kde if that helps.

Edit: Sorry maybe this should be moved to the vlc thread?

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16150
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15 Repository: The SMPlayer Thread

#10 Post by Stevo » Wed Mar 30, 2016 8:50 pm

SMPlayer 16.4.0 is now in the test repository. From the developer's release announcement:

Now it's easier to switch between mplayer and mpv (Preferences -> General, select either mplayer or mpv as multimedia engine).
The extrastereo filter works again when using mpv. (the mpv 0.16 in our test repo)
Possibility to use the VLC shortcuts. (Preferences -> Keyboard and mouse, click the load button, select vlc.keys)
Possibility to enable mouse gestures (when the mouse is dragged up or down in the video window the volume changes. If dragged left or right it changes the time position). You can enable this option in Preferences -> Keyboard and mouse -> Mouse -> Drag function: seek and volume.
A fix for saving bookmarks.
The option for streaming sites in Preferences -> Network is different now, and allows these values:
Disabled: support for video sites is turned off
Auto: enables the internal support for YouTube and uses mpv + youtube-dl for the rest of sites
YouTube: only the internal support for YouTube will be used
mpv + youtube-dl: uses mpv + youtube-dl for all sites
An animated icon has been added in the status bar to indicate when the player is buffering.
A new layout is used to display the media information (Options -> View info and properties).

Post Reply

Return to “Package Requests/Status - MX-15/16”