The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

I broke APT in MEPIS 12. -- SOLVED

Post Reply
User avatar
Forum Regular
Forum Regular
Posts: 1009
Joined: Wed Aug 02, 2006 12:12 pm

I broke APT in MEPIS 12. -- SOLVED


Post by eemaestro » Sat Feb 25, 2017 1:31 pm

I was thinking of calling this APT/Synaptic problems in MEPIS 12, but cut to the chase and chose this title instead.

It started when I installed--or rather, tried to install --the Chrome browser yesterday using APT. APT gave me a missing library message that I ought to have posted here but didn't.

Today I get the following when trying to use APT:

Code: Select all

# apt-get update && apt-get upgrade
Hit http://dl.google.com stable Release.gpg
Hit http://ftp.us.debian.org wheezy Release.gpg                                                    
Get:1 http://ftp.us.debian.org wheezy-updates Release.gpg [1,554 B]                                
Hit http://dl.google.com stable Release                                                            
Get:2 http://ftp.us.debian.org wheezy-backports Release.gpg [1,554 B]                              
Get:3 http://security.debian.org wheezy/updates Release.gpg [1,554 B]                              
Hit http://ftp.us.debian.org wheezy Release                                                        
Get:4 http://security.debian.org wheezy/updates Release [39.0 kB]                                  
Get:5 http://ftp.us.debian.org wheezy-updates Release [155 kB]                                     
Hit http://main.mepis-deb.org mepis12cr Release.gpg                                                
Hit http://dl.google.com stable/main amd64 Packages                                                
Hit http://nl.mxrepo.com mepis-12.0 Release.gpg                                                    
Hit http://main.mepis-deb.org mepis12cr Release                                                    
Get:6 http://ftp.us.debian.org wheezy-backports Release [164 kB]                                   
Hit http://dl.google.com stable/main i386 Packages                                                 
Get:7 http://security.debian.org wheezy/updates/main amd64 Packages [471 kB]                       
Hit http://nl.mxrepo.com mepis-12.0 Release                                                        
Hit http://main.mepis-deb.org mepis12cr/main amd64 Packages                                        
Hit http://ftp.us.debian.org wheezy/main amd64 Packages                                            
Hit http://ftp.us.debian.org wheezy/contrib amd64 Packages                                         
Hit http://main.mepis-deb.org mepis12cr/non-free amd64 Packages                                    
Hit http://nl.mxrepo.com mepis-12.0/main amd64 Packages                                            
Hit http://ftp.us.debian.org wheezy/non-free amd64 Packages                                        
Hit http://ftp.us.debian.org wheezy/main i386 Packages                                             
Hit http://main.mepis-deb.org mepis12cr/main i386 Packages                                         
Hit http://ftp.us.debian.org wheezy/contrib i386 Packages                                          
Hit http://ftp.us.debian.org wheezy/non-free i386 Packages                                         
Hit http://nl.mxrepo.com mepis-12.0/main i386 Packages                                             
Hit http://ftp.us.debian.org wheezy/contrib Translation-en                                         
Hit http://main.mepis-deb.org mepis12cr/non-free i386 Packages                                     
Hit http://ftp.us.debian.org wheezy/main Translation-en                                            
Hit http://ftp.us.debian.org wheezy/non-free Translation-en                                        
Hit http://ftp.us.debian.org wheezy-updates/main amd64 Packages/DiffIndex                          
Get:8 http://security.debian.org wheezy/updates/contrib amd64 Packages [14 B]                      
Get:9 http://ftp.us.debian.org wheezy-updates/contrib amd64 Packages [14 B]                        
Get:10 http://security.debian.org wheezy/updates/non-free amd64 Packages [14 B]                    
Get:11 http://security.debian.org wheezy/updates/main i386 Packages [474 kB]                       
Hit http://ftp.us.debian.org wheezy-updates/non-free amd64 Packages/DiffIndex                      
Hit http://ftp.us.debian.org wheezy-updates/main i386 Packages/DiffIndex                           
Get:12 http://ftp.us.debian.org wheezy-updates/contrib i386 Packages [14 B]                        
Hit http://ftp.us.debian.org wheezy-updates/non-free i386 Packages/DiffIndex                       
Get:13 http://ftp.us.debian.org wheezy-updates/contrib Translation-en [14 B]                       
Hit http://ftp.us.debian.org wheezy-updates/main Translation-en/DiffIndex                          
Ign http://dl.google.com stable/main Translation-en_US                                             
Hit http://ftp.us.debian.org wheezy-updates/non-free Translation-en/DiffIndex                      
Ign http://dl.google.com stable/main Translation-en                                                
Hit http://ftp.us.debian.org wheezy-backports/main amd64 Packages/DiffIndex                        
Hit http://ftp.us.debian.org wheezy-backports/contrib amd64 Packages/DiffIndex                     
Hit http://ftp.us.debian.org wheezy-backports/non-free amd64 Packages/DiffIndex                    
Hit http://ftp.us.debian.org wheezy-backports/main i386 Packages/DiffIndex                         
Hit http://ftp.us.debian.org wheezy-backports/contrib i386 Packages/DiffIndex                      
Hit http://ftp.us.debian.org wheezy-backports/non-free i386 Packages/DiffIndex                     
Hit http://ftp.us.debian.org wheezy-backports/contrib Translation-en/DiffIndex                     
Get:14 http://security.debian.org wheezy/updates/contrib i386 Packages [14 B]                      
Get:15 http://security.debian.org wheezy/updates/non-free i386 Packages [14 B]                     
Get:16 http://security.debian.org wheezy/updates/contrib Translation-en [14 B]                     
Get:17 http://security.debian.org wheezy/updates/main Translation-en [259 kB]                      
Hit http://ftp.us.debian.org wheezy-backports/main Translation-en/DiffIndex                        
Hit http://ftp.us.debian.org wheezy-backports/non-free Translation-en/DiffIndex                    
Get:18 http://security.debian.org wheezy/updates/non-free Translation-en [14 B]                    
Ign http://nl.mxrepo.com mepis-12.0/main Translation-en_US                                       
Ign http://nl.mxrepo.com mepis-12.0/main Translation-en                                            
Ign http://main.mepis-deb.org mepis12cr/main Translation-en_US           
Hit http://main.mepis-deb.org mepis12cr/main Translation-en
Ign http://main.mepis-deb.org mepis12cr/non-free Translation-en_US
Hit http://main.mepis-deb.org mepis12cr/non-free Translation-en
Fetched 1,568 kB in 4s (346 kB/s)
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
root@mepis1:/home/jon# lsf /var/lib/dpkg/*lock*
bash: lsf: command not found
root@mepis1:/home/jon# ls /var/lib/dpkg/*lock*
root@mepis1:/home/jon# ls -Fdltr /var/lib/dpkg/*lock*
-rw-r----- 1 root root 0 Feb 24 19:36 /var/lib/dpkg/lock
root@mepis1:/home/jon# file /var/lib/dpkg/lock 
/var/lib/dpkg/lock: empty
root@mepis1:/home/jon# cat /var/lib/dpkg/lock
root@mepis1:/home/jon# apt-get install -f
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
Synaptic gives me a pop-up dialog box with the error message "Could not upgrade the system! Fix broken packages first."
Does anybody know how to fix broken packages and restore APT to working order?
Last edited by eemaestro on Sat Feb 25, 2017 7:14 pm, edited 1 time in total.

User avatar
Posts: 12556
Joined: Sun Dec 16, 2007 1:17 pm

Re: I broke APT in MEPIS 12.


Post by dolphin_oracle » Sat Feb 25, 2017 1:44 pm

try apt-get install -f and see if that fixing things. its always the first thing i try.
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
Posts: 1829
Joined: Sat Jan 16, 2016 8:20 pm

Re: I broke APT in MEPIS 12.


Post by v3g4n » Sat Feb 25, 2017 2:10 pm

Code: Select all

rm -rf /var/lib/dpkg/lock
apt-get install -f

User avatar
Forum Regular
Forum Regular
Posts: 1009
Joined: Wed Aug 02, 2006 12:12 pm

Re: I broke APT in MEPIS 12.


Post by eemaestro » Sat Feb 25, 2017 7:13 pm

I had tried that last night, dolphin_oracle, but it did not reenable apt-get.
v3g4n, I just did the two commands you suggested, but without the -rf on rm.
It worked! I was able to just now run #apt-get update && apt-get upgrade to completion successfully.
Thank you!

Post Reply

Return to “Mepis 12 Beta”