Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

openshot is broken

Post Reply
Message
Author
User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2532
Joined: Thu May 01, 2014 10:12 am

openshot is broken

#1 Post by mmikeinsantarosa » Mon Nov 23, 2015 6:20 pm

I needed a video editor yesterday and when I went to install openshot from synaptic, it shows up broken. This is true on my 64 bit desktop and a clean 32 bit vm. It does not show up as broken when trying to install on mx14.

Can anybody else confirm this?

Mike
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Joined: Wed Aug 02, 2006 12:12 pm

Re: openshot is broken

#2 Post by eemaestro » Mon Nov 23, 2015 6:56 pm

Code: Select all

# apt-get install openshot
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libfreerdp1 libproxy-tools libqt5xmlpatterns5 libwebp5 libxcb-sync0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gtk2-engines-pixbuf libgoocanvas-common libgoocanvas3 python-httplib2 python-mlt5
  python-pygoocanvas
Suggested packages:
  blender inkscape
Recommended packages:
  openshot-doc frei0r-plugins
The following NEW packages will be installed:
  gtk2-engines-pixbuf libgoocanvas-common libgoocanvas3 openshot python-httplib2 python-mlt5
  python-pygoocanvas
0 upgraded, 7 newly installed, 0 to remove and 4 not upgraded.
Need to get 20.5 MB of archives.
After this operation, 49.1 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ftp.us.debian.org/debian/ wheezy/main gtk2-engines-pixbuf amd64 2.24.10-2 [594 kB]
Get:2 http://ftp.us.debian.org/debian/ wheezy/main libgoocanvas-common all 0.15-1 [40.7 kB]
Get:3 http://ftp.us.debian.org/debian/ wheezy/main libgoocanvas3 amd64 0.15-1 [139 kB]
Get:4 http://ftp.us.debian.org/debian/ wheezy/main python-httplib2 all 0.7.4-2+deb7u1 [61.2 kB]
Get:5 http://ftp.us.debian.org/debian/ wheezy/main python-mlt5 amd64 0.8.0-4 [242 kB]
Get:6 http://ftp.us.debian.org/debian/ wheezy/main python-pygoocanvas amd64 0.14.1-1+b3 [111 kB]
Get:7 http://ftp.us.debian.org/debian/ wheezy/main openshot all 1.4.2-1.1 [19.3 MB]
Fetched 20.5 MB in 15s (1,293 kB/s)
Selecting previously unselected package gtk2-engines-pixbuf:amd64.
dpkg: warning: files list file for package 'xserver-xorg-video-qxl' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'xfsprogs' missing; assuming package has no files currently installed
(Reading database ... 139312 files and directories currently installed.)
Unpacking gtk2-engines-pixbuf:amd64 (from .../gtk2-engines-pixbuf_2.24.10-2_amd64.deb) ...
Selecting previously unselected package libgoocanvas-common.
Unpacking libgoocanvas-common (from .../libgoocanvas-common_0.15-1_all.deb) ...
Selecting previously unselected package libgoocanvas3.
Unpacking libgoocanvas3 (from .../libgoocanvas3_0.15-1_amd64.deb) ...
Selecting previously unselected package python-httplib2.
Unpacking python-httplib2 (from .../python-httplib2_0.7.4-2+deb7u1_all.deb) ...
Selecting previously unselected package python-mlt5.
Unpacking python-mlt5 (from .../python-mlt5_0.8.0-4_amd64.deb) ...
Selecting previously unselected package python-pygoocanvas.
Unpacking python-pygoocanvas (from .../python-pygoocanvas_0.14.1-1+b3_amd64.deb) ...
Selecting previously unselected package openshot.
Unpacking openshot (from .../openshot_1.4.2-1.1_all.deb) ...
Processing triggers for mime-support ...
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Processing triggers for man-db ...
gdbm fatal: read error
Processing triggers for desktop-file-utils ...
Setting up gtk2-engines-pixbuf:amd64 (2.24.10-2) ...
Setting up libgoocanvas-common (0.15-1) ...
Setting up libgoocanvas3 (0.15-1) ...
Setting up python-httplib2 (0.7.4-2+deb7u1) ...
Setting up python-mlt5 (0.8.0-4) ...
Setting up python-pygoocanvas (0.14.1-1+b3) ...
Setting up openshot (1.4.2-1.1) ...
Processing triggers for python-support ...
The GUI pops up when I type openshot at the command line. But it hangs.
Nothing in Openshot's viewport works. Even pkill does not get rid of it. All my other KDE applications
work fine. This is in beta MEPIS 12.0 wheezy 64-bit. Do you want me to check for a log file before I scrap openshot?

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2532
Joined: Thu May 01, 2014 10:12 am

Re: openshot is broken

#3 Post by mmikeinsantarosa » Mon Nov 23, 2015 7:01 pm

eemaestro wrote:The GUI pops up when I type openshot at the command line. But it hangs.
Nothing in Openshot's viewport works. Even pkill does not get rid of it. All my other KDE applications
work fine. This is in beta MEPIS 12.0 wheezy 64-bit. Do you want me to check for a log file before I scrap openshot?
- please dump openshot.
This is what I get from a terminal.

Code: Select all

apt-get install openshot -s
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 openshot : Depends: python-mlt5 but it is not going to be installed or
                     python-mlt3 but it is not installable or
                     python-mlt2 but it is not installable
E: Unable to correct problems, you have held broken packages.
And those python packages turn red when checked in synaptic.
Last edited by mmikeinsantarosa on Mon Nov 23, 2015 7:17 pm, edited 1 time in total.
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2532
Joined: Thu May 01, 2014 10:12 am

Re: openshot is broken

#4 Post by mmikeinsantarosa » Mon Nov 23, 2015 7:04 pm

Maybe a rebuild of openshot with the python-mlt5-0.8.8-2 from sid will fix it...
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 17097
Joined: Fri Dec 15, 2006 8:07 pm

Re: openshot is broken

#5 Post by Stevo » Mon Nov 23, 2015 7:36 pm

This was addressed and fixed some time ago; you'll have to prefer "mepis" in Synaptic or on the command line in MEPIS:

Code: Select all

apt-get install frei0r-plugins openshot -t mepis
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libvncclient0 libvncserver-config
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  python-mlt
Suggested packages:
  blender
Recommended packages:
  openshot-doc frei0r-plugins
The following NEW packages will be installed:
  openshot python-mlt
0 upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/20.6 MB of archives.
After this operation, 60.6 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Selecting previously unselected package python-mlt.
(Reading database ... 443259 files and directories currently installed.)
Unpacking python-mlt (from .../python-mlt_0.9.0-3mcr120+1_amd64.deb) ...
Selecting previously unselected package openshot.
Unpacking openshot (from .../openshot_1.4.4-1mcr120+3_all.deb) ...
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Processing triggers for man-db ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for mime-support ...
Setting up python-mlt (0.9.0-3mcr120+1) ...
Setting up openshot (1.4.4-1mcr120+3) ...
If you don't install frei0r-plugins, an error dialog appears behind the main GUI, which will then appear to be locked up. Perhaps a rebuild to mcr120+4, making frei0r-plugins a hard depends, would be the fix...Mike?

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2532
Joined: Thu May 01, 2014 10:12 am

Re: openshot is broken

#6 Post by mmikeinsantarosa » Mon Nov 23, 2015 8:28 pm

If you don't install frei0r-plugins, an error dialog appears behind the main GUI, which will then appear to be locked up. Perhaps a rebuild to mcr120+4, making frei0r-plugins a hard depends, would be the fix...Mike?
DOH! i just found the openshot_1.4.4-1mcr120+2 in test. I'll hook up those depnds and send it up.

mike
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 17097
Joined: Fri Dec 15, 2006 8:07 pm

Re: openshot is broken

#7 Post by Stevo » Mon Nov 23, 2015 9:45 pm

mmikeinsantarosa wrote:
If you don't install frei0r-plugins, an error dialog appears behind the main GUI, which will then appear to be locked up. Perhaps a rebuild to mcr120+4, making frei0r-plugins a hard depends, would be the fix...Mike?
DOH! i just found the openshot_1.4.4-1mcr120+2 in test. I'll hook up those depnds and send it up.

mike
The latest +3 version is in main, so build a +4 off of that one--which fixed some mlt problems, I think.

Post Reply

Return to “Mepis 12 Beta”