The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Root password not accepted on 3 different machines?!

Post Reply
User avatar
Forum Regular
Forum Regular
Posts: 1052
Joined: Sun Jul 23, 2006 7:51 pm

Root password not accepted on 3 different machines?!


Post by SilverBear » Fri Oct 23, 2015 11:02 pm

Hey, folks. Happy Autumn!

For those who love mysteries, I've got a doozie that I need help solving. I have 3 different machines with Debian-esque distros --all of which have a similar problem.

1] It started with my main desktop box (the MSI-7). Most of the time it runs Debian Jessie, but I can also boot into MX (I'm in that now) and also MS-Win7. (Windows is on a separate SDD from the Linuxes boot HDD, and also from the Data Partitions HDD.)
About a week ago I noticed that polkit refuses to accept the correct root password when I try to install updates via the "apper" update utility. I can run synaptic --the authorization window then accepts the root pw. And I can su into root on the command line.

Nothing I've tried in MX on this box so far seems to be a problem --BUT this is the first time I've run MX since June or July, after I get Jessie installed and customized. I have not actually installed any of the 163 packages now due for updating on MX.

2] Completely different box: the old "Klingon" I built in 2005 and refurbed in 2010. It runs only Mepis 12, no dual-boot. On that machine I can log in as silverbear, but Synaptic's authorization window will not accept the correct root password. Nor can I su into root on the command line in Konsole.

3] Laptop machine "Novi": running dual boot Win7 and Jessie. Windows is fine; Debian 8 acts exactly like Mepis 12 does on the Klingon desktop box.

Maybe I've had it too good lately, and my troubleshooting skills have atrophied! But I am stumped. Since all this has cropped up within the last week or so, with no previous problems, and all relates to a Debian-based KDE distro, I first thought it might be an update to polkit1 that somehow put the Spaniard in the works (as John Lennon would say). Googling every variation I can think of to ferret out "Debian polkit authorization failure" does not get me any hits that describe my strange scenario.

And, I'm thinking, if it were just a Jessie issue, why is my old Mepis 12 (Wheezy-based, right?) on the other box got a similar affliction?

Can anybody point an old bear in the right direction?
"masai7" Intel i7 3770k; 16GB RAM; GeForce GTX-750

User avatar
Forum Veteran
Forum Veteran
Posts: 5918
Joined: Mon Feb 12, 2007 1:45 pm

Re: Root password not accepted on 3 different machines?!


Post by joany » Sat Oct 24, 2015 1:54 pm

The only suggestion I can offer is to boot using a live medium on one of the boxes, reset the root password and see if that corrects the problem. A how-to: http://www.microhowto.info/howto/reset_ ... ution.html
MX-14; 3.12-0.bpo.1-686-pae kernel using 4GB RAM
2.4GHz AMD Athlon 4600+
NVidia GeForce 6150 LE; 304.121 Display Driver
You didn't slow down because you're old; you're old because you slowed down.

User avatar
Posts: 9687
Joined: Wed Jul 12, 2006 2:26 pm

Re: Root password not accepted on 3 different machines?!


Post by kmathern » Sat Oct 24, 2015 2:00 pm

It might have gotten kdesudo-ized, I would just try your regular user password in some of those instances where it's not accepting the root password.

User avatar
Forum Regular
Forum Regular
Posts: 2777
Joined: Sat May 16, 2009 3:59 pm

Re: Root password not accepted on 3 different machines?!


Post by DBeckett » Sat Oct 24, 2015 5:13 pm

I've gotten into this situation several times. Neither my root nor user passwords worked in certain situations.

What has always fixed it for me is removing kdesudo.
Gigabyte 990FXA-UD3, AMD FX-6100 hex-core, 3.3GHz, 8G, Radeon HD6570

Post Reply

Return to “Mepis 12 Beta”