Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MEPIS12 won't boot normally

Message
Author
User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Joined: Wed Aug 02, 2006 12:12 pm

Re: MEPIS12 won't boot normally

#11 Post by eemaestro » Tue Sep 13, 2016 5:12 pm

After fooling around with System....MX Select Sound for awhile, I got actual sound coming out of my left speaker, but not my right one. I guess this means I should buy a new pair of speakers.

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 2049
Joined: Mon Nov 21, 2011 5:50 pm

Re: MEPIS12 won't boot normally

#12 Post by Gordon Cooper » Tue Sep 13, 2016 5:29 pm

eemaestro wrote:After fooling around with System....MX Select Sound for awhile, I got actual sound coming out of my left speaker, but not my right one. I guess this means I should buy a new pair of speakers.
Maybe, maybe not. Fault could be in stereo section of the sound card, or something simple as the output connector. Can you plug headphones in place of the speakers and see what is there?
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9333
Joined: Wed Jul 12, 2006 2:26 pm

Re: MEPIS12 won't boot normally

#13 Post by kmathern » Tue Sep 13, 2016 6:14 pm

eemaestro wrote:After fooling around with System....MX Select Sound for awhile, I got actual sound coming out of my left speaker, but not my right one...
Does this mean you were able to get it to boot to the desktop?

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Joined: Wed Aug 02, 2006 12:12 pm

Re: MEPIS12 won't boot normally

#14 Post by eemaestro » Tue Sep 13, 2016 7:45 pm

kmathern, I booted from the MX 15 Live DVD. I have not been able to boot from the hard drive.
I must get a pair of headphones with two working earphones.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4378
Joined: Wed Jul 12, 2006 4:05 pm

Re: MEPIS12 won't boot normally

#15 Post by timkb4cq » Tue Sep 13, 2016 8:35 pm

You don't need to log in to M12 to run fsck. Running the LiveDVD, open a terminal. Type:
mount
See what device your root partition is mounted from. For the next commands I assume it's /dev/sda1 - correct the next commands as needed.

Code: Select all

sudo umount /dev/sda1
sudo fsck -pv /dev/sda1
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Joined: Wed Aug 02, 2006 12:12 pm

Re: MEPIS12 won't boot normally

#16 Post by eemaestro » Tue Sep 13, 2016 8:50 pm

From MX 15 Live DVD 64-bit:

Code: Select all

root@mx1:/home/demo# ls /dev/
autofs		 hidraw0	   midi1	       sdc1	 tty17	tty37  tty57	vcs4
block		 hpet		   net		       sg0	 tty18	tty38  tty58	vcs5
bsg		 input		   network_latency     sg1	 tty19	tty39  tty59	vcs6
btrfs-control	 kfd		   network_throughput  sg2	 tty2	tty4   tty6	vcs7

bus		 kmsg		   null		       sg3	 tty20	tty40  tty60	vcsa
cdrom		 kvm		   nvram	       shm	 tty21	tty41  tty61	vcsa1
cdrw		 log		   parport0	       snapshot  tty22	tty42  tty62	vcsa2
char		 loop0		   port		       snd	 tty23	tty43  tty63	vcsa3
console		 loop1		   ppp		       sr0	 tty24	tty44  tty7	vcsa4
core		 loop2		   psaux	       stderr	 tty25	tty45  tty8	vcsa5
cpu		 loop3		   ptmx		       stdin	 tty26	tty46  tty9	vcsa6
cpu_dma_latency  loop4		   pts		       stdout	 tty27	tty47  ttyS0	vcsa7
cuse		 loop5		   random	       tty	 tty28	tty48  ttyS1	vfio
disk		 loop6		   rfkill	       tty0	 tty29	tty49  ttyS2	vga_arbiter
dmmidi1		 loop7		   rtc		       tty1	 tty3	tty5   ttyS3	vhci
dri		 loop-control	   rtc0		       tty10	 tty30	tty50  uhid	vhost-net
dvd		 lp0		   sda		       tty11	 tty31	tty51  uinput	xconsole
dvdrw		 MAKEDEV	   sda1		       tty12	 tty32	tty52  urandom	zero
fb0		 mapper		   sda2		       tty13	 tty33	tty53  vcs
fd		 mcelog		   sdb		       tty14	 tty34	tty54  vcs1
full		 mem		   sdb1		       tty15	 tty35	tty55  vcs2
fuse		 memory_bandwidth  sdc		       tty16	 tty36	tty56  vcs3
root@mx1:/home/demo# umount /dev/sda1
umount: /media/demo/99353bf0-65d0-4e1b-9aaf-31ccfdd2e516: target is busy
        (In some cases useful info about processes that
         use the device is found by lsof(8) or fuser(1).)
Last edited by eemaestro on Tue Sep 13, 2016 10:25 pm, edited 1 time in total.

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Joined: Wed Aug 02, 2006 12:12 pm

Re: MEPIS12 won't boot normally

#17 Post by eemaestro » Tue Sep 13, 2016 8:56 pm

OOPS! Found a shell open to the device. Closed it. Tried again

Code: Select all

root@mx1:/home/demo# ls /dev/sda1
/dev/sda1
root@mx1:/home/demo# umount /dev/sda1
umount: /dev/sda1: not mounted
root@mx1:/home/demo# fsck -pvt /dev/sda1
fsck from util-linux 2.25.2
root@mx1:/home/demo# fsck -pv /dev/sda1
fsck from util-linux 2.25.2
/dev/sda1 contains a file system with errors, check forced.
/dev/sda1: Inode 4730315 has a bad extended attribute block 13937.  

/dev/sda1: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
	(i.e., without -a or -p options)
I will run fsck again with just the -v and see if that works.

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Joined: Wed Aug 02, 2006 12:12 pm

Re: MEPIS12 won't boot normally

#18 Post by eemaestro » Tue Sep 13, 2016 9:00 pm

Code: Select all

root@mx1:/home/demo# fsck -v /dev/sda1
fsck from util-linux 2.25.2
e2fsck 1.42.12 (29-Aug-2014)
/dev/sda1 contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Inode 4730315 has a bad extended attribute block 13937.  Clear<y>? yes
Inodes that were part of a corrupted orphan linked list found.  Fix<y>? yes
Inode 4730316 was part of the orphaned inode list.  FIXED.
Inode 4730328 was part of the orphaned inode list.  FIXED.
Inode 4730329 was part of the orphaned inode list.  FIXED.
Inode 4730352 was part of the orphaned inode list.  FIXED.
Inode 4730532 was part of the orphaned inode list.  FIXED.
Inode 4730672 was part of the orphaned inode list.  FIXED.
Deleted inode 4730676 has zero dtime.  Fix<y>? yes
Inode 4730677 was part of the orphaned inode list.  FIXED.
Inode 4730680 was part of the orphaned inode list.  FIXED.
Inode 4730671 has a bad extended attribute block 60857.  Clear<y>? yes
Inode 4730671 has illegal block(s).  Clear<y>? yes
Illegal block #0 (4077518848) in inode 4730671.  CLEARED.
Illegal block #5 (2168782848) in inode 4730671.  CLEARED.
.
.
.
/dev/sda1: ***** FILE SYSTEM WAS MODIFIED *****

      273432 inodes used (1.40%, out of 19472384)
         909 non-contiguous files (0.3%)
         283 non-contiguous directories (0.1%)
             # of inodes with ind/dind/tind blocks: 0/0/0
             Extent depth histogram: 258272/122
     7637303 blocks us
Got it! Thanks for pointing me in the right direction, timkb4cq.
Next I will see if GRUB will now reboot MEPIS12 from the hard drive, after dinner.

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Joined: Wed Aug 02, 2006 12:12 pm

Re: MEPIS12 won't boot normally

#19 Post by eemaestro » Tue Sep 13, 2016 10:29 pm

Okay, yes, that did it. I successfully booted from the hard drive. Thank you, timbkb4cq, for pointing me in the right direction. I will remember that mount without arguments is a crucial source of information.

BTW, I need no earphones. My speakers and soundcard both work fine in stereo under MEPIS 12 64-bit. Just not in MX 15 64-bit.

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 2049
Joined: Mon Nov 21, 2011 5:50 pm

Re: MEPIS12 won't boot normally

#20 Post by Gordon Cooper » Wed Sep 14, 2016 1:44 am

Great news!
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

Post Reply

Return to “Mepis 12 Beta”