Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Overheating Laptop II

If you are having a problem with getting any of your computer's hardware to work with MEPIS or you can't find the right driver, this is the forum to use. It's for newbies and regular users to post questions. Just make sure to post what hardware you are having problems with, in the subject and not just in the post's text area, please.
Post Reply
Message
Author
User avatar
nalerive
Forum Novice
Forum  Novice
Posts: 34
Joined: Sat Jul 27, 2013 10:03 am

Overheating Laptop II

#1 Post by nalerive » Sat Oct 18, 2014 3:58 pm

Hi all,

I recently installed MepisX 14 on my computer (Dell Inspiron 14z, 64-bit). I run into the same issue as last time (see http://forum.mepiscommunity.org/viewtop ... 11&t=34908),
so I run the following commands (see here: http://planetoss.com/articles/how-to-di ... -in-linux/) to disable the discrete AMD graphic card:

Code: Select all

root@nalerive:/home/nalerive# mount -t debugfs none /sys/kernel/debug
root@nalerive:/home/nalerive# cat /sys/kernel/debug/vgaswitcheroo/switch
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Pwr:0000:02:00.0
root@nalerive:/home/nalerive# echo OFF> /sys/kernel/debug/vgaswitcheroo/switch
root@nalerive:/home/nalerive# cat /sys/kernel/debug/vgaswitcheroo/switch
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Off:0000:02:00.0
The discrete card is now switched off. See the results:

BEFORE

Code: Select all

$ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +78.5°C  (crit = +84.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +79.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +79.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +77.0°C  (high = +87.0°C, crit = +105.0°C)

pkg-temp-0-virtual-0
Adapter: Virtual device
temp1:        +79.0°C 

radeon-pci-0200
Adapter: PCI adapter
temp1:        +79.5°C
AFTER

Code: Select all

acpitz-virtual-0
Adapter: Virtual device
temp1:        +49.5°C  (crit = +84.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +52.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +52.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +48.0°C  (high = +87.0°C, crit = +105.0°C)

pkg-temp-0-virtual-0
Adapter: Virtual device
temp1:        +52.0°C  

radeon-pci-0200
Adapter: PCI adapter
temp1:       -128.0°C
Now that I want to have the discrete card disabled at system start-up, the gedit command doesn't work:
root@nalerive:/home/nalerive# gedit /etc/rc.d/rc.local
sudo: gedit: command not found
Then I tried:

Code: Select all

root@nalerive:/home/nalerive# nano /etc/rc.d/rc.local
But I got an empty file.

Then I tried:

Code: Select all

nano /etc/fstab
so that I could add the following line to the file:

Code: Select all

none          /sys/kernel/debug      debugfs        defaults    0      0
I turned off my laptop, turned it on again, and, surprise, surprise, it did not work. So I had to run the echo OFF command again.

Where can I find the rc.local file? (if that is what I actually need). Any advice? (am I doing something wrong?)

Thanks in advanced!

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9351
Joined: Wed Jul 12, 2006 2:26 pm

Re: Overheating Laptop II

#2 Post by kmathern » Sat Oct 18, 2014 4:29 pm

I think you need to add the lines:

Code: Select all

chown <your user name> /sys/kernel/debug/vgaswitcheroo/switch
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
to the /etc/rc.local file instead of /etc/rc.d/rc.local

A /etc/rc.local file does exist on my MX-14 install, I think it has always been there, I don't recall having created it myself.

User avatar
nalerive
Forum Novice
Forum  Novice
Posts: 34
Joined: Sat Jul 27, 2013 10:03 am

Re: Overheating Laptop II

#3 Post by nalerive » Sun Oct 19, 2014 3:30 am

Thanks, kmathern!

I did that, but in the file I have the following:

Code: Select all

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits. 
#
# By default this script does nothing.

 chown <nalerive>> /sys/kernel/debug/vgaswitcheroo/switch
 echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
exit 0
So, what change should I make and where? Because, as it is now, the file is doing nothing.

Thanks!

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9351
Joined: Wed Jul 12, 2006 2:26 pm

Re: Overheating Laptop II

#4 Post by kmathern » Sun Oct 19, 2014 8:43 am

I think you should remove the "<" and ">>" angle brackets surrounding your username.

So it becomes this:

Code: Select all

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits. 
#
# By default this script does nothing.

chown nalerive /sys/kernel/debug/vgaswitcheroo/switch
echo OFF /sys/kernel/debug/vgaswitcheroo/switch
exit 0

User avatar
nalerive
Forum Novice
Forum  Novice
Posts: 34
Joined: Sat Jul 27, 2013 10:03 am

Re: Overheating Laptop II

#5 Post by nalerive » Sun Oct 19, 2014 9:58 am

Image

Problem solved!

Thanks for your time and patience, kmatherm! ;)

Post Reply

Return to “Hardware General”