Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Firefox 67 profile problem [SOLVED]

Post Reply
BV206
Forum Novice
Forum  Novice
Posts: 55
Joined: Sat Mar 09, 2019 11:55 am

Firefox 67 profile problem [SOLVED]

#1

Post by BV206 » Tue May 21, 2019 11:10 am

I like to run Firefox locally in my home folder (no root access to anything) instead of installing the distro versions.

On Xubuntu and MX when I do a fresh install I purge firefox and use the .tar.bz2 file from Mozilla, extract it to ~/firefox, then make .desktop files to launch it. When Mozilla releases a new version it updates itself and I don't have to wait days or weeks for the distros to update it. I can copy the program and profile folders between distros and had no problems until today.

Today when Firefox 67 was released I was using my Xubuntu installation and it updated itself with no issues, so I copied my profile folder and program folder over to my MX live USB installation. This time I had a problem. for some reason on MX it keeps trying to make a new profile. It tells me if I want to copy the old profile I have to get a firefox account and sync the profiles. I have not had that happen before. I wish I would have let it update itself first and see if the same thing happened.

I would be interested if anybody else can duplicate this.
Last edited by BV206 on Mon May 27, 2019 6:16 pm, edited 1 time in total.
HP Pavilion g7 Notebook, AMD A4-3305M, Radeon HD 6480G, 4GB RAM, PNY 240GB SSD, MX-18.2_x64 Live USB

BV206
Forum Novice
Forum  Novice
Posts: 55
Joined: Sat Mar 09, 2019 11:55 am

Re: Firefox 67 profile problem (probably my fault)

#2

Post by BV206 » Tue May 21, 2019 11:25 am

Probably has something to do with this:
https://blog.nightly.mozilla.org/2019/0 ... chitecture
https://support.mozilla.org/en-US/kb/de ... stallation

I gave up and installed FF from the MX repo.
HP Pavilion g7 Notebook, AMD A4-3305M, Radeon HD 6480G, 4GB RAM, PNY 240GB SSD, MX-18.2_x64 Live USB

dwaynepa
Forum Novice
Forum  Novice
Posts: 5
Joined: Tue Apr 02, 2019 10:24 am

Re: Firefox 67 profile problem (probably my fault)

#3

Post by dwaynepa » Wed May 22, 2019 12:42 pm

I am having the same problem. I am moving a users data from a Mint Box to a MX Box. Both the same version of FF. I refuse to upload anything to the cloud. So there is no way to locally make the existing profile work? But the version in the Repo will work? What about when it updates?

sunrat
Forum Regular
Forum Regular
Posts: 509
Joined: Mon Mar 28, 2016 9:54 pm

Re: Firefox 67 profile problem (probably my fault)

#4

Post by sunrat » Wed May 22, 2019 6:49 pm

Try this from a console and point it to the profile you want to use:

Code: Select all

firefox -profilemanager
Another way is to let Firefox create a new profile and then copy the contents of the profile folder (not the folder itself) and overwrite the contents of the new profile folder.
Also,if you have a profile in place in ~/.mozilla before you start Firefox the first time, it should just use that.

BV206
Forum Novice
Forum  Novice
Posts: 55
Joined: Sat Mar 09, 2019 11:55 am

Re: Firefox 67 profile problem (probably my fault)

#5

Post by BV206 » Wed May 22, 2019 11:28 pm

sunrat wrote:
Wed May 22, 2019 6:49 pm
Try this from a console and point it to the profile you want to use:

Code: Select all

firefox -profilemanager
Another way is to let Firefox create a new profile and then copy the contents of the profile folder (not the folder itself) and overwrite the contents of the new profile folder.
Also,if you have a profile in place in ~/.mozilla before you start Firefox the first time, it should just use that.
I saw that on Mozilla's support site and it does NOT work.
It used to be you could copy profiles (made by the exact same version of Firefox) between computers, or distros on different drives or partitions, with no problems. Firefox would not know the difference. Now this is no longer true.

If you start firefox without a ~/.mozilla folder it now makes two profiles. one of them is empty except for one file called times.json.

I tried copying the whole ~/.mozilla folder, just the profile folder, and just the contents of the profile folder. I also tried starting firefox -P and firefox -profilemanager and trying to rename or choose a default profile. Nothing works. It gives you warnings about using an older version which is BS because the profile was created by the same version.

It isn't limited to MX either I have the same problem on Xubuntu 18.04.

At first I thought this was something I broke but it's a Mozilla problem.
HP Pavilion g7 Notebook, AMD A4-3305M, Radeon HD 6480G, 4GB RAM, PNY 240GB SSD, MX-18.2_x64 Live USB

User avatar
JayM
Qualified MX Guide
Posts: 2132
Joined: Tue Jan 08, 2019 4:47 am

Re: Firefox 67 profile problem (probably my fault)

#6

Post by JayM » Wed May 22, 2019 11:48 pm

sunrat wrote:
Wed May 22, 2019 6:49 pm
Another way is to let Firefox create a new profile and then copy the contents of the profile folder (not the folder itself) and overwrite the contents of the new profile folder.
That's what I always do and it works fine. I've noticed that sometimes Firefox has created more than one profile for some reason, and as I don't know which of them it's actually using I just copy the contents of my backed-up profile into all of them under $HOME/.mozilla/firefox, with Firefox not running. Then the next time I start it all of my preferences, bookmarks, etc. are there.

I just looked and I currently have two profiles, one labeled "default" so I imagine that's the one Firefox is currently using. I must have created a new profile at some point then switched back to the original one, though I don't remember having done so recently.
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

BV206
Forum Novice
Forum  Novice
Posts: 55
Joined: Sat Mar 09, 2019 11:55 am

Re: Firefox 67 profile problem (probably my fault)

#7

Post by BV206 » Sun May 26, 2019 10:06 am

I figured out how to fix this. Here is an article about it.
https://www.bleepingcomputer.com/news/s ... oss-fears/

What I have to do when copying my profile from Xubuntu to MX live USB is set Firefox to use the old profile as the article says. When I restart Firefox it uses the correct profile but my extension icons do not appear in the toolbar.
I discovered that if I disable the extensions, restart Firefox, enable the extensions and restart Firefox again the extension icons return. I can then delete the new empty profile and it looks as if everything works the same as before.
HP Pavilion g7 Notebook, AMD A4-3305M, Radeon HD 6480G, 4GB RAM, PNY 240GB SSD, MX-18.2_x64 Live USB

Post Reply

Return to “Software / Configuration”