Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Login Manager bug? Correct user and root credentials!

Message
Author
Mich-C
Forum Novice
Forum  Novice
Posts: 48
Joined: Tue Nov 21, 2017 1:11 pm

Re: Login Manager bug? Correct user and root credentials!

#11 Post by Mich-C » Sun Nov 04, 2018 8:05 pm

dolphin_oracle wrote:
Sat Nov 03, 2018 8:23 pm
Another thing to check is the permissions of your users home folder and make sure your user is still the owner.
ls -ld

Code: Select all

drwx------ 21 root root 4096 Nov 5 00:17 
ls-ld /

Code: Select all

drwxrwxrwx 22 root root 4096 nov 3 00:18

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9655
Joined: Sun Dec 16, 2007 1:17 pm

Re: Login Manager bug? Correct user and root credentials!

#12 Post by dolphin_oracle » Sun Nov 04, 2018 8:51 pm

Is that the root folder or the user's home folder? If that's the users folder then the root ownership is the problem.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

Mich-C
Forum Novice
Forum  Novice
Posts: 48
Joined: Tue Nov 21, 2017 1:11 pm

Re: Login Manager bug? Correct user and root credentials!

#13 Post by Mich-C » Mon Nov 05, 2018 12:47 pm

dolphin_oracle wrote:
Sun Nov 04, 2018 8:51 pm
Is that the root folder or the user's home folder? If that's the users folder then the root ownership is the problem.
Thank you for the reply :) Yes, I believe you're right, I'm not sure so I post here some outputs

I logged in as user (michele):

Code: Select all

michele@michele:~
Immediately after ls :

Code: Select all

Documenti Immagini Musica Video Modelli Scrivania and so on...
and ls -ld :

Code: Select all

drwxr-xr-x 57 root root 4096 nov 4 00:59
Then I also done cd / and ls :

Code: Select all

bin boot build dev etc home lib lib64 media mnt opt proc root run sbin srv sys tmp usr var
and ls-ld showed

Code: Select all

drwxrwxrwx 22 root root 4096 no  3 00:18

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9655
Joined: Sun Dec 16, 2007 1:17 pm

Re: Login Manager bug? Correct user and root credentials!

#14 Post by dolphin_oracle » Mon Nov 05, 2018 1:05 pm

thanks for the clarifications

for this, we are only interested in the "michele" home folder.

so try this:
sudo chown -R michele:michele /home/michele
that should change the ownership for everything inside and including the home folder back to michele:michele instead of root:root (the format being USER:GROUP).

reboot and see if you can log in.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

Mich-C
Forum Novice
Forum  Novice
Posts: 48
Joined: Tue Nov 21, 2017 1:11 pm

Re: Login Manager bug? Correct user and root credentials!

#15 Post by Mich-C » Mon Nov 05, 2018 8:34 pm

dolphin_oracle wrote:
Mon Nov 05, 2018 1:05 pm
so try this:
sudo chown -R michele:michele /home/michele
Many many thanks dolphin_oracle! :)
Now each time I boot I got directly my desktop (I set MX to autologin when I installed it, so it's ok)
The problem is that now I have a lot of little problems.. some of them:
---file manager doesn't see my usb pendrives/hdds
---wifi not working
---xfce volume popup at the top right corner of the screen continously refreshing
---shutdown, standby and hibernation buttons are disables, I can only use the exit button but I don't get lightdm
...

I believe that I done something wrong from sudo-thunar the other day when I tryed to change permissions and ownerships to fix the lightdm loop :bawling:
Now I just booted MX in "systemd" mode from grub and most of these problems not seem to be there, it's strange :confused: but here's an example of error that is present also in systemd mode

Code: Select all

opera

[4269:4269:1106/010531.801724:FATAL:setuid_sandbox_host.cc(158)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /usr/lib/x86_64-linux-gnu/opera/opera_sandbox is owned by root and has mode 4755.
Istruction not allowed
I believe that my system still presents a problem about permissions and root/user ownerhip.
Would you (or other users) be so kind to help me fixing it to fix the entire system?

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9655
Joined: Sun Dec 16, 2007 1:17 pm

Re: Login Manager bug? Correct user and root credentials!

#16 Post by dolphin_oracle » Mon Nov 05, 2018 8:46 pm

if you've modified permissions elsewhere in the filesystem, and you don't know what you did, its probably faster to reinstall.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: Login Manager bug? Correct user and root credentials!

#17 Post by fehlix » Mon Nov 05, 2018 9:06 pm

Mich-C wrote:
Mon Nov 05, 2018 8:34 pm
I done something .... from sudo-thunar the other day ..
Yes, that's a cool killer-feature :alien:

You shall better reinstall now
:anispider2:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Mich-C
Forum Novice
Forum  Novice
Posts: 48
Joined: Tue Nov 21, 2017 1:11 pm

Re: Login Manager bug? Correct user and root credentials!

#18 Post by Mich-C » Tue Nov 06, 2018 6:07 pm

dolphin_oracle wrote:
Mon Nov 05, 2018 8:46 pm
its probably faster to reinstall.
fehlix wrote:
Mon Nov 05, 2018 9:06 pm
Yes, that's a cool killer-feature :alien:

You shall better reinstall now
:anispider2:
Thank you, I'll do this! I'll delete everything from this partition except my eclipse and android studio folders (dozens of GBs) so I'll continue to use this partition as a partition for my data and I'll install MX on a new Partition :happy:

Post Reply

Return to “Software / Configuration”