Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Screen/window tearing with compositor

Post Reply
Message
Author
User avatar
ekeimaja
Forum Novice
Forum  Novice
Posts: 43
Joined: Fri May 25, 2018 6:43 pm

Screen/window tearing with compositor

#1 Post by ekeimaja » Sun Oct 14, 2018 5:57 am

I have had compton enabled from beginning of using MX. But it caused vertical tearing line when scrolling browser window and also when playing in middle or above at screen. Now when I disabled composition, this kind of tearing line is gone, but all windows get completely teared when moving the window and also movement applies a few ms later than actual mouse movement. So is there any fix for this, or do I just need to disable composition before playing?
Last edited by ekeimaja on Mon Oct 15, 2018 8:46 am, edited 2 times in total.
Desktop: AMD FX-4350, 12 Gb RAM, NVIDIA GTX660 (MX Linux-17.1)
Laptops: Asus R510L, Intel i5-4200U, 8Gb RAM, Nvidia GeForce 820M & Intel HD Graphics 4400 (Debian 8)
Asus Eee 1005P, Intel Atom N450, 2 Gb RAM, Intel GMA3150 (MX Linux-17.1)

User avatar
KernSpy
Forum Regular
Forum Regular
Posts: 625
Joined: Wed Nov 05, 2014 10:09 pm

Re: Screen/window tearing with compositor

#2 Post by KernSpy » Sun Oct 14, 2018 8:42 pm

What is your hardware?
MX-17.1_x64 | System76 Galago UltraPro / Clevo W740SU | Intel Core i7-4770HQ | Intel Iris Pro Graphics 5200 | 16 GB DDR3 | Intel 530 series mSATA SSD - 240-GB | WD7500BPKX - 750-GB | Intel HD Audio. Note: [System76] and the Galago's neutered UEFI

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6094
Joined: Wed Jul 12, 2006 2:10 am

Re: Screen/window tearing with compositor

#3 Post by Eadwine Rose » Mon Oct 15, 2018 1:37 am

*points to the poster's signature*

Can you also post the output of MX Tools - Quick system info?
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

User avatar
KoO
Forum Regular
Forum Regular
Posts: 301
Joined: Fri Feb 10, 2017 1:21 am

Re: Screen/window tearing with compositor

#4 Post by KoO » Mon Oct 15, 2018 2:15 am

One thing you could try is Nvidia settings >X Server Display Configuration > Force Full Composition Pipeline (tick box then Apply). May Help?

Also have a look at this post.

viewtopic.php?f=97&t=41878
AntiX 17.2 (4.18.7) i3 ,Windows8.1 , Intel Xeon E3-1241 v3 , 16gb HyperX , Samsung EVO 860 500 GB , Samsung EVO 860 500 GB , GTX 970
Lenovo T430 AntiX17.2 (4.18.7) i3 ,MX17 ,Windows8.1 , i5 +4000 , 8gb , Samsung EVO 860 500 GB , 1TB HGST

User avatar
ekeimaja
Forum Novice
Forum  Novice
Posts: 43
Joined: Fri May 25, 2018 6:43 pm

Re: Screen/window tearing with compositor

#5 Post by ekeimaja » Mon Oct 15, 2018 2:42 am

My inxi report is like this:

Code: Select all

Graphics:
  Device-1: NVIDIA GK106 [GeForce GTX 660] driver: nvidia v: 384.130 
  Display: x11 server: X.Org 1.19.2 driver: none unloaded: nvidia 
  resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 660/PCIe/SSE2 v: 4.5.0 NVIDIA 384.130 
I also enabled thet full composition, and now when playing the tearing line still appears, but not so clearly as before.
Desktop: AMD FX-4350, 12 Gb RAM, NVIDIA GTX660 (MX Linux-17.1)
Laptops: Asus R510L, Intel i5-4200U, 8Gb RAM, Nvidia GeForce 820M & Intel HD Graphics 4400 (Debian 8)
Asus Eee 1005P, Intel Atom N450, 2 Gb RAM, Intel GMA3150 (MX Linux-17.1)

User avatar
ekeimaja
Forum Novice
Forum  Novice
Posts: 43
Joined: Fri May 25, 2018 6:43 pm

Re: Screen/window tearing with compositor

#6 Post by ekeimaja » Mon Oct 15, 2018 8:49 am

Now I tried that custom compton start. There is still some tearing which is visible at least when taking a screenshot and it is still lagging when moving windows fastly. Also the fps in game(s) dropped drastically.
Desktop: AMD FX-4350, 12 Gb RAM, NVIDIA GTX660 (MX Linux-17.1)
Laptops: Asus R510L, Intel i5-4200U, 8Gb RAM, Nvidia GeForce 820M & Intel HD Graphics 4400 (Debian 8)
Asus Eee 1005P, Intel Atom N450, 2 Gb RAM, Intel GMA3150 (MX Linux-17.1)

Post Reply

Return to “Software / Configuration”