Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Image thumbnails go grey after editing

Post Reply
Message
Author
User avatar
ekeimaja
Forum Novice
Forum  Novice
Posts: 43
Joined: Fri May 25, 2018 6:43 pm

Image thumbnails go grey after editing

#1 Post by ekeimaja » Sun Sep 23, 2018 7:12 am

When I save screenshot or image, its thumbnail is normal. However, if I edit that picture (I use Kolourpaint4) its thumbnail goes to grey except top as seen in this screenshot:

Image

Is this known bug or does this have any solution?
Desktop: AMD FX-4350, 12 Gb RAM, NVIDIA GTX660 (MX Linux-17.1)
Laptops: Asus R510L, Intel i5-4200U, 8Gb RAM, Nvidia GeForce 820M & Intel HD Graphics 4400 (Debian 8)
Asus Eee 1005P, Intel Atom N450, 2 Gb RAM, Intel GMA3150 (MX Linux-17.1)

User avatar
LnoyBoy
Forum Regular
Forum Regular
Posts: 104
Joined: Fri Jul 14, 2006 2:39 am

Re: Image thumbnails go grey after editing

#2 Post by LnoyBoy » Sun Sep 23, 2018 1:53 pm

For me, sometimes Kolourpaint will not open files that Screenshot saved as .png.

I never figured out why. I open the files with GIMP, and save (export) them as either .jpg or .bmp.

Not sure if this is the same issue though.

Hope this helps.

User avatar
ekeimaja
Forum Novice
Forum  Novice
Posts: 43
Joined: Fri May 25, 2018 6:43 pm

Re: Image thumbnails go grey after editing

#3 Post by ekeimaja » Sun Sep 23, 2018 4:00 pm

Now I tested with GIMP and thumbnail changes as it should without going grey. Also if I open and save grey'ed image in GIMP, thumbnail is fixed to normal. Should I enable RDE services since Kolourpaint is KDE-based?
Desktop: AMD FX-4350, 12 Gb RAM, NVIDIA GTX660 (MX Linux-17.1)
Laptops: Asus R510L, Intel i5-4200U, 8Gb RAM, Nvidia GeForce 820M & Intel HD Graphics 4400 (Debian 8)
Asus Eee 1005P, Intel Atom N450, 2 Gb RAM, Intel GMA3150 (MX Linux-17.1)

User avatar
LnoyBoy
Forum Regular
Forum Regular
Posts: 104
Joined: Fri Jul 14, 2006 2:39 am

Re: Image thumbnails go grey after editing

#4 Post by LnoyBoy » Sun Sep 23, 2018 4:21 pm

Sorry, don't know the answer to that question.

My opinion is, that it's a Screenshot issue, NOT a Kolourpaint issue. As Kolourpaint does fine with .pngs created from any other source. It just doesn't like .pngs created with Screenshot.

On older versions of Screenshot, you could save as .jpgs or .bmps, and Kolourpaint didn't have a problem with them. On my current install, .png is my only option.

User avatar
ekeimaja
Forum Novice
Forum  Novice
Posts: 43
Joined: Fri May 25, 2018 6:43 pm

Re: Image thumbnails go grey after editing

#5 Post by ekeimaja » Sat Sep 29, 2018 7:25 pm

And now I noticed that one thumbnail of unmodified screenshot was a view from website which on I never have taken a screenshot. This starts to go really interesting. :hmm:
Desktop: AMD FX-4350, 12 Gb RAM, NVIDIA GTX660 (MX Linux-17.1)
Laptops: Asus R510L, Intel i5-4200U, 8Gb RAM, Nvidia GeForce 820M & Intel HD Graphics 4400 (Debian 8)
Asus Eee 1005P, Intel Atom N450, 2 Gb RAM, Intel GMA3150 (MX Linux-17.1)

Post Reply

Return to “Software / Configuration”