Welcome!
Important information
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-18 Final release info here
-- Migration Information to MX-18 here
-- antiX-17.3 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

How can I deactivte my Bluetooth applet?

Post Reply
User avatar
c4os
Forum Novice
Forum  Novice
Posts: 64
Joined: Tue Jun 19, 2018 12:28 pm

How can I deactivte my Bluetooth applet?

#1

Post by c4os » Sun Sep 16, 2018 9:28 am

Hi folks,

why I don't need so often I want to deactivate my Bluetooth applet.
In terminal it works fine with "rfkill block bluetooth".
So I added it's to the /etc/rc.local file, but it wont work.
Also with .bashrc or .profile wont work.

Next I created a desktop file called Bluetooth-stop.desktop with the content below and placed it's to the folder $HOME/.config/autostart.
The Bluetooth disabler itself works fine from menu, when I add it's to $HOME/local/applications.

Code: Select all

[Desktop Entry]
Type=Application
Name=Bluetooth disabler
Comment=deactivates Bluetooth service
Exec=/usr/sbin/rfkill block bluetooth
Icon=blueman
#Terminal=true
Type=Application
#Categories=ConsoleOnly;Utility;
Keywords=theme switch tool;console;
Additionally I removed the file $HOME/.config/autostart/Blueman-start.desktop.

Non of them works for me.

Is there a special trick to deactivate the bluetooth?
Powered on: MX 17 Horizon x86_64
Hardware: Dell Latitude E4300 - CPU: Intel Core 2 Duo P9600 (2) @ 2.535GHz - Memory: 4GB
Style: Resolution: 1280x800 - WM Theme: Balou - Theme: Blackbird [GTK2/3] - Icons: Papirus-Dark [GTK2]

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2683
Joined: Wed Apr 11, 2018 5:09 pm

Re: How can I deactivte my Bluetooth applet?

#2

Post by fehlix » Sun Sep 16, 2018 9:59 am

c4os wrote:
Sun Sep 16, 2018 9:28 am
Additionally I removed the file $HOME/.config/autostart/Blueman-start.desktop.
Removing within user's autostart folder will still left enabled system start-entries

You might better check Settings-> Session Startup and deactivate bluethooth related Start-entries here.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
c4os
Forum Novice
Forum  Novice
Posts: 64
Joined: Tue Jun 19, 2018 12:28 pm

Re: How can I deactivte my Bluetooth applet?

#3

Post by c4os » Sun Sep 16, 2018 10:11 am

fehlix wrote:
Sun Sep 16, 2018 9:59 am
c4os wrote:
Sun Sep 16, 2018 9:28 am
Additionally I removed the file $HOME/.config/autostart/Blueman-start.desktop.
Removing within user's autostart folder will still left enabled system start-entries

You might better check Settings-> Session Startup and deactivate bluethooth related Start-entries here.
There's a option at Session Startup for disabling Bluetooth-Applet.
But I don't want to disable the applet. I want to keep the applet at the tray, only want it's deactivated.
Because Bluetooth shows of at the deactivated applet and I can it turn on if I want.
How can I turn it on if the applet is disabled (not at the tray)?
Powered on: MX 17 Horizon x86_64
Hardware: Dell Latitude E4300 - CPU: Intel Core 2 Duo P9600 (2) @ 2.535GHz - Memory: 4GB
Style: Resolution: 1280x800 - WM Theme: Balou - Theme: Blackbird [GTK2/3] - Icons: Papirus-Dark [GTK2]

User avatar
tascoast
Forum Guide
Forum Guide
Posts: 1100
Joined: Sat Aug 06, 2011 4:58 am

Re: How can I deactivte my Bluetooth applet?

#4

Post by tascoast » Sun Sep 16, 2018 3:29 pm

Is Turn Bluetooth Off/on in the blueman panel notification icon menu (default right-click of mouse) not suitable for your requirements?

I believe there may be a desktop keyboard shortcut, or switch on laptop computers available too.
Lenovo ThinkCentre A58 4GBRAM (64-bit), MX17/MX-16/antiX17/Mint 19

User avatar
c4os
Forum Novice
Forum  Novice
Posts: 64
Joined: Tue Jun 19, 2018 12:28 pm

Re: How can I deactivte my Bluetooth applet?

#5

Post by c4os » Tue Sep 18, 2018 6:52 am

tascoast wrote:
Sun Sep 16, 2018 3:29 pm
Is Turn Bluetooth Off/on in the blueman panel notification icon menu (default right-click of mouse) not suitable for your requirements?

I believe there may be a desktop keyboard shortcut, or switch on laptop computers available too.
Yes it is. That my current solution.
Powered on: MX 17 Horizon x86_64
Hardware: Dell Latitude E4300 - CPU: Intel Core 2 Duo P9600 (2) @ 2.535GHz - Memory: 4GB
Style: Resolution: 1280x800 - WM Theme: Balou - Theme: Blackbird [GTK2/3] - Icons: Papirus-Dark [GTK2]

User avatar
daleq
Forum Novice
Forum  Novice
Posts: 2
Joined: Thu Jan 10, 2019 11:45 pm

Re: How can I deactivte my Bluetooth applet?

#6

Post by daleq » Thu Jan 10, 2019 11:58 pm

First, THANKS! to all that make MX possible. I've been using for a couple of weeks and am really appreciating how well everything works!

This is a tiny nit, but I too am interested in having bluetooth be "off" until I purposely turn it on (which will be almost never). I understand it's easy to right-click and "Turn BlueTooth off", but I'm lazy... :-)

I presume this would save a tiny bit of battery and be a tiny bit more secure.

But really, MX is very, very lovely and I'm so glad to be using it. Thanks again!
Dale

Post Reply

Return to “Software / Configuration”