Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOlved] Annoying Problem With Mouse cursor in Xfce (Mx Linux)

Post Reply
Message
Author
User avatar
vamsi
Forum Regular
Forum Regular
Posts: 433
Joined: Thu Apr 13, 2017 2:50 am

[SOlved] Annoying Problem With Mouse cursor in Xfce (Mx Linux)

#1 Post by vamsi » Thu Aug 02, 2018 7:00 am

Event hough i change my cursor in xfce and after i shutdown and login into my PC the changed cursor is gone and default cursor appears everytime to solve this i tried to edit /etc/environment and added

Code: Select all

XCURSOR_THEME="Capitaine Cursors"
For few days it worked and now it is again back when i open VLC or MX Package installer the Default icon cursor shows yeah i placed the cursor theme in the root directory of cursors and it happens

Although it is XFCE bug anybody found a way to solve this

Thanks. :happy:
Last edited by vamsi on Sat Aug 04, 2018 8:40 am, edited 1 time in total.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1695
Joined: Wed Apr 11, 2018 5:09 pm

Re: Annoying Problem With Mouse cursor in Xfce (Mx Linux)

#2 Post by fehlix » Thu Aug 02, 2018 8:37 am

vamsi wrote:
Thu Aug 02, 2018 7:00 am
Even though i change my cursor in xfce and after i shutdown and login into my PC the changed cursor is gone ...
It works for me in MX-17.1 XFCE. I have installed as follows:
To make the new cursor theme "Capitaine Cursors" available also for apps
running with system priveledges like " MX Package Installer" I do
create a new folder like this:

Code: Select all

sudo mkdir /usr/share/icons/capitaine-cursors
and extract the "Capitaine Cursors" themes archive
into this newly created folder /usr/share/icons/capitaine-cursors
Further I do copy index.theme to cursor.theme like this:

Code: Select all

sudo cp /usr/share/icons/capitaine-cursors/index.theme /usr/share/icons/capitaine-cursors/cursor.theme
From within "Mouse and Touchpad" settings I do select the new "Capitaine Cursors" theme.
cursur-theme.png
The cursor theme is now available also for all system-apps and stays after reboot.
:puppy:
You do not have the required permissions to view the files attached to this post.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
vamsi
Forum Regular
Forum Regular
Posts: 433
Joined: Thu Apr 13, 2017 2:50 am

Re: Annoying Problem With Mouse cursor in Xfce (Mx Linux)

#3 Post by vamsi » Thu Aug 02, 2018 9:26 am

fehlix wrote:
Thu Aug 02, 2018 8:37 am
vamsi wrote:
Thu Aug 02, 2018 7:00 am
Even though i change my cursor in xfce and after i shutdown and login into my PC the changed cursor is gone ...
It works for me in MX-17.1 XFCE. I have installed as follows:
To make the new cursor theme "Capitaine Cursors" available also for apps
running with system priveledges like " MX Package Installer" I do
create a new folder like this:

Code: Select all

sudo mkdir /usr/share/icons/capitaine-cursors
and extract the "Capitaine Cursors" themes archive
into this newly created folder /usr/share/icons/capitaine-cursors
Further I do copy index.theme to cursor.theme like this:

Code: Select all

sudo cp /usr/share/icons/capitaine-cursors/index.theme /usr/share/icons/capitaine-cursors/cursor.theme
From within "Mouse and Touchpad" settings I do select the new "Capitaine Cursors" theme.
cursur-theme.png
The cursor theme is now available also for all system-apps and stays after reboot.
:puppy:
Actually i did this when i open the root folder the capataine cursor works fine but not working in MXPI no matter what i change it is not working in MX tools also kind of weird

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1695
Joined: Wed Apr 11, 2018 5:09 pm

Re: Annoying Problem With Mouse cursor in Xfce (Mx Linux)

#4 Post by fehlix » Thu Aug 02, 2018 9:37 am

I have verfied on a freshly installed MX17.1_June system and it workes for me as desired
including VLC and all MX Tools.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

boombaby
Forum Novice
Forum  Novice
Posts: 65
Joined: Fri Jul 27, 2018 1:41 am

Re: Annoying Problem With Mouse cursor in Xfce (Mx Linux)

#5 Post by boombaby » Thu Aug 02, 2018 7:31 pm

Hello, vamsi, fehlix, et al...

I, too, can confirm the problem as discribed by vamsi. That is, if I change the mouse cursor to LARGER size it always reverts back to default size.

I manage the cursor modification through Control Centre > Appearance > Theme (choice) > Customize (button) > Pointer (tab) << and then choose size. Change "applies" properly at that point, but later it always reverts back to default size. (This occurs within the same session, or even if I save it and immediately logout or reboot.)

This oddity occurs with my current theme, Green Submarine, and every other theme that I tried.

[Side comment on mouse/cursor adjustment: I think alteration to cursor size should be done under "Input Devices" > Mouse. From a User point (no pun intended) of view that seems a more logical goto place, with the other being "counter-intuitive", but I suppose the Developers have their reasons for the current method (no pun intended). (Perhaps access via both locations would be better for Users?) ]

N.B.
1.
I tend to use the GUI interface for everything. For me, delving into CLI is a rarity, and usually only for desperate measures. In fact, if a distro requires too much CLI then I ditch it. (No offence to the Sticklers. Hey; remember "DOS"?)

2.
As mentioned in another post I used to use xfce desktop but then added MATE into my setup (without removing xfce components) and now use it exclusively. So perhaps something in my config is relevant to this "problem" (as described by, both, vamsi and me) given that vamsi uses xfce. [However I doubt that last point (no pun intended) at this point (pun optional).]

So I am interested in the outcome of this thread.


Regards,
boombaby

User avatar
JmaCWQ
Forum Novice
Forum  Novice
Posts: 50
Joined: Fri Sep 09, 2016 4:42 am

Re: Annoying Problem With Mouse cursor in Xfce (Mx Linux)

#6 Post by JmaCWQ » Fri Aug 03, 2018 2:27 am

I had similar to this happen with XFCE a couple of years ago on another distro.
The mouse cursor would revert to default within different program's windows (only some not all) & even just mousing over their window buttons it would change.

I found the following stopped it at the time:
Just before a restart with no other programs open, set the mouse to the desired cursor scheme, size etc. via the Mouse and Touchpad settings.
Then open Session and Startup settings, on the general tab under Logout Settings check 'Automatically save session on logout', click Close.
If it's already checked uncheck it, click close, open Session and Startup settings again, check it, click Close.
Restart.

:toast:

skidoo
Forum Regular
Forum Regular
Posts: 862
Joined: Tue Sep 22, 2015 6:56 pm

Re: Annoying Problem With Mouse cursor in Xfce (Mx Linux)

#7 Post by skidoo » Fri Aug 03, 2018 2:09 pm

"not working in MXPI no matter what i change it is not working in MX tools"
. . .
"(some not all)"
Possibly confusing for someone migrating to MX from ubuntu: On MX and antiX systems, a "really real" root user login account exists.
Separate recently-used documents list, app preferences, and theming / icon / cursor preferences exist specific to the root user account.

When a root-permissioned instance of an app is launched, the launcher should be (but might not always be) crafted to preserve the logged-in user's environment / preferences.

Toward revising launcher commandstrings to eliminate any inconsistent or different-from-expected results, reporters probably need to provide nitty-gritty details:
here's EXACTLY what I did, step-by-step... what I clicked (launcher in menu? on desktop? in panel? typed something in terminal?)
(vs "some not all" or "no matter what I change")

User avatar
Mauser
Forum Regular
Forum Regular
Posts: 632
Joined: Mon Jun 27, 2016 7:32 pm

Re: Annoying Problem With Mouse cursor in Xfce (Mx Linux)

#8 Post by Mauser » Fri Aug 03, 2018 3:03 pm

This is a strange anomaly. I had different issues with the mouser cursor but nothing like that is described in this thread. Changing the settings corrected the sticky mouse cursor that I was experiencing. I have and am using different theming than all of you. I get my theming out of Synaptic and most out of xfce-look.org. I am currently using Windows10-Optimized with Win10 icons. If you are not getting your theming from those 2 sources then it might be a theming problem. If not, then theming has nothing to do with it. My mouse cursor size stays the size and theme it is.

boombaby
Forum Novice
Forum  Novice
Posts: 65
Joined: Fri Jul 27, 2018 1:41 am

Re: Annoying Problem With Mouse cursor in Xfce (Mx Linux)

#9 Post by boombaby » Fri Aug 03, 2018 10:54 pm


Hello, vamsi...


I worked out my "solution" to the mouse thingy (in MATE).

In Control Centre choose Appearance (under "Look & Feel" section) and select a Theme.

Click on the Customize button.

For my requirement (to adjust mouse-pointer size) I clicked on the "Interface" tab and adjusted the size.

Then comes the tricky part. (Well, it was for me - so don't laugh!)

Once a change has been made to the theme it becomes a "custom" theme so you have to give it a name and "Save" it. (Like I said, don't laugh.)

Now it shows up in the list of themes as as your own "Custom Theme".

It sticks too.

COMMENT on procedure...
To change the pointer size, the location of it (to me) seems a bit counter-intuitive, AND ALSO the saving part seems unnecessary. Ok, OK; so that's how MX does it. Ok! I get it.


vamsi, there is the "saving" issue there that may apply to your difficulty in xfce. Give it a shot.


Regards,
boombaby

User avatar
vamsi
Forum Regular
Forum Regular
Posts: 433
Joined: Thu Apr 13, 2017 2:50 am

Re: Annoying Problem With Mouse cursor in Xfce (Mx Linux)

#10 Post by vamsi » Sat Aug 04, 2018 8:40 am

JmaCWQ wrote:
Fri Aug 03, 2018 2:27 am
I had similar to this happen with XFCE a couple of years ago on another distro.
The mouse cursor would revert to default within different program's windows (only some not all) & even just mousing over their window buttons it would change.

I found the following stopped it at the time:
Just before a restart with no other programs open, set the mouse to the desired cursor scheme, size etc. via the Mouse and Touchpad settings.
Then open Session and Startup settings, on the general tab under Logout Settings check 'Automatically save session on logout', click Close.
If it's already checked uncheck it, click close, open Session and Startup settings again, check it, click Close.
Restart.

:toast:
First i tried this and didn't worked because i didn't removed /etc/environment line and i removed it and did as you said now it works i think i did like this before once on MX-16 but after some days it became normal. So i think this time it will fix.
Thanks for everyone for answering

Post Reply

Return to “Software / Configuration”