The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX-17: DVD burning problems, not related to dvdisaster

Post Reply
User avatar
Forum Guide
Forum Guide
Posts: 1052
Joined: Mon Feb 13, 2017 12:09 pm

MX-17: DVD burning problems, not related to dvdisaster


Post by MX-16_fan » Wed Aug 01, 2018 1:22 pm


I promised (https://forum.mxlinux.org/viewtopic.php ... 83#p456183) to report on my problems during my attempts at using dvdisaster in order to create an optical medium that would provide more reliability than a DVD burned the standard way (following the great recommendations from @timkb4cq in https://forum.mxlinux.org/viewtopic.php ... 15#p455715).

Here's the story in short: It seems as if I didn't have problems connected with the dvdisaster application itself, but that the problem had something to do with the DVD burner, be it a hardware issue or a software issue.

Here's the long story of what happened:

I tried to burn the ISO using

1) Brasero,
2) Xfburn and
3) K3b,

all of which aborted the burning process after approximately one minute, either returning an unspecified error or an I/O error.

My suspicion was that this had something to do with the size of the ISO which dvdisaster had generated (enlarged by filling it up with error correction data).

If you look at dvdisaster's preferences, you'll find a menue where you can adjust the number of sectors the ISO is to equal (in the DE localization version: Einstellungen -> Fehlerkorrektur -> Verwende kleinsten möglichen Wert aus folgender Tabelle -> einlagige DVD). There you can

a) either choose dvdisaster's typical default value, or
b) choose to let dvdisaster ask the empty DVD how many sectors it provides (which, according to the information you get when you click on "einlagige DVD", may return wrong information at times).

I tried both methods, but no matter what I did, the resulting ISO could not be burned.

Here's what K3b's log file said:
Burned media
DVD-R Sequential

TEAC DV-W28EAW R.0A (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, SAO/R96P, SAO/R96R, Restricted Overwrite] [%7]

K3b Version: 2.0.3
KDE Version: 4.14.26
QT Version: 4.8.7
Kernel: 4.15.0-1-amd64

Used versions
growisofs: 7.1

Executing 'builtin_dd if=/dev/fd/0 of=/dev/sr0 obs=32k seek=0'
/dev/sr0: engaging DVD-R DAO upon user request...
/dev/sr0: reserving 2287080 blocks
/dev/sr0: "Current Write Speed" is 1.0x1352KBps.
1769472/4683939840 ( 0.0%) @0.4x, remaining 176:24 RBU 100.0% UBU 2.8%
5799936/4683939840 ( 0.1%) @0.9x, remaining 94:06 RBU 100.0% UBU 97.2%
5799936/4683939840 ( 0.1%) @0.0x, remaining 147:52 RBU 100.0% UBU 100.0%
5799936/4683939840 ( 0.1%) @0.0x, remaining 188:12 RBU 100.0% UBU 100.0%
5799936/4683939840 ( 0.1%) @0.0x, remaining 228:31 RBU 100.0% UBU 100.0%
5799936/4683939840 ( 0.1%) @0.0x, remaining 282:18 RBU 100.0% UBU 100.0%
5799936/4683939840 ( 0.1%) @0.0x, remaining 322:38 RBU 100.0% UBU 100.0%
5799936/4683939840 ( 0.1%) @0.0x, remaining 362:57 RBU 100.0% UBU 100.0%
:-[ WRITE@LBA=b10h failed with SK=3h/NO SEEK COMPLETE]: Input/output error
:-( write failed: Input/output error
/dev/sr0: flushing cache

growisofs command:
/usr/bin/growisofs -Z /dev/sr0=/dev/fd/0 -use-the-force-luke=notray -use-the-force-luke=tty -use-the-force-luke=4gms -use-the-force-luke=tracksize:2287080 -use-the-force-luke=dao:2287080 -dvd-compat -speed=1 -use-the-force-luke=bufsize:32m
The drive used was, as you can see in the logfile, a TEAC DV-W28EAW R.0A. (I would have updated its firmware for testing purposes, but I didn't find a reliable firmware source.)

After hours of testing, I did a test run without dvdisaster, i.e. simply burning the data to the DVD the standard way.

Now guess what: That didn't work either.

Here's what I got using the current 0.5.5 version of Xfburn which @Stevo has thankworthily fixed, compiled and put into the MX Test Repo:

First try:
Letzter Versuch Xfburn: "Fehlgeschlagen: SCSI error on write(1936,16): [5 30 05] Illegal request. Cannot write medium, incompatible format."

Second try:
Fehlgeschlagen: SCSI error on write(1904,16): [5 30 05] Illegal request. Cannot write medium, incompatible format.

I therefore exchanged the DVD burner against another one. (The notebook I used for testing has a proprietary caddy system, so this was only a matter of seconds.)

The "new" drive turned out to be an Optiarc AD-7590A (so no more TEAC).

Using the different drive, I had no problems any more whatsoever, be it using dvdisaster or burning without dvdisaster protection.

Now what I'd love to know is whether this rather indicates that

a) the DVD burner is damaged, or
b) the DVD burner didn't like the empty DVD type, or
c) this is a driver issue,
d) this is a BIOS issue.

e) Apart from that, I'd love to know whether DVD burners can provide MX-17 with any valuable information on how well they are (meaning "o.k." or "damaged").

Greetings, and thanks in advance for any answers,


Post Reply

Return to “Software / Configuration”