Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

moc is back! mocp that is.

Post Reply
Message
Author
User avatar
Richard
Posts: 2069
Joined: Fri Dec 12, 2008 10:31 am

moc is back! mocp that is.

#1 Post by Richard » Tue Jul 31, 2018 10:02 pm

A while back, in another thread, I discovered that mocp was broken for me.
http://forum.mxlinux.org/viewtopic.php? ... 8a#p455989

Code: Select all

$ mocp
Running the server...
Trying JACK...
Trying ALSA...
mocp: alsa.c:319: alsa_read_mixer_raw: Assertion `RANGE(0, vol, 100)' failed.

FATAL_ERROR: Server exited!
The concensus was that something was misconfigured.

For that reason, I set up the July Monthly on USB and mocp played as expected.
Backed up the configurations from my laptop and installed the monthly.
It seems a bit lighter since getting rid of a few months worth of kruft and such.
And mocp plays as expected.

Tonight, I started mocp, and to my surprise, got the same error from mocp as above.
Went to the moc forum, http://moc.daper.net/forum, and there,
about a half page down on the left hand side, was a post about the Error!
and a very short message in reply:
Turn your volume level to less than 100%.
Well, at least my system is reorganized. :)
MX171: Lenovo T430: Intel DualCore i5-3320M, 8 GB RAM, 4.18.7-antix.1-amd64-smp, 119GB SSD
MX171: AA1-ZG5/EeePC-1005HA: DualCore N270, 1 GB RAM, 4.9.126-antix.1-686-smp-pae, 150GB HDD
Doublecmd84, LibO61, Dropbx, PMoon, CherryT,Vbox. LinuxCounter #208633

Post Reply

Return to “Software / Configuration”