Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

CIFS VFS: Server has not responded in 120 seconds

Post Reply
Message
Author
User avatar
Roberto
Forum Novice
Forum  Novice
Posts: 4
Joined: Sun May 27, 2018 6:54 am

CIFS VFS: Server has not responded in 120 seconds

#1 Post by Roberto » Sun May 27, 2018 7:43 am

Hi everybody,

I'm a new MX Linux user and I'm new here in the forum.

I have a Raspberry Pi as a NAS server with Openmediavault as NAS software. I have mounted the NAS via smb / cifs and the following entry in the fstab:

Code: Select all

//ip-adress/Daten /media/Datenpool cifs     defaults,credentials=/home/user/.smbcredentials,rw,nounix,iocharset=utf8,vers=1.0,uid=user,gid=user 0 0
Everything works finde and I have full access to all my documents.
Unfortunately, the shutdown hangs with the following message:

Code: Select all

Stopping enhanced syslogd: rsyslogd
[ 1757.153231]CIFS VFS: Server (ip-adress) has not responded in 120 seconds. Reconnecting...
When I umount my NAS manually and shutdown my notebook afterwords, there is no delay.
When I use a different notebook with Artix Linux and OpenRc, the shutdown works smoothly.
Does anyone have an idea what I'm doing wrong or what I have to do so that my computer shut down quickly?

Thanks to all for your ideas and help.
Roberto

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4309
Joined: Wed Jul 12, 2006 4:05 pm

Re: CIFS VFS: Server has not responded in 120 seconds

#2 Post by timkb4cq » Sun May 27, 2018 9:56 am

It appears that your network is shutting down before your share is unmounted.
A search brought up an Ubuntu thread that indicates this will happen if the All users may connect to this network box in Network manager is unchecked.
That box is found thus: Right click on the Network icon in the panel -> Edit Connections -> Select your connection -> Edit -> General (tab)
With any luck, checking the box will solve the problem.

Update: Mounting a cifs share, and unchecking that box causes the same 120 second shutdown delay on my machine. With the box checked, shutdown is normal.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
Roberto
Forum Novice
Forum  Novice
Posts: 4
Joined: Sun May 27, 2018 6:54 am

Re: CIFS VFS: Server has not responded in 120 seconds

#3 Post by Roberto » Sun May 27, 2018 3:21 pm

Hi timkb4cq,

the checkbox "all users may connect to this network" was checked an and I tried both, checking an unchecking it, but every time I have the 120 seconds delay.
What value is important for "Connection-priority for auto-activation"? My default in the wifi connection is "0".

Roberto

User avatar
Roberto
Forum Novice
Forum  Novice
Posts: 4
Joined: Sun May 27, 2018 6:54 am

Re: CIFS VFS: Server has not responded in 120 seconds

#4 Post by Roberto » Mon Jul 09, 2018 1:26 pm

Has nobody an idea to solve my problem?

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1164
Joined: Wed Apr 11, 2018 5:09 pm

Re: CIFS VFS: Server has not responded in 120 seconds

#5 Post by fehlix » Mon Jul 09, 2018 4:17 pm

Roberto wrote:
Mon Jul 09, 2018 1:26 pm
Has nobody an idea to solve my problem?
Why not mounting/unmounting with one click manually e.g through filemanager?
Mounting smb's through fstab is kown to become potentially troublesome,
as you make boot and shutdown dependent from network-connectivity
causing timeouts during boot or shutdown.
I've seen lot's of tweaks and workaround to handle this. But why bother,
if it's just for your documents etc a simpler approach
would be by one-click manual connect/disconnect, imho.

User avatar
Roberto
Forum Novice
Forum  Novice
Posts: 4
Joined: Sun May 27, 2018 6:54 am

Re: CIFS VFS: Server has not responded in 120 seconds

#6 Post by Roberto » Sat Jul 28, 2018 2:03 am

Many times, I tried to mount/umount through the filemanager, but every time I try to do it, I don't get full access to my raspberry.
I always get the message, that the owner is root and that I can't edit a file and can't create a new file.
If anybody has a solution for this problem, using the filemanager would be the way to use my raspberry.

Post Reply

Return to “Software / Configuration”