Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[Solved] boot error msg (do_vector) after kernel upgrade to 4.15

Post Reply
Message
Author
User avatar
outlaw
Forum Regular
Forum Regular
Posts: 298
Joined: Thu Jul 13, 2006 6:35 pm

[Solved] boot error msg (do_vector) after kernel upgrade to 4.15

#1 Post by outlaw » Thu Mar 15, 2018 12:30 am

$ inxi -F
System: Host: opus Kernel: 4.15.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17_x64 Horizon December 15, 2017
Machine: Device: laptop System: HP product: HP Notebook v: Type1ProductConfigId serial: N/A
Mobo: HP model: 81F5 v: 66.41 serial: N/A UEFI: Insyde v: F.24 date: 06/15/2017
Battery BAT1: charge: 30.2 Wh 100.0% condition: 30.2/30.2 Wh (100%)
CPU: Quad core AMD A8-7410 APU with AMD Radeon R5 Graphics (-MCP-) cache: 2048 KB
clock speeds: max: 2200 MHz 1: 1772 MHz 2: 1135 MHz 3: 1207 MHz 4: 1444 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics]
Display Server: x11 (X.Org 1.19.2 )
drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
Resolution: 1366x768@60.09hz
OpenGL: renderer: Gallium 0.4 on AMD MULLINS (DRM 2.50.0 / 4.15.0-1-amd64, LLVM 3.9.1)
version: 4.3 Mesa 13.0.6
Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel
Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.15.0-1-amd64
Network: Card-1: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee
IF: wlan0 state: up mac: 40:49:0f:a9:41:c4
Card-2: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller driver: r8169
IF: eth0 state: down mac: c8:d3:ff:24:ef:0e
Drives: HDD Total Size: 1000.2GB (7.9% used)
ID-1: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB
Partition: ID-1: / size: 59G used: 6.8G (13%) fs: ext4 dev: /dev/sda8
ID-2: /home size: 150G used: 47G (33%) fs: ext4 dev: /dev/sda6
ID-3: swap-1 size: 9.18GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors: System Temperatures: cpu: 53.9C mobo: 20.0C gpu: 44.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 186 Uptime: 15 min Memory: 1002.8/6918.0MB Client: Shell (bash) inxi: 2.3.54


After following the procedure described in my preceding post:

I'm upgrading from MX-17 to MX-17.1 which means changing to kernel 4.15.
What I would like to do is install the new kernel but keep the old ... just in case.

After selecting the appropriate kernel and headers for my system (amd64) in the MX Package Installer
and then clicking on the install button I believe the following should /will happen:

1) New kernel will be installed and old will not be removed.
2) Grub will be updated to use the new kernel.

Am I correct in this assumption? (Or if not what procedure should I use to accomplish this task?)

Thank you in advance for any advice offered.


The change process appears to have been successful however, the following error messages
are generated at the beginning of the boot process:

0.001000 do_IRQ 1:55 no irqhandler for vector
0.001000 do_IRQ 3:55 no irqhandler for vector
0.001000 do_IRQ 2:55 no irqhandler for vector

Not sure how serious these error messages are.

I thought maybe installing the irqbalance package might help.
(It was suggested by apt-get during the kernel install.)
Bad idea ... I think it's a systemd service.

Should I be worried by this error message? Can I eliminate it?

Thanks in advance for any and all help / suggestions offered.

Tom
Naturally nuts ... no pharmaceuticals required.
Last edited by outlaw on Sat Nov 03, 2018 2:42 pm, edited 1 time in total.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22709
Joined: Wed Jul 19, 2006 6:13 am

Re: boot error msg (do_vector) after kernel upgrade to 4.15

#2 Post by Jerry3904 » Thu Mar 15, 2018 3:21 am

Welcome to my little club! I saw this on my testing machine during Development, seems only annoying, will post details in the morning.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22709
Joined: Wed Jul 19, 2006 6:13 am

Re: boot error msg (do_vector) after kernel upgrade to 4.15

#3 Post by Jerry3904 » Thu Mar 15, 2018 9:00 am

I see it on my testing laptop in sig every time I boot or resume from suspend. Here is the point in the dmesg log where it appears:

Code: Select all

  0.028340] x86: Booting SMP configuration:
[    0.028344] .... node  #0, CPUs:      #1
[    0.001000] do_IRQ: 1.55 No irq handler for vector
[    0.040010] smp: Brought up 1 node, 2 CPUs
[    0.040014] smpboot: Max logical packages: 2
[    0.040018] smpboot: Total of 2 processors activated (3989.99 BogoMIPS)
Googling around, it seems to be the kernel's interactions with specific mother boards.

You can get rid of it by changing kernels using MX Package Installer, either dropping to the 14.4 kernel or trying one of the other 15s on the list. Once you find one that works on your system, then click the 15 kernel that is causing the problem and uninstall it.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16624
Joined: Fri Dec 15, 2006 8:07 pm

Re: boot error msg (do_vector) after kernel upgrade to 4.15

#4 Post by Stevo » Thu Mar 15, 2018 1:38 pm

Yes, the 4.14 kernel should be OK for your AMD processor, since it's not afflicted by the Meltdown and Spectre problems.

User avatar
outlaw
Forum Regular
Forum Regular
Posts: 298
Joined: Thu Jul 13, 2006 6:35 pm

Re: boot error msg (do_vector) after kernel upgrade to 4.15

#5 Post by outlaw » Sat Mar 17, 2018 9:44 am

Thank you Stevo and Jerry for your responses.

I'm considering trying the kernel specifically complied for desktops / laptops.
(I forget exactly what it's called .... liqu?)

To be perfectly honest I should probably just enjoy my stable system and stop messing about.

Tom
Naturally nuts ... no pharmaceuticals required.

User avatar
outlaw
Forum Regular
Forum Regular
Posts: 298
Joined: Thu Jul 13, 2006 6:35 pm

Re: boot error msg (do_vector) after kernel upgrade to 4.15

#6 Post by outlaw » Sat Nov 03, 2018 2:41 pm

I'm using the kernel that ships with antiX-17.2 (4.9.126-antix.1-amd64-smp) and the vector error message no longer appears.

Tom
Naturally nuts no pharmaceuticals required

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16624
Joined: Fri Dec 15, 2006 8:07 pm

Re: [Solved] boot error msg (do_vector) after kernel upgrade to 4.15

#7 Post by Stevo » Sat Nov 03, 2018 3:05 pm

I think the newer kernels in the test repo, such as the 4.18 Liquorix or backported Debian ones, also don't throw those messages.

Post Reply

Return to “Software / Configuration”