Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

HardInfo 0.5.1 Devices->Storage Shows Nothing

Message
Author
User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4374
Joined: Wed Jul 12, 2006 4:05 pm

Re: HardInfo 0.5.1 Devices->Storage Shows Nothing

#11 Post by timkb4cq » Fri Feb 16, 2018 5:51 pm

I just built i-nex for the MX-17 Test repo. It's a hardware information tool designed to look like the CPU-Z Windows tool.
I'm not crazy about the look of it but it's comprehensive including for Storage & USB. Give it a try.

<Mod: I changed the name to start with lower case>
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22461
Joined: Wed Jul 19, 2006 6:13 am

Re: HardInfo 0.5.1 Devices->Storage Shows Nothing

#12 Post by Jerry3904 » Fri Feb 16, 2018 5:58 pm

Quickie: butt-ugly, very small dimensions can't be changed that I can see
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1429
Joined: Sun Dec 16, 2007 6:29 pm

Re: HardInfo 0.5.1 Devices->Storage Shows Nothing

#13 Post by GuiGuy » Fri Feb 16, 2018 6:32 pm

I don't mind the ugliness, and it is big enough when I change my display setting from 1600x1200 to 1024x768.
Actually I rather like it, although I wish it could be enlarged more easily.
It does work, and is very comprehensive.
Screenshot-21.png
Thanks, Tim.
You do not have the required permissions to view the files attached to this post.

User avatar
ChrisUK
Forum Regular
Forum Regular
Posts: 190
Joined: Tue Dec 12, 2017 1:04 pm

Re: HardInfo 0.5.1 Devices->Storage Shows Nothing

#14 Post by ChrisUK » Sat Feb 17, 2018 4:16 am

All the hardware info etc is easily accessed in Linux, and all/most of the tools are pre-installed (lsusb, lshw, lspci, lscpu, blkid, etc) - inxi provides the easiest way for a user to view this information. So I'm not sure what else people need. Here's a list of options for inxi.

OK, you could easily code a pretty GUI... but the GUI would take more time to design than actually coding the hardware info (Even using something like Eric for designing the GUI and Python as the language).

Almost forgot - Antix has a basic GUI for inxi... inxi-gui-antix... it's in the repos. It's quite basic, but I'd guess useful for those a bit wary of using the command line
Chris

MX 17 - Manjaro

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1429
Joined: Sun Dec 16, 2007 6:29 pm

Re: HardInfo 0.5.1 Devices->Storage Shows Nothing:i-nex better

#15 Post by GuiGuy » Sat Feb 24, 2018 8:05 am

On this thinkpad 1280x800, i-nex display is quite acceptable.
And i-nex works much better than hardinfo.
Screenshot-1.png
You do not have the required permissions to view the files attached to this post.

NevilsStation
Forum Regular
Forum Regular
Posts: 243
Joined: Sun Feb 26, 2017 3:09 pm

Re: HardInfo 0.5.1 Devices->Storage Shows Nothing

#16 Post by NevilsStation » Sat Feb 24, 2018 10:14 pm

timkb4cq wrote:I just built i-nex for the MX-17 Test repo. It's a hardware information tool designed to look like the CPU-Z Windows tool.
I'm not crazy about the look of it but it's comprehensive including for Storage & USB. Give it a try.

<Mod: I changed the name to start with lower case>
I can find inxi in Synaptic Package Manager but not "i-nex"

Thanks
Custom-built PC w/i7 CPU running MX-16.

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 2035
Joined: Mon Nov 21, 2011 5:50 pm

Re: HardInfo 0.5.1 Devices->Storage Shows Nothing

#17 Post by Gordon Cooper » Sat Feb 24, 2018 10:22 pm

NevilsStation wrote:
timkb4cq wrote:I just built i-nex for the MX-17 Test repo. It's a hardware information tool designed to look like the CPU-Z Windows tool.
I'm not crazy about the look of it but it's comprehensive including for Storage & USB. Give it a try.

<Mod: I changed the name to start with lower case>
I can find inxi in Synaptic Package Manager but not "i-nex"

Thanks
Tim said that he changed the case, look for I-nex - first I item in Synaptic
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4374
Joined: Wed Jul 12, 2006 4:05 pm

Re: HardInfo 0.5.1 Devices->Storage Shows Nothing

#18 Post by timkb4cq » Sat Feb 24, 2018 10:27 pm

NevilsStation wrote:I can find inxi in Synaptic Package Manager but not "i-nex"
Probably because it's in the Test repo. Use MX Tools -> Package Installer -> Full App Catalog -> MX Test Repo to find it.
You could also enable the test repository in Synaptic & Reload, but make sure to disable it again afterwards if you do. The Package Installer handles that for you.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

NevilsStation
Forum Regular
Forum Regular
Posts: 243
Joined: Sun Feb 26, 2017 3:09 pm

Re: HardInfo 0.5.1 Devices->Storage Shows Nothing

#19 Post by NevilsStation » Tue Feb 27, 2018 10:58 pm

timkb4cq wrote:
NevilsStation wrote:I can find inxi in Synaptic Package Manager but not "i-nex"
Probably because it's in the Test repo. Use MX Tools -> Package Installer -> Full App Catalog -> MX Test Repo to find it.
You could also enable the test repository in Synaptic & Reload, but make sure to disable it again afterwards if you do. The Package Installer handles that for you.
i-nez is awesome.

I need to figure out how to add a button for it to the sidebar.

I also need a way to make it larger.
Custom-built PC w/i7 CPU running MX-16.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4374
Joined: Wed Jul 12, 2006 4:05 pm

Re: HardInfo 0.5.1 Devices->Storage Shows Nothing

#20 Post by timkb4cq » Tue Feb 27, 2018 11:31 pm

I agree larger would be nice, but in my browsing through the code it seems that all sizes are hard-coded. IIRC, there aren't any easy options in Gambas to write resizable complex layouts. It probably could be done, but it's not a project I'd like to tackle...
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

Post Reply

Return to “Software / Configuration”