Welcome!

Please read this important information about Spectre and Meltdown vulnerabilities.
Please read this important information about MX sources lists.

News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17.1 Final release info here
  • antiX-17 release info here
New users
  • Please read this first, and don't forget to add system and hardware information to posts!
  • Read Forum Rules

[Solved] Smplayer no longer works

Message
Author
erbou
Forum Novice
Forum  Novice
Posts: 39
Joined: Sun May 21, 2017 12:21 pm

[Solved] Smplayer no longer works

#1 Postby erbou » Fri Jan 12, 2018 3:44 am

Hello,

I had to reinstall MX-16.1 (Nov 2017 release) and I got this error message as running Smplayer for the first time :

Code: Select all

/home/tt/.config/smplayer/styles.ass -subfont-autoscale 0 -subfont-text-scale 20 -subcp ISO-8859-1 -subpos 100 -volume 84 -cache 2048 -ss 63 -osdlevel 0 -vf-add screenshot -noslices -channels 2 -af scaletempo -softvol -softvol-max 110 /media/Data-2/Musique/Blues/Eric Clapton-02-Before You Accuse Me-1992-UNPLUGGED.mp4

Error parsing option noquiet (option not found)

Setting commandline option --noquiet= failed.

Exiting... (Fatal error)


I uninstalled mpv and Smplayer then re-install both of them with Synaptic and ran Smplayer again : it didn't help.
Last edited by erbou on Fri Jan 12, 2018 2:42 pm, edited 1 time in total.
1st boot: Linux ttx 4.7.0-0.bpo.1-amd64 #1 SMP MX 4.7.8-1mx16+3 (2017-02-23) x86_64 GNU/Linux
2nd boot: Windows 7 Home Edition
Processor: Intel i5-4570 - Ram: 16 Gb - NAS: Synology DS216j - DSM 6.1

User avatar
penguin
Forum Regular
Forum Regular
Posts: 199
Joined: Wed Jan 04, 2017 3:15 pm

Re: Smplayer no longer works

#2 Postby penguin » Fri Jan 12, 2018 9:51 am

This message comes up when you tried to play eric*.mp4 or when you open Smplayer for the first time ?
If this happen when you tried to open Smplayer without playing nothing...means Smplayer is looking to play smth from previous history and the path is not valid , I guess.
I never have problem with mpv or even smplayer.

I made a search for you in google :-).
https://www.google.no/search?client=opera&hs=3ph&ei=171YWvfJJIGssAGJq63QAg&q=Smplayer+styles.ass+-subfont-autoscale+0+-subfont-text-scale+20&oq=Smplayer+styles.ass+-subfont-autoscale+0+-subfont-text-scale+20&gs_l=psy-ab.3...4170.5584.0.7581.0.0.0.0.0.0.0.0..0.0....0...1c.1.64.psy-ab..0.0.0....0.02pEu6WRmk4

Try > Mx Tools and install Multimedia Codecs if you have not installed them.

erbou
Forum Novice
Forum  Novice
Posts: 39
Joined: Sun May 21, 2017 12:21 pm

Re: Smplayer no longer works

#3 Postby erbou » Fri Jan 12, 2018 2:11 pm

In the settings, I changed the Executable Mplayer from mpv to mplayer : Smplayer now reads my video but it remains mute !
1st boot: Linux ttx 4.7.0-0.bpo.1-amd64 #1 SMP MX 4.7.8-1mx16+3 (2017-02-23) x86_64 GNU/Linux
2nd boot: Windows 7 Home Edition
Processor: Intel i5-4570 - Ram: 16 Gb - NAS: Synology DS216j - DSM 6.1

erbou
Forum Novice
Forum  Novice
Posts: 39
Joined: Sun May 21, 2017 12:21 pm

[Solved] Re: Smplayer no longer works

#4 Postby erbou » Fri Jan 12, 2018 2:33 pm

I changed the output driver to alsa and everything is fine.
1st boot: Linux ttx 4.7.0-0.bpo.1-amd64 #1 SMP MX 4.7.8-1mx16+3 (2017-02-23) x86_64 GNU/Linux
2nd boot: Windows 7 Home Edition
Processor: Intel i5-4570 - Ram: 16 Gb - NAS: Synology DS216j - DSM 6.1

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15063
Age: 59
Joined: Fri Dec 15, 2006 8:07 pm

Re: [Solved] Smplayer no longer works

#5 Postby Stevo » Fri Jan 12, 2018 3:17 pm

It appears that SMPlayer no longer works with the rather old version of mpv we have in the main repository, or the default "mplayer" in Jessie, which is actually the defunct mplayer2. I'll see about bumping up the minimum dependencies for those.

dr-kart
Forum Regular
Forum Regular
Posts: 118
Joined: Sun Oct 22, 2017 8:12 pm

Re: [Solved] Smplayer no longer works

#6 Postby dr-kart » Sat Jan 13, 2018 6:32 am

Stevo wrote:rather old version of mpv we have in the main repository

mpv won't play youtube live streaming too.
https://github.com/mpv-player/mpv/issues/5286

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15063
Age: 59
Joined: Fri Dec 15, 2006 8:07 pm

Re: [Solved] Smplayer no longer works

#7 Postby Stevo » Sat Jan 13, 2018 7:07 pm

The mpv 0.27 version in the test repo worked a couple days ago when I used it as the backend in SMPlayer 17.12.2 and set the streaming to use mpv + youtube-dl. The 18.1.0 update was supposed to fix this with the "Auto" setting.

dr-kart
Forum Regular
Forum Regular
Posts: 118
Joined: Sun Oct 22, 2017 8:12 pm

Re: [Solved] Smplayer no longer works

#8 Postby dr-kart » Sun Jan 14, 2018 5:17 am

Stevo wrote:The mpv 0.27 version in the test repo worked a couple days ago when I used it as the backend in SMPlayer 17.12.2 and set the streaming to use mpv + youtube-dl.

it's not working with live youtube streaming videos. As the link describes above.
Any other not-live streams are fine with mpv + youtube-dl option. 0.27 is included.

kb50
Forum Novice
Forum  Novice
Posts: 20
Joined: Sun Nov 26, 2017 9:51 pm

Re: [Solved] Smplayer no longer works

#9 Postby kb50 » Sun Jan 14, 2018 9:06 pm

Same here, I installed SmTube player, and it shows several links, but nothing opens. Just get URL Not found.
Do I need SmPLayer installed as well? Guess I can just go get SmPlayer to see if that is the cure? I just now got an update on Package Manager.
Would like to see that developed more, for those like me that are just not confident in using terminal commands.
{erhaps a future suggestion to just have a notifier of newly packaged items. It's a very accurate, and useful tool. Perhaps also to automate Y when prompted, but I usually enjoy watching
it install anyhow, just so I can catch any errors.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15063
Age: 59
Joined: Fri Dec 15, 2006 8:07 pm

Re: [Solved] Smplayer no longer works

#10 Postby Stevo » Sun Jan 14, 2018 10:34 pm

Live streaming seems to be a known issue. I will build smtube-18.1.0, but it seems we would need mpv-0.28, too.

https://forum.smplayer.info/viewtopic.p ... =30#p17518

Mpv 0.28 is not in Debian yet, but I tried building it against ffmpeg 3.4.1, which should have been good since they said 3.4 is the minimum. It failed when it wanted even newer, unreleased libraries such as libavcodec58. :confused:


Return to “Software / Configuration”

Who is online

Users browsing this forum: Richard and 3 guests