Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Google Earth and Google Earth Pro

Post Reply
Message
Author
User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16286
Joined: Fri Dec 15, 2006 8:07 pm

Google Earth and Google Earth Pro

#1 Post by Stevo » Mon Jan 08, 2018 6:52 pm

I installed Google Earth via the Package Installer. It worked fine as far as it went, but I noticed it was the rather antique version 6 that googleearth-package creates and installs.

I also had a 2016 vintage Google Earth 7 deb from the Google sitting on my drive, so I installed that, and it also worked well. I then checked Google, and they now have only Google Earth Pro 7.3 for download for free--no more "amateur" versions. So I installed that, but encountered the exact same issue as this--but I have the same popular Skylake 520 graphics, and it might be restricted to that GPU.

I then downloaded and installed the older 7.1.8 GE Pro linked in that bug report, and that works fine. So I'm wondering how GE Pro 7.3 is working for other users, and if it's worth adding that option to the package installer.

User avatar
richb
Administrator
Posts: 17096
Joined: Wed Jul 12, 2006 2:17 pm

Re: Google Earth and Google Earth Pro

#2 Post by richb » Mon Jan 08, 2018 7:24 pm

7.3 working here.

Code: Select all

System:    Host: mxlaptop Kernel: 4.9.0-4-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
           Distro: MX-17_x64 Updated to Final Horizon December 10, 2017
Machine:   Device: laptop System: Acer product: Aspire V5-572G v: V2.06 serial: N/A
           Mobo: Acer model: Dazzle_CX v: Type2 - A01 Board Version serial: N/A
           UEFI [Legacy]: Insyde v: V2.06 date: 05/22/2013
Battery    BAT1: charge: 43.2 Wh 100.0% condition: 43.2/53.4 Wh (81%)
CPU:       Dual core Intel Core i5-3337U (-MT-MCP-) cache: 3072 KB
           clock speeds: max: 2700 MHz 1: 1723 MHz 2: 1636 MHz 3: 2288 MHz 4: 1693 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]
           Display Server: x11 (X.Org 1.19.2 )
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.99hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile version: 3.3 Mesa 13.0.6
Audio:     Card Intel 7 Series/C216 Family High Def. Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.0-4-amd64
Network:   Card-1: Qualcomm Atheros AR9462 Wireless Network Adapter driver: ath9k
           IF: wlan0 state: up mac: 2c:d0:5a:eb:3e:cc
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: down mac: 08:9e:01:a4:28:8e
Drives:    HDD Total Size: 256.1GB (22.8% used)
           ID-1: /dev/sda model: SanDisk_SDSSDP25 size: 256.1GB
Partition: ID-1: / size: 117G used: 11G (10%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.16GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 266 Uptime: 1 day Memory: 2055.9/11901.0MB Client: Shell (bash) inxi: 2.3.53 

Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16286
Joined: Fri Dec 15, 2006 8:07 pm

Re: Google Earth and Google Earth Pro

#3 Post by Stevo » Mon Jan 08, 2018 7:35 pm

Thanks...I plan to try 7.3 with "optirun" to see if the Nvidia renderer makes any difference. But 7.3 also bumps the version of Qt 5, and that leads to theming issues (small text, not respecting colors, etc). I don't know if we can find legal sources of older releases, though.

Update: I can run GE Pro 7.3 using the Nvidia GPU for rendering with "optirun".

Post Reply

Return to “Software / Configuration”