Welcome!

Please read this important information about Spectre and Meltdown vulnerabilities.
Please read this important information about MX sources lists.

News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17.1 Final release info here
  • antiX-17 release info here
New users
  • Please read this first, and don't forget to add system and hardware information to posts!
  • Read Forum Rules

SOLVED Plex Media Server instlall

Message
Author
kb50
Forum Novice
Forum  Novice
Posts: 20
Joined: Sun Nov 26, 2017 9:51 pm

SOLVED Plex Media Server instlall

#1 Postby kb50 » Thu Nov 30, 2017 1:29 pm

FINALLY, since PLEX MEDIA server have installed I was fighting to get the server to launch.
So I downloaded the DEB package, Version 1.8.0.49 wheezy_amd 64 version. Checksum left out.
It appears to install fine, but there is a missing peice of the puzzle.

It was simple, need to open up symantic and install avahi-utilities

Then reinstall plex media server deb.
Then Restart Your System, and you will see Plex Deamon loading and when You open the Plex Manager you can Login.

Hopefully SOMEDAY Plex will Update their install to include adding the avahi-utils and fix the user problem as described in the next message.

NOW also be sure the Machine Name of your MX-16 is NOT the same as any other, including windows and android, IF you use the same email address.

So now I have a Complete PLEX media server, and its hosting 250GB worth of media and in Linux it uses far less resources and much faster better access to my LAN.

To add media outside of the Linux Drive and Home, you also need to Go to Disk Manager, Check ON all Local Drives. I keep all my media on my Windows Drive, so that when I boot into Windows its Plex Both Windows and Linux Server has the same access to all the same media.
Otherwise you simply cannot, and you have to have the Windows folders always mounted, but then why would you not? Another hoping flaw that MX-17 will fix.
Last edited by kb50 on Thu Dec 14, 2017 12:15 am, edited 1 time in total.

kb50
Forum Novice
Forum  Novice
Posts: 20
Joined: Sun Nov 26, 2017 9:51 pm

Re: SOLVED Plex Media Server instlall

#2 Postby kb50 » Thu Nov 30, 2017 11:27 pm

Additional FIX for Plex Media Server to gain access to all the folders.

Open Terminal

Open up for editing sub out nano for your fav editor if you desire.

sudo nano /etc/default/plexmediaserver


Move cursor to last line as shown here

PLEX_MEDIA_SERVER_USER=plex

Change the word plex to your username that you normally logon with not root

Save the file nano uses ctrl-x and Y to save it

Then restart the plex server

sudo service plexmediaserver restart

Afterwards you can select media on your hard drive.

NOTE doing this you WILL lose the entire database, it is like starting from scratch. But it is worth it to be able to access ANY mounted media on your system.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21418
Joined: Wed Jul 19, 2006 6:13 am

Re: SOLVED Plex Media Server instlall

#3 Postby Jerry3904 » Fri Dec 01, 2017 6:34 am

I'm trying to replicate this procedure so we can create a Wiki entry, but ran into a problem: how did you get past the page loading problem for this:

Code: Select all

http://localhost:32400/manage
Or did you never see it?
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
metalchef
Forum Novice
Forum  Novice
Posts: 1
Joined: Thu Dec 21, 2017 1:50 pm

Re: SOLVED Plex Media Server instlall

#4 Postby metalchef » Thu Dec 21, 2017 2:10 pm

Why is this marked as solved?

On MX17, it remains an issue:

Code: Select all

adrian@mx-linux:~
$ lsb_release -a
No LSB modules are available.
Distributor ID:   MX
Description:   MX 17 Horizon
Release:   17
Codename:   Horizon
adrian@mx-linux:~


Anyone found a way to access the plex service locally?

Code: Select all

adrian@mx-linux:~
$ sudo service plexmediaserver status
plexmediaserver: unrecognized service
adrian@mx-linux:~


I removed gufw (so it's not running) -

I set the Plex user as indicated in the previous reply:

Code: Select all

$ grep "adrian" /etc/default/plexmediaserver
export PLEX_MEDIA_SERVER_USER=adrian
adrian@mx-linux:~


Although I've abandoned MX for Debian, I'd still like to see a fix for this.
You do not have the required permissions to view the files attached to this post.

kb50
Forum Novice
Forum  Novice
Posts: 20
Joined: Sun Nov 26, 2017 9:51 pm

Re: SOLVED Plex Media Server instlall

#5 Postby kb50 » Tue Jan 09, 2018 10:26 pm

YAY

Finally the Distro Wizards have added Plex, and it is in the MX Software Manager.

So they got it right, 100 percent.
It comes up as MX17 as the server name, which is fine. But basically that it all works!

HATS OFF I Spent over 8 hours trying to get it working.
YES I DO hope that they include it in the next release.

SEE I have over 8000 music, 100s of Movies, some converted over, some ripped out of my DVD collection etc.
And just thousands of photos. NOW I can project them to the main 50 inch screen in up to 4K that has ROKU Plex TV app.

DONE.

I had it working in Windows, and I had it working in MX-16 but something changed, but they have fixed whatever.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 8268
Joined: Sun Dec 16, 2007 1:17 pm

Re: SOLVED Plex Media Server instlall

#6 Postby dolphin_oracle » Tue Jan 09, 2018 10:37 pm

kb50 wrote:YAY

Finally the Distro Wizards have added Plex, and it is in the MX Software Manager.

So they got it right, 100 percent.
It comes up as MX17 as the server name, which is fine. But basically that it all works!

HATS OFF I Spent over 8 hours trying to get it working.
YES I DO hope that they include it in the next release.

SEE I have over 8000 music, 100s of Movies, some converted over, some ripped out of my DVD collection etc.
And just thousands of photos. NOW I can project them to the main 50 inch screen in up to 4K that has ROKU Plex TV app.

DONE.

I had it working in Windows, and I had it working in MX-16 but something changed, but they have fixed whatever.


I'm glad you like it.

the main issue was that plex quit supporting sysV init, which is important to getting the server to run correctly at startup. if you don't use the mx-packageinstaller to install it, say be downloading the deb directly from plex, it should still work in systemd mode.
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 17 32 bit (streaming media player)
lenovo ThinkPad T530 - MX-17
lenovo s21e - antiX-17, MX17(live-usb)

kb50
Forum Novice
Forum  Novice
Posts: 20
Joined: Sun Nov 26, 2017 9:51 pm

Re: SOLVED Plex Media Server instlall Aditional Info and solution.

#7 Postby kb50 » Sat Jan 13, 2018 3:28 pm

In my computer running PLEX server I have 2 hard drives, One for Windows and One for Linux.
I ran into this next problem, and figured a resolution, again after blaming PLEX but it is a Linux issue instead.

I have 2 partitions which are NTFS ones One is WIN10 which is my Windows C drive and the other is
STORE.
STORE contains all the folders of my media.

One thing I do know is of course that you basically have to have your folders mounted all the time for PLEX and many other apps to see them.
I do that using the MX Disk Manager GUI, which allows you to check the checkboxes. So that seemed all good. The Drives tool basically edits for you the fstab file to
permanently mount said drive partitions.

However, I attempted in the Web Plex Manager, to add media from STORE.
Nope, it showed the drive but NO folders beyond that.

So I figure OK its some Plexl thing. So here after spending a few hours is how it got resolved.
It was looking like I would
have to move everything out of STORE and to some other location.

So I got to looking at the Disk Manager, and discovered that the Gui has an edit box to show what it changes in fstab file, and thus mounts the shares you check so that on startup they are mounted, which makes sense being local drives.
There would be no point to want to unmount them, in my mind. But in the edit box I noticed the entry in fstab was not the same.
So I unchecked the boxes, and restarted MX-17. I went back into the Plex Server web app, and see now that only my Linux drive would be allowed to add to a Library. and it removed the entries that had referred to STORE and WIN10 drives.

Then I went back to Disk Manager application, and rechecked the boxes, BUT I noticed now that both WIN10 and STORE were now identical in their fstab entries.
So after doing that now went back into Plex Manager, and WOILA STORE now showed all the folders!!!

So basically this information is to mean that you must have identical fstab entries for each ntfs local drive in your system, or PLEX and probably other applications might not see any folders.
I also noticed that type is ntfs -3g

Some may prefer to just edit fstab, and the GUI saves you all the work, and eliminates (hopefully) any mistakes, which would hang your system if done wrong.

Now for most it may not matter, if all your media is stored on your Linux drive. But I have dual boot, so Windows Plex Server uses the same folders so I have basically a consistent PLEX Server, whether in Linux or Windows. (Well not identical but the same media).

Here basically is my FSTAB content
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

#Entry for /dev/sdb1 :
UUID=49fca2ed-7059-4234-b95e-96ed04662a8b / ext4 defaults 1 1
#Entry for /dev/sda5 :
UUID=8036EBC636EBBB74 /media/STORE ntfs-3g defaults,locale=en_US.UTF-8 0 0
#Entry for /dev/sda2 :
UUID=98E2CAD7E2CAB8B0 /media/WIN10 ntfs-3g defaults,locale=en_US.UTF-8 0 0
#Entry for /dev/sdb2 :
UUID=39ae70f5-b7e9-46f8-850e-ad6260ce3535 swap swap defaults 0 0

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21418
Joined: Wed Jul 19, 2006 6:13 am

Re: SOLVED Plex Media Server instlall

#8 Postby Jerry3904 » Sat Jan 13, 2018 3:45 pm

Helpful post, thanks.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

kb50
Forum Novice
Forum  Novice
Posts: 20
Joined: Sun Nov 26, 2017 9:51 pm

Plex Media Server is brijeb again.

#9 Postby kb50 » Fri Mar 09, 2018 6:52 pm

Apparently were back in never never land, and a recent update has cause PLEX to fail to startup again.
So Now here we are stuck, with no Plex Server.

The Update broke it again.

I cannot seem to find the folders containing the items it keeps looking at to force it to launch again at startup.
So it never starts up anymore.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 8268
Joined: Sun Dec 16, 2007 1:17 pm

Re: SOLVED Plex Media Server instlall

#10 Postby dolphin_oracle » Fri Mar 09, 2018 7:28 pm

I updated the install routine in MX package installer recently. The new routine tries to address this never-ending Plex breaking things when it updates.

Just a reminder that we do not package Plex. Plex drop support for our init system.

Just reinstalling plex from mx-pi is enough to bring in the new sysvinit script. Plex does not package it.
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 17 32 bit (streaming media player)
lenovo ThinkPad T530 - MX-17
lenovo s21e - antiX-17, MX17(live-usb)


Return to “Software / Configuration”

Who is online

Users browsing this forum: Stevo and 3 guests