Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] MX-16 issue: "Clawsker" has no starter icon

Post Reply
Message
Author
User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 831
Joined: Mon Feb 13, 2017 12:09 pm

[SOLVED] MX-16 issue: "Clawsker" has no starter icon

#1 Post by MX-16_fan » Mon Apr 24, 2017 3:48 pm

Clawsker (http://www.claws-mail.org/clawsker.php - package name: "clawsker") is an application that allows you to change Claws Mail's hidden preferences. While it is a GUI app, it lacks a starter button in MX-16 after installation. Greetings, Joe
Last edited by MX-16_fan on Fri May 19, 2017 8:49 am, edited 1 time in total.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15402
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX-16 issue: "Clawsker" has no starter icon

#2 Post by Stevo » Mon Apr 24, 2017 5:14 pm

I'd say it's a Debian problem instead of just an MX-16 issue--it doesn't install any desktop file or icon, using instead the old, deprecated menu system. One workaround that the user can use is to create a desktop file with the menu editor.

The version in Stretch does incorporate the the fixes, including a desktop file; let's see if it can be backported to our test repo.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15402
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX-16 issue: "Clawsker" has no starter icon

#3 Post by Stevo » Mon Apr 24, 2017 5:27 pm

OK, the fix came from clawsker's source, not from anything that the Debian maintainer did. The 1.0.1 version in upstream Debian is already been surpassed by Clawsker 1.1.0, so I packaged that version: https://drive.google.com/open?id=0BxE7w ... mdEX1NjbXc

User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 831
Joined: Mon Feb 13, 2017 12:09 pm

Re: MX-16 issue: "Clawsker" has no starter icon

#4 Post by MX-16_fan » Wed Apr 26, 2017 8:07 am

@Stevo:
Stevo wrote:OK, the fix came from clawsker's source, not from anything that the Debian maintainer did. The 1.0.1 version in upstream Debian is already been surpassed by Clawsker 1.1.0, so I packaged that version: https://drive.google.com/open?id=0BxE7w ... mdEX1NjbXc
Very cool, thank you.

* Are you putting this into the Test Repo?
* Can I mark this thread as "solved"?


Greetings, Joe

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15402
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX-16 issue: "Clawsker" has no starter icon

#5 Post by Stevo » Wed Apr 26, 2017 2:41 pm

Yes, 1.1.0 is in the testing repo, and it has a working menu entry and icon on my system. Let us know how it's working for you!

User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 831
Joined: Mon Feb 13, 2017 12:09 pm

Re: MX-16 issue: "Clawsker" has no starter icon

#6 Post by MX-16_fan » Wed Apr 26, 2017 3:23 pm

@Stevo:
Stevo wrote:Yes, 1.1.0 is in the testing repo, and it has a working menu entry and icon on my system. Let us know how it's working for you!
Thanks a lot. I'll test it for some time and then report on it. Greetings, Joe

User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 831
Joined: Mon Feb 13, 2017 12:09 pm

Re: MX-16 issue: "Clawsker" has no starter icon

#7 Post by MX-16_fan » Fri May 19, 2017 8:48 am

@all:
MX-16_fan wrote:@Stevo:
Stevo wrote:Yes, 1.1.0 is in the testing repo, and it has a working menu entry and icon on my system. Let us know how it's working for you!
Thanks a lot. I'll test it for some time and then report on it. Greetings, Joe
Seems to work fine. I'll mark this "SOLVED". Thanks ever so much to Stevo for packaging the new version for the MX Test Repo – you're really great!

Greetings, and have a nice weekend, Joe

Post Reply

Return to “Software / Configuration”