Welcome!

NewsCurrent releases
  • MX-16 release info here
  • antiX-16 release info here
New users
  • Please read this first, and don't forget to add system and hardware information to posts!
  • Read Forum Rules

[SOLVED] Can't perform dist-upgrade because packages cannot be authenticated

Message
Author
User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 193
Joined: Mon Feb 13, 2017 12:09 pm

Re: Can't perform dist-upgrade because packages cannot be authenticated

#11 Postby MX-16_fan » Tue Feb 14, 2017 1:41 pm

@kmathern:

kmathern wrote:Okay, could you post the actual error message(s) about being unable to authenticate those packages?

Fwiw I just had those same packages installed earlier today during the initial dist-upgrade on a relatively new MX-16 install and there weren't errors/warnings about them.


First is

Code: Select all

$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following package was automatically installed and is no longer required:
  libechonest2.1
Use 'apt-get autoremove' to remove it.
Done
The following NEW packages will be installed:
  libftgl2 libimobiledevice6 libmygpo-qt1 libprojectm2 libqt4-sql-sqlite libqxt-core0 libqxt-gui0 python-bluez
The following packages will be upgraded:
  bluez clementine
2 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
Need to get 6260 kB of archives.
After this operation, 4618 kB disk space will be freed.
Do you want to continue? [Y/n]


When I confirm this with "Y", strangely enough, it now does a fine

Code: Select all

Get:1 http://ftp.de.debian.org/debian/ jessie/main libftgl2 amd64 2.1.3~rc5-4+nmu1 [93.2 kB]
Get:2 http://nl.mxrepo.com/mx/repo/ mx15/main python-bluez amd64 0.22-1mx15+1 [51.0 kB]
Get:3 http://ftp.de.debian.org/debian/ jessie/main libqt4-sql-sqlite amd64 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 [62.5 kB]
Get:4 http://nl.mxrepo.com/mx/repo/ mx16/main bluez amd64 5.43-1mx15+2 [950 kB]
Get:5 http://ftp.de.debian.org/debian/ jessie/main libqxt-core0 amd64 0.6.2-1+b1 [166 kB]
Get:6 http://ftp.de.debian.org/debian/ jessie/main libqxt-gui0 amd64 0.6.2-1+b1 [262 kB]
Get:7 http://ftp.de.debian.org/debian/ jessie/main libprojectm2 amd64 2.1.0+dfsg-1+b1 [218 kB]                                                   
Get:8 http://nl.mxrepo.com/mx/repo/ mx15/main libimobiledevice6 amd64 1.2.0+dfsg-3mx15+1 [64.9 kB]                                               
Get:9 http://nl.mxrepo.com/mx/repo/ mx15/main libmygpo-qt1 amd64 1.0.9~git20151122-1mx150+1 [63.5 kB]                                             
Get:10 http://nl.mxrepo.com/mx/repo/ mx15/main clementine amd64 1.3.1+git240-g1a2f6e2+dfsg-1mx15+1 [4328 kB]                                     
Fetched 6260 kB in 54s (114 kB/s)                                                                                                                 
Selecting previously unselected package libftgl2:amd64.
(Reading database ... 184143 files and directories currently installed.)
Preparing to unpack .../libftgl2_2.1.3~rc5-4+nmu1_amd64.deb ...
Unpacking libftgl2:amd64 (2.1.3~rc5-4+nmu1) ...
Selecting previously unselected package libqt4-sql-sqlite:amd64.
Preparing to unpack .../libqt4-sql-sqlite_4%3a4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1_amd64.deb ...
Unpacking libqt4-sql-sqlite:amd64 (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Selecting previously unselected package libqxt-core0:amd64.
Preparing to unpack .../libqxt-core0_0.6.2-1+b1_amd64.deb ...
Unpacking libqxt-core0:amd64 (0.6.2-1+b1) ...
Selecting previously unselected package libqxt-gui0:amd64.
Preparing to unpack .../libqxt-gui0_0.6.2-1+b1_amd64.deb ...
Unpacking libqxt-gui0:amd64 (0.6.2-1+b1) ...
Selecting previously unselected package python-bluez.
Preparing to unpack .../python-bluez_0.22-1mx15+1_amd64.deb ...
Unpacking python-bluez (0.22-1mx15+1) ...
Preparing to unpack .../bluez_5.43-1mx15+2_amd64.deb ...
Unpacking bluez (5.43-1mx15+2) over (5.23-2+b1) ...
Selecting previously unselected package libimobiledevice6:amd64.
Preparing to unpack .../libimobiledevice6_1.2.0+dfsg-3mx15+1_amd64.deb ...
Unpacking libimobiledevice6:amd64 (1.2.0+dfsg-3mx15+1) ...
Selecting previously unselected package libmygpo-qt1:amd64.
Preparing to unpack .../libmygpo-qt1_1.0.9~git20151122-1mx150+1_amd64.deb ...
Unpacking libmygpo-qt1:amd64 (1.0.9~git20151122-1mx150+1) ...
Selecting previously unselected package libprojectm2.
Preparing to unpack .../libprojectm2_2.1.0+dfsg-1+b1_amd64.deb ...
Unpacking libprojectm2 (2.1.0+dfsg-1+b1) ...
Preparing to unpack .../clementine_1.3.1+git240-g1a2f6e2+dfsg-1mx15+1_amd64.deb ...
Unpacking clementine (1.3.1+git240-g1a2f6e2+dfsg-1mx15+1) over (1.3.1-0mx150+1) ...
Processing triggers for dbus (1.8.22-0+deb8u1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for systemd (215-17+deb8u6) ...
Processing triggers for libc-bin (2.19-18+deb8u7) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Processing triggers for gconf2 (3.2.6-3) ...
Setting up libftgl2:amd64 (2.1.3~rc5-4+nmu1) ...
Setting up libqt4-sql-sqlite:amd64 (4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1) ...
Setting up libqxt-core0:amd64 (0.6.2-1+b1) ...
Setting up libqxt-gui0:amd64 (0.6.2-1+b1) ...
Setting up python-bluez (0.22-1mx15+1) ...
Setting up bluez (5.43-1mx15+2) ...
Installing new version of config file /etc/bluetooth/main.conf ...
Installing new version of config file /etc/dbus-1/system.d/bluetooth.conf ...
[ ok ] Reloading system message bus config...done.
[ ok ] Stopping bluetooth: /usr/sbin/bluetoothd.
[ ok ] Starting bluetooth: bluetoothd.
Setting up libimobiledevice6:amd64 (1.2.0+dfsg-3mx15+1) ...
Setting up libmygpo-qt1:amd64 (1.0.9~git20151122-1mx150+1) ...
Setting up libprojectm2 (2.1.0+dfsg-1+b1) ...
Setting up clementine (1.3.1+git240-g1a2f6e2+dfsg-1mx15+1) ...
Processing triggers for libc-bin (2.19-18+deb8u7) ...
Processing triggers for dbus (1.8.22-0+deb8u1) ...


Seems like the problem was fixed by something in the routine done as gimcrack recommended (viewtopic.php?p=407465&sid=1eda2922c0bb3456274576a83e31f322#p407465) plus the

Code: Select all

sudo apt-get dist-upgrade


(I finally got that one right :-)).

Thanks to you all, but what does that mean - why did this error occur in the first place?


Greetings, Joe

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1726
Joined: Sat Jan 16, 2016 8:20 pm

Re: Can't perform dist-upgrade because packages cannot be authenticated

#12 Postby v3g4n » Tue Feb 14, 2017 2:15 pm

My guess is it was more than likely a communications issue with one of the mirrors, possibly do to syncing. Usually just waiting a while and trying again later works. Nothing major to worry about, but if it is a MX mirror it is nice to know just in case there is an issue.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 12681
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Re: Can't perform dist-upgrade because packages cannot be authenticated

#13 Postby Stevo » Tue Feb 14, 2017 3:04 pm

Those package upgrades that could not be authenticated were coming from Debian, so there must have been a temporary issue with their repository or keyring somehow. Every so often, they have a hiccup.

User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 193
Joined: Mon Feb 13, 2017 12:09 pm

Re: Can't perform dist-upgrade because packages cannot be authenticated

#14 Postby MX-16_fan » Mon Feb 20, 2017 10:28 am

v3g4n wrote:Nothing major to worry about, but if it is a MX mirror it is nice to know just in case there is an issue.


Thanks for the hint, I will try not to forget to keep an eye on it if I see that an MX repo is concerned next time. Greetings, Joe

User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 193
Joined: Mon Feb 13, 2017 12:09 pm

Re: Can't perform dist-upgrade because packages cannot be authenticated

#15 Postby MX-16_fan » Mon Feb 20, 2017 10:32 am

@Stevo:

Stevo wrote:Those package upgrades that could not be authenticated were coming from Debian, so there must have been a temporary issue with their repository or keyring somehow. Every so often, they have a hiccup.


Thanks for the info. I wasn't aware of that. I used to think that everything that comes from Debian would be super-solid and that their infrastructure is cleaner than anything else, so I could not have imagined the answer could be so simple.

As far as I am concerned, this can be marked as "solved" here.

Thanks to everybody else, too, Joe

User avatar
Paul..
Forum Guide
Forum Guide
Posts: 1854
Joined: Sun Mar 18, 2007 6:34 pm

Re: Can't perform dist-upgrade because packages cannot be authenticated

#16 Postby Paul.. » Mon Feb 20, 2017 1:31 pm

Hi Joe, just edit your original post title and append with [Solved]...Thanks.

Daily: MSI 890FXA-GD70 | AMD Phenom II X6 1055T | GeForce GTX 750 Ti | 8G
Test: Dell Inspiron 20 3043 | Intel quad N3530 | Intel Atom Graphics | 4G
Test: Thinkpad T431s | Intel i5-3437U | Intel 3rd gen Graphics | 4G

User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 193
Joined: Mon Feb 13, 2017 12:09 pm

Re: Can't perform dist-upgrade because packages cannot be authenticated

#17 Postby MX-16_fan » Thu May 11, 2017 1:56 pm

@Paul..:

Paul.. wrote:Hi Joe, just edit your original post title and append with [Solved]...Thanks.


Done :happy: . Greetings, Joe


Return to “Software / Configuration”

Who is online

Users browsing this forum: No registered users and 2 guests