Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[Solved] Black Screen Suspend - No Brightness Settings?

Post Reply
Message
Author
rej
Forum Regular
Forum Regular
Posts: 138
Joined: Thu Mar 09, 2017 11:11 pm

[Solved] Black Screen Suspend - No Brightness Settings?

#1 Post by rej » Wed May 16, 2018 1:31 pm

A Thinkpad T520 with MX17.1 installed, does not respond to any settings for display brightness.

When it is returning from "Suspend", it goes completely black and must be powered off. No curser, no blinking light.

When re-booted, it returns with a brightness, not optimal, but usable - somewhat dim. This PC usually has a nice bright screen with MX.

It is dual booted with AntiX17 and AntiX works well - brightness keys, slider bar, suspend and startup. Both Snapshots were installed to this device on the same day.

This is a larger new Western Digital hard drive, which is the reason the re-installs were needed and on each snapshot, when installing, got the message that GSmart thought it would soon fail. Extended and short GSmart Control tests and outside tests in Windows With Seatools extended and short tests, Western Digital Lifeguard Diagnostics extended test, and CrystalDiskInfo - passed with no errors. [more than 10 tests]

Unchecked "handle brightness keys" and "lock screen on suspend". Installed xbacklight and it does not show up in applications.

I have the file "/etc/modprobe.d/i915.conf" - options i915 invert_brightness=1.

Tried installing kernel 4.9.91 - same issue.

MX was installed with a Snapshot from a T420 where everything works correctly and have done this many times on this T520 with no issues. AntiX was installed from a T420 Snapshot also.

Tried to start over and re-install completely from the latest download @ sourceforge - the live usb did the same thing - no way to adjust the screen brightness, yet it was even dimmer - almost unusable.

At this point, I would guess it was a hardware issue, if AntiX did not work perfectly - it does though.

Any help with this would be much appreciated.

Thank you.
----------------------------------
System:
Host: mx17.1 Kernel: 4.15.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17.1_x64 Horizon December 15, 2017
Machine:
Type: Laptop System: LENOVO product: 4239CTO v: ThinkPad T520 serial: N/A
Mobo: LENOVO model: 4239CTO serial: N/A UEFI [Legacy]: LENOVO
v: 8AET65WW (1.45 ) date: 05/14/2015
Battery:
ID-1: BAT0 charge: 54.9 Wh condition: 54.9/93.2 Wh (59%)
CPU:
Topology: Dual Core model: Intel Core i7-2640M bits: 64 type: MT MCP
L2 cache: 4096 KiB
Speed: 1949 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 797 2: 796
3: 797 4: 798
Graphics:
Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics
driver: i915 v: kernel
Card-2: NVIDIA GF119M [Quadro NVS 4200M] driver: nouveau v: kernel
Display: x11 server: X.Org 1.19.2 driver: modesetting,nouveau
unloaded: fbdev,nv,vesa resolution: 1600x900~60Hz
OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 13.0.6
Audio:
Card-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel
Sound Server: ALSA v: k4.15.0-1-amd64
Network:
Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
IF: eth0 state: down mac: f0:de:f1:d1:27:38
Card-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi
IF: wlan0 state: up mac: 24:77:03:46:d5:64
Drives:
HDD Total Size: 298.09 GiB used: 10.35 GiB (3.5%)
ID-1: /dev/sda vendor: Seagate model: ST320LM010-1KJ15C size: 298.09 GiB
Partition:
ID-1: / size: 38.20 GiB used: 10.35 GiB (27.1%) fs: ext4 dev: /dev/sda3
Sensors:
System Temperatures: cpu: 37.0 C mobo: N/A gpu: nouveau temp: 36 C
Fan Speeds (RPM): cpu: 0
Info:
Processes: 193 Uptime: 11m Memory: 7.68 GiB used: 442.1 MiB (5.6%)
Shell: bash inxi: 3.0.08
Last edited by rej on Sat May 19, 2018 2:36 pm, edited 1 time in total.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21644
Joined: Wed Jul 19, 2006 6:13 am

Re: Black Screen Suspend - No Brightness Settings?

#2 Post by Jerry3904 » Wed May 16, 2018 2:44 pm

First thing I would try is to use the Nvidia Driver Installer and switch to the proprietary driver. On my production machine that is what I had to do to settle things down after suspend--which I use all the time.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

rej
Forum Regular
Forum Regular
Posts: 138
Joined: Thu Mar 09, 2017 11:11 pm

Re: Black Screen Suspend - No Brightness Settings?

#3 Post by rej » Thu May 17, 2018 1:04 am

Hi Jerry-

Thank you.

Tried Nvidia installer in MX Tools and it appears to have failed the installation. Not much knowledge of drivers and more than likely I did something wrong, but here's the terminal copy of the installation attempt:
-------------------------
About to execute /usr/local/bin/ddm-mx -i nvidia.
This command needs root privileges to be executed.
Using su...
Enter root password at prompt.
Password:
creating lock ...
===================================
Install drivers for: nvidia
Start at (m/d/y): 05/17/2018 00:28:42
===================================


Candidate is: 384.111-3~~mx17+1
Installed is: (none)

Would you like to check debian-backports for a later version?

Yes or No?

1: Yes
2: No

Enter Number of selection
1
Ok...
Enabling backports repo
Running apt-get update...
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable Release
Hit:3 http://mxrepo.com/mx/repo stretch InRelease
Hit:4 http://repo.antixlinux.com/stretch stretch InRelease
Hit:5 http://ftp.us.debian.org/debian stretch-updates InRelease
Get:6 http://ftp.debian.org/debian stretch-backports InRelease [91.8 kB]
Ign:7 http://ftp.us.debian.org/debian stretch InRelease
Hit:8 http://ftp.us.debian.org/debian stretch Release
Hit:10 http://security.debian.org stretch/updates InRelease
Get:12 http://ftp.debian.org/debian stretch-backports/main amd64 Packages [324 kB]
Get:13 http://ftp.debian.org/debian stretch-backports/main i386 Packages [320 kB]
Get:14 http://ftp.debian.org/debian stretch-backports/main Translation-en [238 kB]
Get:15 http://ftp.debian.org/debian stretch-backports/contrib i386 Packages [7,300 B]
Get:16 http://ftp.debian.org/debian stretch-backports/contrib amd64 Packages [7,284 B]
Get:17 http://ftp.debian.org/debian stretch-backports/contrib Translation-en [5,877 B]
Get:18 http://ftp.debian.org/debian stretch-backports/non-free amd64 Packages [17.8 kB]
Get:19 http://ftp.debian.org/debian stretch-backports/non-free i386 Packages [18.5 kB]
Get:20 http://ftp.debian.org/debian stretch-backports/non-free Translation-en [24.1 kB]
Fetched 1,054 kB in 2s (450 kB/s)
Reading package lists...

Installing latest nvidia-detect package

Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be upgraded:
nvidia-detect
1 upgraded, 0 newly installed, 0 to remove and 99 not upgraded.
Need to get 191 kB of archives.
After this operation, 19.5 kB of additional disk space will be used.
Get:1 http://ftp.debian.org/debian stretch-backports/non-free amd64 nvidia-detect amd64 390.48-2~bpo9+3 [191 kB]
dpkg-preconfigure: unable to re-open stdin: No such file or directory
Fetched 191 kB in 0s (277 kB/s)
(Reading database ... 333984 files and directories currently installed.)
Preparing to unpack .../nvidia-detect_390.48-2~bpo9+3_amd64.deb ...
Unpacking nvidia-detect (390.48-2~bpo9+3) over (384.111-3~~mx17+1) ...
Setting up nvidia-detect (390.48-2~bpo9+3) ...

Main repo candidate is: 384.111-3~~mx17+1
Debian backports candidate is: 390.48-2~bpo9+3
Installed is: (none)

Which driver do you wish to install

Main repos or debian-backports?

1: Main 384.111-3~~mx17+1

2: debian-backports 390.48-2~bpo9+3

3: Exit

Enter Number of selection
1
Ok...



Need driver: nvidia-driver (390.48-2~bpo9+3)
packages to install are nvidia-driver nvidia-settings nvidia-kernel-dkms nvidia-xconfig

Continue?
1) yes (default)
2) no
Press <Enter> for the default entry
Use 'q' to quit

Frontend:
Nvidia command = apt-get install --reinstall -y --force-yes nvidia-driver nvidia-settings nvidia-kernel-dkms nvidia-xconfig
Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 3 reinstalled, 0 to remove and 3 not upgraded.
Need to get 488 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://ftp.us.debian.org/debian stretch/main amd64 build-essential amd64 12.3 [7,346 B]
Get:2 http://mxrepo.com/mx/repo stretch/non-free amd64 firmware-linux-nonfree all 20170823-1mx17+1 [14.9 kB]
Get:3 http://mxrepo.com/mx/repo stretch/main amd64 linux-headers-4.15.0-1-amd64 amd64 4.15.4-1~mx17+1 [465 kB]
dpkg-preconfigure: unable to re-open stdin: No such file or directory
Fetched 488 kB in 0s (631 kB/s)
(Reading database ... 333988 files and directories currently installed.)
Preparing to unpack .../build-essential_12.3_amd64.deb ...
Unpacking build-essential (12.3) over (12.3) ...
Preparing to unpack .../firmware-linux-nonfree_20170823-1mx17+1_all.deb ...
Unpacking firmware-linux-nonfree (20170823-1mx17+1) over (20170823-1mx17+1) ...
Preparing to unpack .../linux-headers-4.15.0-1-amd64_4.15.4-1~mx17+1_amd64.deb ...
Unpacking linux-headers-4.15.0-1-amd64 (4.15.4-1~mx17+1) over (4.15.4-1~mx17+1) ...
Setting up build-essential (12.3) ...
Setting up firmware-linux-nonfree (20170823-1mx17+1) ...
Setting up linux-headers-4.15.0-1-amd64 (4.15.4-1~mx17+1) ...
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgl1 : Depends: libglx0 (= 1.0.0+git20180308-2~bpo9+1) but it is not going to be installed
nvidia-driver : Depends: nvidia-driver-libs (= 384.111-3~~mx17+1) but it is not going to be installed or
nvidia-driver-libs-nonglvnd (= 384.111-3~~mx17+1) but it is not going to be installed
Depends: nvidia-driver-bin (= 384.111-3~~mx17+1) but it is not going to be installed
Depends: xserver-xorg-video-nvidia (= 384.111-3~~mx17+1) but it is not going to be installed
Depends: nvidia-vdpau-driver (= 384.111-3~~mx17+1) but it is not going to be installed
Depends: nvidia-alternative (= 384.111-3~~mx17+1)
Recommends: nvidia-persistenced
nvidia-kernel-dkms : Depends: nvidia-kernel-support--v1
nvidia-settings : Depends: nvidia-alternative
Recommends: libgl1-nvidia-glvnd-glx but it is not going to be installed or
libgl1-nvidia-glx but it is not going to be installed
Recommends: nvidia-vdpau-driver but it is not going to be installed
Recommends: libnvidia-ml1 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
/usr/local/bin/ddm-mx: line 460: creating /etc/X11/xorg.conf file: No such file or directory
/usr/local/bin/ddm-mx: line 461: nvidia-xconfig: command not found
Finished


Hit:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:3 http://ftp.us.debian.org/debian stretch-updates InRelease
Ign:4 http://ftp.us.debian.org/debian stretch InRelease
Hit:5 http://repo.antixlinux.com/stretch stretch InRelease
Hit:6 http://ftp.us.debian.org/debian stretch Release
Hit:7 http://dl.google.com/linux/chrome/deb stable Release
Hit:8 http://mxrepo.com/mx/repo stretch InRelease
Reading package lists... Done

Press <Enter> to exit

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 5546
Joined: Wed Jul 12, 2006 2:10 am

Re: Black Screen Suspend - No Brightness Settings?

#4 Post by Eadwine Rose » Thu May 17, 2018 3:42 am

A tip: long bits of terminal and such output text can best be included using the code tags. You can use the </> button (next to the quotes one), or enter your text between these:

[code.]your text here[/code].

Omit the . in the first code tag to get it to work. :)
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.111 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 8498
Joined: Sun Dec 16, 2007 1:17 pm

Re: Black Screen Suspend - No Brightness Settings?

#5 Post by dolphin_oracle » Thu May 17, 2018 8:17 am

kicking this dependency problem up to stevo. I thought we had that fixed.

you can do

Code: Select all

sudo ddm-mx -p nvidia
to purge out nvidia driver stuff and reverse any changes.
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 17 32 bit (streaming media player)
lenovo ThinkPad T530 - MX-17
lenovo s21e - antiX-17, MX17(live-usb)

rej
Forum Regular
Forum Regular
Posts: 138
Joined: Thu Mar 09, 2017 11:11 pm

Re: Black Screen Suspend - No Brightness Settings?

#6 Post by rej » Thu May 17, 2018 12:21 pm

Eadwine Rose-

Thanks for the tip! I had initially tried to attach a terminal screenshot, which can only be the size of the terminal interface, but when I selected the file to attach, there was a notification saying the file was too large. Tried again and the same result. So thank you - will look for your suggestion next time.

D.O.-

Thank you - was wondering if and how the driver could be purged if it had not worked out. However, I was looking around for other reasons for the screen issue that I might have missed in Power Manager settings and was experimenting with the "Handle display brightness keys",forgot to reset it to "unchecked" and rebooted.

On the reboot, the files started loading and went to a totally black screen less than halfway through it and never recovered. Tried to reboot several times with the same results. No cursor - just black. Even though I had in the interim, managed to get the brightness function keys to work (but not the slider bar settings..), these were also not usable. I had to re-install, so the partially installed driver is no longer there.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15424
Joined: Fri Dec 15, 2006 8:07 pm

Re: Black Screen Suspend - No Brightness Settings?

#7 Post by Stevo » Thu May 17, 2018 2:08 pm

We can't help with whatever stretch-backports has in their repo. How about if you try enabling our test repo manually (can be done in a GUI in Synaptic) and see if you can install our own backported 390.48 instead?

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 8498
Joined: Sun Dec 16, 2007 1:17 pm

Re: Black Screen Suspend - No Brightness Settings?

#8 Post by dolphin_oracle » Thu May 17, 2018 2:12 pm

Stevo wrote:
Thu May 17, 2018 2:08 pm
We can't help with whatever stretch-backports has in their repo. How about if you try enabling our test repo manually (can be done in a GUI in Synaptic) and see if you can install our own backported 390.48 instead?
note the user tried to install the 384 drivers. the message in the "Need driver" area of the ddm-mx output is incorrect. I'll have to fix that. All the apt messages,including nvidia-driver, indicate 384

Code: Select all

nvidia-driver : Depends: nvidia-driver-libs (= 384.111-3~~mx17+1) but it is not going to be installed

Code: Select all

Main repo candidate is: 384.111-3~~mx17+1
Debian backports candidate is: 390.48-2~bpo9+3
Installed is: (none)

Which driver do you wish to install

Main repos or debian-backports?

1: Main 384.111-3~~mx17+1

2: debian-backports 390.48-2~bpo9+3

3: Exit

Enter Number of selection
1
Ok...



Need driver: nvidia-driver (390.48-2~bpo9+3)
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 17 32 bit (streaming media player)
lenovo ThinkPad T530 - MX-17
lenovo s21e - antiX-17, MX17(live-usb)

rej
Forum Regular
Forum Regular
Posts: 138
Joined: Thu Mar 09, 2017 11:11 pm

Re: Black Screen Suspend - No Brightness Settings?

#9 Post by rej » Sat May 19, 2018 2:30 pm

Upon fresh install of MX17.1 April I.S.O. from Sourceforge, to a separate partition and restarting to find the black screen - rebooted again and had enough light to fish around and find the panel and get a faint hint of the power manager settings - enough to un-check the "handle display brightness keys", and once there was enough backlight, found that about 50% of everything clicked on did not function - logout, suspend, updater, etc. Terminal did work and was able to upgrade and update through there.

Powered off and after reboot, everything, little by little settled in and worked normally - including Suspend. The "handle display brightness keys" still needs to be unchecked. Otherwise over all, seems to work quite well. Installed apps and customized flawlessly.

Although various extensive tests were done including the one suggested on the notification with Gsmart control, and found 0 errors - passing all, I still wonder if there is something there.

The last time the installation indicated this on a brand new hard drive, it was accurate - the drive had errors on every extended test.

Probably best to see if another HD will be the cure.

Thanks so very much for your time and help.

Post Reply

Return to “Software / Configuration”