Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX-17/MX-17.1 issue: No laptop monitor after prior "beamer" (AKA video projector) session (on RK886EX)

Post Reply
Message
Author
User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 917
Joined: Mon Feb 13, 2017 12:09 pm

MX-17/MX-17.1 issue: No laptop monitor after prior "beamer" (AKA video projector) session (on RK886EX)

#1 Post by MX-16_fan » Mon Mar 12, 2018 6:29 pm

EDIT: Added "MX-17.1" to the heading of this original posting, after having tested this with MX-17.1 also.


@all:

I'm currently testing MX-17 on a roda Rocky III+ (AKA roda Rocky RK886EX) (see project overview in this thread: http://forum.mxlinux.org/viewtopic.php?f=108&t=43892), which IMHO is one of the best computers ever built.

The monitor works o.k.

When I attach a beamer via DVI output -> HDMI input, that's o.k. also. Talking about this: This doesn't work if the beamer is attached during startup, but that seems to be a minor problem.

The main problem is that when I shut down the machine after a "beamer only" session and reboot afterwards, I get no login screen. The machine seems to be forever fixed on having a beamer attached as the primary and only monitor device. This is really bad. Feels like Linux year 2001 or something.

As you probably know, I've posted a great number of links to manuals, specifications etc. at http://forum.mxlinux.org/viewtopic.php?f=108&t=43892. However, I can't even see any shortcut for switching display outputs in any of those documents. (Having some relating shortcut available would provide some kind of workaround, hope I didn't overlook anything.)

Best thing IMHO would be that the built-in display is the default-on-startup device. Else one should have some GUI option to define this available.

Looking forward to your comments, and advice.


Greetings, and thanks in advance, Joe
Last edited by MX-16_fan on Mon Mar 19, 2018 9:41 pm, edited 2 times in total.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9066
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX-17 issue: No laptop monitor after prior beamer session (on RK886EX)

#2 Post by dolphin_oracle » Mon Mar 12, 2018 6:32 pm

I don't know what a beamer is, but I would check display settings in Menu->Display and make sure the device you want to be primary is set to be primary.

You will need to do that while your non-primary device is plugged in.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 917
Joined: Mon Feb 13, 2017 12:09 pm

Re: MX-17 issue: No laptop monitor after prior beamer session (on RK886EX)

#3 Post by MX-16_fan » Mon Mar 12, 2018 7:23 pm

@dolphin_oracle:
dolphin_oracle wrote:I don't know what a beamer is (...)
Marketing slang for "video projector". I'll see if I can give a hint in the original posting's heading. Greetings, Joe
Last edited by MX-16_fan on Mon Mar 12, 2018 7:28 pm, edited 1 time in total.

User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 917
Joined: Mon Feb 13, 2017 12:09 pm

Re: MX-17 issue: No laptop monitor after prior beamer session (on RK886EX)

#4 Post by MX-16_fan » Mon Mar 12, 2018 7:28 pm

@dolphin_oracle:
dolphin_oracle wrote:(...) I would check display settings in Menu->Display and make sure the device you want to be primary is set to be primary. You will need to do that while your non-primary device is plugged in.
Had that setting all the time while that problem occured. Greetings, Joe

User avatar
rokytnji.1
Forum Regular
Forum Regular
Posts: 745
Joined: Sun Apr 13, 2014 9:06 pm

Re: MX-17 issue: No laptop monitor after prior "beamer" (AKA video projector) session (on RK886EX)

#5 Post by rokytnji.1 » Tue Mar 13, 2018 7:40 am

Back when I was running a Amrel. The external monitor setting was in the bios. You might want to look in there. Experiment with the settings in there.

User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 917
Joined: Mon Feb 13, 2017 12:09 pm

Re: MX-17 issue: No laptop monitor after prior "beamer" (AKA video projector) session (on RK886EX)

#6 Post by MX-16_fan » Tue Mar 13, 2018 12:43 pm

@rokytnji.1:
rokytnji.1 wrote:Back when I was running a Amrel. The external monitor setting was in the bios. You might want to look in there. Experiment with the settings in there.
Indeed I had some option for that with the original buggy BIOS, but none any more after BIOS update (viewtopic.php?t=44210). I suppose the manufacturer became convinced that external monitors should be handled by the operating system only.

Greetings, Joe

User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 917
Joined: Mon Feb 13, 2017 12:09 pm

Re: MX-17 issue: No laptop monitor after prior "beamer" (AKA video projector) session (on RK886EX)

#7 Post by MX-16_fan » Mon Mar 19, 2018 9:49 pm

UPDATE:

1) Issue prevails in MX-17.1.

2) The machine's manual says that "[Fn] + [F9]" is to be the key combination for calling "switch to external monitor / switch to LCD / switch to both monitors". However, this key combination is being ignored by MX-17.1 (didn't test this with MX-17). Could this somehow be implemented permanently into MX-17.1 (in combination with MX-17.1's hardware detection)? At least this would provide a workaround option, plus (of course) provide the function intended by the machine's manufacturer.


Greetings, Joe

Post Reply

Return to “Software / Configuration”