Welcome!

Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17 Final release info here
  • MX-16.1 release info here
  • antiX-17 release info here
    New users
    • Please read this first, and don't forget to add system and hardware information to posts!
    • Read Forum Rules

Sylpheed 3.6.0: How to correct wrong MIME type assignments for IMAP-stored e-mail attachments?

Message
Author
User avatar
MX-16_fan
Forum Regular
Forum Regular
Posts: 542
Joined: Mon Feb 13, 2017 12:09 pm

Sylpheed 3.6.0: How to correct wrong MIME type assignments for IMAP-stored e-mail attachments?

#1 Postby MX-16_fan » Wed Dec 06, 2017 1:03 pm

@all:

Just wanted to print out some documents which I had in the "Sent" folder of some IMAP account, using the fantastic Sylpheed (https://en.wikipedia.org/wiki/Sylpheed) 3.6.0 for MX-16.1 that Stevo thankworthily built for the MX Test Repo.

Now I noticed that MX-16.1 couldn't properly open a number of PDF files attached to various e-mails. I tried to open them using both evince and okular. PDFs where opened with broken graphics and no visible text at all. Apart from that, the file sizes of documents downloaded from Sylpheed where significantly smaller than the file sizes of the original files.

I tried to debug this and I noticed that all of these mails had been sent using Thunderbird, which by then after some update seemed to be severely going down the road and showed a number of severe errors I had never seen before. One of these errors was that PDFs where "displayed" in the main e-mail window as scrambled text.

According to Sylpheed's old manual (http://sylpheeddoc.sourceforge.net/en/0 ... ed-13.html), the correct MIME type for PDFs is "application/pdf".

In the e-mails that are causing trouble, however, the MIME type of the PDFs in question is shown as "text/plain", or, in at least one case, "application/binary".

Looks to me as if these garbage MIME type assignments have been done by Thunderbird. Sylpheed probably only reads this stuff but doesn't change anything on old mails.

Note that Thunderbird messed this up even though all PDFs had been generated in some super-standard way using some Linux-based OS, and even though they all had "*.pdf" file extensions.

So my question is: Is there a GUI way of cleanly correcting the MIME type while preserving all the rest of the data (especially the time stamp of the e-mails)?

I remember having clicked on some attachment in Sylpheed and getting what looked like a window for editing the MIME type information, but I can't reproduce this unfortunately.


Greetings, and thanks in advance for any hint, Joe

Return to “Software / Configuration”

Who is online

Users browsing this forum: timkb4cq and 4 guests