Welcome!
Forum users
  • Please read this before asking for help, and don't forget to add Quick System Info to help requests!
  • Please follow the Forum Rules

Current releases
--MX-21 release info here
--Migration information to MX-21 here
--antiX-21 (Grup Yorum) release info here

Important information
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- New Forum Features, Marking Solved and Referencing a User: here

Numlock "." instead of ","  [Solved]

Post Reply
Message
Author
Matt
Posts: 6
Joined: Mon Jun 07, 2021 6:40 am

Numlock "." instead of ","  [Solved]

#1 Post by Matt »

Hi,
on my Apple Keyboard (german) I've got a Numblock. This works well so far. Only "." puts an ",", but I wanted the dot to work with. Where and how can I change that. Thanks a lot for your help in advance.

User avatar
radonrose
Posts: 217
Joined: Thu Dec 12, 2019 7:59 am

Re: Numlock "." instead of ","

#2 Post by radonrose »

Which keyboards layouts are you switching between? Decimal separators differ by country, and that is reflected on keyboard layouts (map).

Assuming you are on MX XFCE, open Keyboard Layouts, and in the first tab Layouts you might find what you need. Are you looking for a German layout that has a thousand separator (dot) in the numpad instead of a decimal separator (comma)? If you can't find some specific layout for this, some remapping would be possible.

PS: This tab also has a menu of several popular keyboards, including some Mac ones. I can't say more about this, as the Generic 105 always has worked for me.
AND1s, tuna, blast processing.
Αν δε βρίσκεις αυτό που ψάχνεις στα Ελληνικά, στείλε μου μήνυμα. Ίσως μπορώ να βοηθήσω.

Matt
Posts: 6
Joined: Mon Jun 07, 2021 6:40 am

Re: Numlock "." instead of ","

#3 Post by Matt »

Hi radonrose,
thanx a lot for your quick response. Your informations are the ones I needed!
Kind regards, Matt.
PS: Yes, I'm an MX XFCE and use the Generic 105.

User avatar
fehlix
Developer
Posts: 9509
Joined: Wed Apr 11, 2018 5:09 pm

Re: Numlock "." instead of ","

#4 Post by fehlix »

Within Session & Startup ("Sitzung und Startverhalten") adding a new autostart entry:
with a setxkbmap command to set numerical keypad to have "dot" instead of a comma for German keyboard layout after login:

Code: Select all

setxkbmap -option kpdl:dot
For one time use:
Open command prompt with Alt+F2 and type shown command.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “Hardware /Configuration”