Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

BT problem with mouse MS3600

P5music
Forum Novice
Forum  Novice
Posts: 19
Joined: Mon Jan 14, 2019 10:34 am

BT problem with mouse MS3600

#1

Post by P5music » Tue Jan 22, 2019 3:00 pm

Hello,
My system is Asus S300CA with MXLinux 18.
With every Linux distro I have problems with bluetooth.
It works the first times I boot the system but after some days or after some hard reset has occurred it is not able to discover my mouse MS3600 anymore. Often the bluetooth adapter is not enabled and cannot be activated.
I wonder why it is so difficult for Linux, and MXLinux is no exception, to handle the bluetooth on this machine.
I hope you can help me with some special startup command or diagnostic.
What's the state now: bluetooth is working and a BT headphone is playing but mouse is not recognized.
Thanks in advance

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 25364
Joined: Wed Jul 19, 2006 6:13 am

Re: BT problem with mouse MS3600

#2

Post by Jerry3904 » Tue Jan 22, 2019 3:12 pm

What is the output of this command:

Code: Select all

hcitool scan
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

P5music
Forum Novice
Forum  Novice
Posts: 19
Joined: Mon Jan 14, 2019 10:34 am

Re: BT problem with mouse MS3600

#3

Post by P5music » Tue Jan 22, 2019 3:22 pm

The output is

Code: Select all

Scanning ...
	AC:07:5F:91:24:D4	HUAWEI P20 lite
	88:36:5F:30:C7:E5	LG-G351
Only some smartphones are displayed.
I turned on the mouse and the BT headphone.
Same result if the mouse is in "discovering mode".

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 25364
Joined: Wed Jul 19, 2006 6:13 am

Re: BT problem with mouse MS3600

#4

Post by Jerry3904 » Tue Jan 22, 2019 3:50 pm

Thanks. I see from a websearch on "linux ms3600" that there are many complaints, but apparently a few successes. The problem supposedly stems from the fact that the mouse is a LE or low-energy device. This thread looks promising, for instance, if you haven't seen it already:

https://forums.linuxmint.com/viewtopic.php?t=229361
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

P5music
Forum Novice
Forum  Novice
Posts: 19
Joined: Mon Jan 14, 2019 10:34 am

Re: BT problem with mouse MS3600

#5

Post by P5music » Tue Jan 22, 2019 4:02 pm

Thank you @Jerry3904 , it seems to be working. I will check on reboot too.

P5music
Forum Novice
Forum  Novice
Posts: 19
Joined: Mon Jan 14, 2019 10:34 am

Re: BT problem with mouse MS3600

#6

Post by P5music » Wed Jan 23, 2019 7:52 am

At reboot I found the bluetooth turned off.
So I turned it on from the menu on the taskbar. But now it seems disabled, and If I try to open the applet it says no adapter found (blueman assistant) in a little window with a button "window-close".
This is what I described in the original post. The mouse was working with the suggested workaround. Just a reboot occurred.
What diagnostic can I do now?

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 25364
Joined: Wed Jul 19, 2006 6:13 am

Re: BT problem with mouse MS3600

#7

Post by Jerry3904 » Wed Jan 23, 2019 10:30 am

Not sure at this point. If it were me, given that you have had problems with many other Linux distros and that there are so many complaints in a web search, I would go crazy and simply spend about $15 to buy a Logitech BT mouse.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

P5music
Forum Novice
Forum  Novice
Posts: 19
Joined: Mon Jan 14, 2019 10:34 am

Re: BT problem with mouse MS3600

#8

Post by P5music » Wed Jan 23, 2019 11:18 am

@Jerry3904
I do not agree on this point. Take into account that the bluetooth-adapter problem is blocking for my entire set of bluetooth devices.
And I am not going to use a separate usb bt adapter.

P5music
Forum Novice
Forum  Novice
Posts: 19
Joined: Mon Jan 14, 2019 10:34 am

Re: BT problem with mouse MS3600

#9

Post by P5music » Thu Jan 24, 2019 3:38 pm

However, it seems that it is still working after a couple of power-cycles.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 25364
Joined: Wed Jul 19, 2006 6:13 am

Re: BT problem with mouse MS3600

#10

Post by Jerry3904 » Thu Jan 24, 2019 4:39 pm

So what steps did you take exactly since your opening post?
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

Post Reply

Return to “Hardware /Configuration”