Page 1 of 1

USB HDD invalid partition table - how to recover?

Posted: Thu Jan 10, 2019 10:51 am
by lalix
Dear Team,

I did one of the biggest mess someone could do.
I am using MX 18. I wanted to make a regular bootable pendive (without persistence) with MX live USB maker. The ISO file was on my backup HDD connected via usb, and I was not carefully enough by choosing the right drive, so it was written to the backup HDD. So far I could realize as long the system was running, I had access to the files (in the meanwhile the kids were looking at some videos from that HDD), so I bought quickly another HDD in the hope I can copy the entire data from the original.
Unfortunately when I was not home there must have been some failure (perhaps electricity or anything else) and the system was restarted. Since there was no flag for booting from USB I don't know if the live linux is working or not, but when I searched the backup HDD I couldn't find it anymore. Further there was no other drive detected.
I tried gparted whether it can recognize anything, but after some time there was an error message: "invalid partition table - recursive partition on /dev/sdb
I googled for some solution but there were topics basicly to get working the HDD again, not to rescue data. I got some suggestions to try UBCD and System rescue CD, too. There is a large amount of data, about 3TB family pics and videos and some other stuff from the past 8 years I'd be very happy to get them back.
What is your suggestion how shall I start not to do it more worse?

Re: USB HDD invalid partition table - how to recover?

Posted: Thu Jan 10, 2019 11:26 am
by fehlix
You can try to recover some data with testdisk's photorec
testdisk might also helps to reconstrcut the orignal partition table entries.
Depends on what alreday have been written to the hdd. If only formated the
chance is high to revover most files. If already installed to the hdd, those overwritten files
are lost.
You can run both test disk and photorec from the terminal command line booted with MX LiveUSB.
:puppy:

Re: USB HDD invalid partition table - how to recover?

Posted: Sat Jan 12, 2019 9:04 am
by lalix
I did not write anything to the HDD, except that live iso. That should be about 1 GB. I run a test now with similar conditions to see if I understand Testdisk/Photorec and do it the correct way. This seems to take some time.