Welcome!
Important information
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-18 Final release info here
-- Migration Information to MX-18 here
-- antiX-17.3 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] Brightness: acpi_video0 & intel_backlight

Post Reply
alcornoqui
Forum Novice
Forum  Novice
Posts: 5
Joined: Wed Aug 08, 2018 8:34 am

[SOLVED] Brightness: acpi_video0 & intel_backlight

#1

Post by alcornoqui » Thu Jan 10, 2019 7:59 am

[Cross-posted in Xfce forums, 'coz ToZ]

Hello. I have some trouble with the brightness controls on my netbook (hardware and software details below):

Fn+F5/F6 seems to use acpi_video0. Fn keys make the brightness change, and the notification popup appear, but don't move the bar in the popup nor the slider in the Power Manager plugin.

Xfce Power Manager v 1.6.1 seems to use intel_backlight when I use the slider or scroll over the panel icon. This way I can get higher max brightness compared to using the Fn keys.

I'd like to use intel_backlight, as it has a bigger max value and is more fine grained (off-topic, anyone knows about the logarithmic scale proposed here, sounded great!), and marginally would like the slider and notification popup update their position properly.

Here's some info from my system:

Code: Select all

user@netbook:~$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.13.0-1-686-pae root=UUID=bcb90034-53b6-482c-a4b1-b35db0c2b510 ro quiet
I tried some of the "popular" acpi options on the grub command line, to no visible effect.

Code: Select all

user@netbook:~$ lspci -k | grep -iA2 VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
	Subsystem: ASUSTeK Computer Inc. Mobile 945GSE Express Integrated Graphics Controller
	Kernel driver in use: i915

Code: Select all

user@netbook:~$ for i in /sys/class/backlight/*; do echo $i;cat $i/brightness;cat $i/max_brightness;done
/sys/class/backlight/acpi_video0
14
15
/sys/class/backlight/intel_backlight
7989
39780

Code: Select all

user@netbook:~$ pastebinit /var/log/Xorg.0.log
https://pastebin.com/60pFPuSy

Code: Select all

user@netbook    :~$ inxi -GMS
System:    Host: mx1 Kernel: 4.13.0-1-686-pae i686 bits: 32 Desktop: Xfce 4.12.3 
           Distro: MX-17_386 Horizon December 15  2017 
Machine:   Type: Laptop System: ASUSTeK product: 1005HA v: x.x serial: <root required> 
           Mobo: ASUSTeK model: 1005HA v: x.xx serial: <root required> BIOS: American Megatrends v: 1102 
           date: 10/16/2009 
Graphics:  Device-1: Intel Mobile 945GSE Express Integrated Graphics driver: i915 v: kernel 
           Display: x11 server: X.Org 1.19.2 driver: intel resolution: 1024x600~60Hz 
           OpenGL: renderer: Mesa DRI Intel 945GME x86/MMX/SSE2 v: 1.4 Mesa 18.2.6 
Following advice from old forum posts, I modified these two file, maybe I should just modify one of them?

Code: Select all

user@netbook:~$ cat /usr/share/X11/xorg.conf.d/20-intel.conf
Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"    "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

Code: Select all

user@netbook:~$ cat /etc/X11/xorg.conf.d/20-intel.conf 
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod" "sna"             # was "uxa"
   Option      "Backlight"   "intel_backlight" # I added this line
   Option      "TearFree"    "true"
   BusID       "PCI:0:2:0"                     # and maybe this one too? I don't remember!
Thanks for any help!
Last edited by alcornoqui on Thu Jan 10, 2019 11:02 am, edited 1 time in total.

alcornoqui
Forum Novice
Forum  Novice
Posts: 5
Joined: Wed Aug 08, 2018 8:34 am

Re: Brightness: acpi_video0 & intel_backlight

#2

Post by alcornoqui » Thu Jan 10, 2019 11:02 am

Solved by:

- Deleting /etc/X11/xorg.conf.d/20-intel.conf
- Adding "acpi_backlight=vendor" to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub
- Updating grub and rebooting.

Thanks to ToZ over the Xfce forum!

Post Reply

Return to “Hardware /Configuration”