Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

How to choose correct Nvidia drivers? [SOLVED]

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19861
Joined: Fri Dec 15, 2006 8:07 pm

Re: How to choose correct Nvidia drivers? [SOLVED]

#31

Post by Stevo » Mon May 06, 2019 6:38 pm

I have some doubts about that driver directly from Nvidia being able to build on our 4.19 kernel. It would be best to keep an close eye on the build output to see any errors. If it fails, you could always try the 4.9 Debian kernel.

Does Nvidia say anything about what kernels the 334 driver will build on?

User avatar
Sparky
Forum Regular
Forum Regular
Posts: 471
Joined: Sun Dec 23, 2018 7:07 pm

Re: How to choose correct Nvidia drivers? [SOLVED]

#32

Post by Sparky » Tue May 07, 2019 3:10 pm

just add modprobe.nouveau=0 and acpi_osi="!Windows 2015", you should be all set then to install the nvidia drivers from MX Tools.
MX Linux Asus F552, 12GB RAM, 1TB HDD

User avatar
pascar73
Forum Novice
Forum  Novice
Posts: 9
Joined: Fri May 03, 2019 12:42 pm

Re: How to choose correct Nvidia drivers? [SOLVED]

#33

Post by pascar73 » Tue May 07, 2019 3:48 pm

Hi Sparky, I think that the issue in my case, as Stevo mentioned, is that my nvidia card is too old and in all the latest drivers the NV285 isn't included. It is although strange that the installation proceeds even without the support for the specific chipset, leading to an unusable OS. Didn't have time to check, I will try later today and see what happens compiling the .run files with the appropriate support for the NV285.

User avatar
Sparky
Forum Regular
Forum Regular
Posts: 471
Joined: Sun Dec 23, 2018 7:07 pm

Re: How to choose correct Nvidia drivers? [SOLVED]

#34

Post by Sparky » Tue May 07, 2019 4:13 pm

pascar73 wrote:
Tue May 07, 2019 3:48 pm
Hi Sparky, I think that the issue in my case, as Stevo mentioned, is that my nvidia card is too old and in all the latest drivers the NV285 isn't included. It is although strange that the installation proceeds even without the support for the specific chipset, leading to an unusable OS. Didn't have time to check, I will try later today and see what happens compiling the .run files with the appropriate support for the NV285.
I see. Yes, if it's really old I'd roll back top a different kernel.
MX Linux Asus F552, 12GB RAM, 1TB HDD

Post Reply

Return to “Hardware /Configuration”