Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

No USB 2.0, no WiFi MX 17.1

Post Reply
User avatar
j2mcgreg
Forum Regular
Forum Regular
Posts: 635
Joined: Tue Oct 23, 2007 12:04 pm

No USB 2.0, no WiFi MX 17.1

#1

Post by j2mcgreg » Mon Sep 03, 2018 1:01 am

I have a computer built on a Gigabyte GA 970A-D3P motherboard which when booted to a live session of MX 17.1 has no functioning USB 2 ports and no WiFi capability (both utilities work fine in Win 10). The keyboard is an old IBM PS2 model and the wireless mouse works when connected to a USB 3 port which means that I can complete the install. My question has to do with a fix for the problem that I found on an Ubuntu forum (posted below). Could the boffins here suggest any changes that I have to make to the instructions vis-a-vis MX17? Thanks in advance.


Fix Instructions

First enable iommu in the uefi by restarting your computer and pressing delete to enter the uefi

plug your usb mouse, keyboard and thumbdrive in usb 2 ports.

save and exit the uefi

Then In Ubuntu:

press Ctrl+Alt+T to open up a terminal

run the following command: sudo gedit /etc/default/grub

Only edit the empty quotes in this line to read: GRUB_CMDLINE_LINUX="iommu=soft"

save changes to grub and exit gedit and the terminal

Open up a new terminal with ctrl+alt+t

run the following command: sudo update-grub

then exit the terminal using this command: exit

Restart your computer press delete to get back into the uefi

Disable iommu in bios, load optimized defaults and restart.

usb, 2.0 usb 3.0 and networking all work now in Ubuntu, and disabling iommu in bios may also help improve your boot times.

If the above post helps anyone I am happy.

User avatar
stsoh
Forum Regular
Forum Regular
Posts: 449
Joined: Sun Aug 20, 2017 10:11 am

Re: No USB 2.0, no WiFi MX 17.1

#2

Post by stsoh » Mon Sep 03, 2018 4:19 am

old pc not iommu supported, check this listings hw /cpu/chipset:
https://en.wikipedia.org/wiki/List_of_I ... g_hardware

Code: Select all

dmesg|grep IOMMU
MX-17.1_x64 Horizon, G41M-P33 Combo (MS-7592), Pentium E5400 (2706 MHz), 8Gb RAM (984 MT/s),
Intel 4 Series Integrated Graphics, Realtek PCIe Fast RTL8101/2/6E, PCI Gigabit RTL8169 Ethernets.
Accepted Linux when i found MX-Linux in 2016.

Ruff
Forum Novice
Forum  Novice
Posts: 9
Joined: Wed May 15, 2019 7:32 pm

Re: No USB 2.0, no WiFi MX 17.1

#3

Post by Ruff » Sun May 19, 2019 1:30 pm

It helped me, though after the fact. I installed MX 18 on a new disk on another motherboard (Dell-something with a Core i3) and when putting it in my desktop (AMD 5850, Gigabyte motherboard) _ONLY_ USB3 ports worked. So I had to plug my keyboard into a USB3 port to be able to log in.

Eventually I found that 'iommu=soft' solved that, now all USB ports work - except for some trouble with USB3, but I had that under Ubuntu too on the same motherboard so perhaps not an MX issue.

But this iommu 'magic bullet' has helped in various distros on various motherboards and laptops, so it's something I'm not likely to forget to try first when things don't work, now!

Post Reply

Return to “Hardware /Configuration”