Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[Solved] Older Atheros combo wireless and Bluetooth card? [Solved]

Post Reply
User avatar
Forum Novice
Forum  Novice
Posts: 1
Joined: Sun Jun 10, 2018 8:02 pm

[Solved] Older Atheros combo wireless and Bluetooth card? [Solved]

#1 Post by prairiedad » Sun Aug 05, 2018 9:37 pm

Not sure if this belongs in General, Software or here...mods feel free to move, sticky, etc. I also propose that a bit of firmware be changed in the distro as a whole, though maybe this has not worried anyone but me!?

I have a vintage 2011 Dell Vostro 1015 laptop, 4GB RAM and a 300 GB HDD. Core2 Duo, T6670. Works great, couldn't be happier (as far as it goes.) But for years, I have limped along with no Bluetooth...booting and dmesg always showed a configuration error and failed module probe, so no BT for me. This, by the way, on whatever distros I loaded...mostly Debian, but also Fedora, OpenSuSE, Arch (a few years ago, admittedly.)

Here are the output, respectively, of lspci and lsusb:

0c:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
Bus 002 Device 004: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth

Apparently both of these chips are on a combo card, one piece of hardware. Lots of models used to have them, though I'm sure they're now overhauled. The bug was discovered by many, and in googling around I repeatedly _almost_ found the solution...but eventually I just gave up, not worth the trouble. Until yesterday/today...I'm having such a good time with MX, and getting it just as I want it, that I figured one last shot couldn't hurt.

This page in kernel.org's bugzilla has the answer, and a link to the patched firmware that now works flawlessly:


I just put the linked-to firmware into /lib/firmware in place of the default ath3-1.fw, and rebooted...and bluetooth for the first time ever! (PS, make sure with rfkill list that the device is turned on...sometimes these Dell laptops have hardware switch that is off and must be turned on...I think on mine is fcn-F11.

md5sum of the good version is, as kernel.org notes above: 24cfee59a24f336dfae838a0de6445a0

md5sum of the default but _bad_ for my/our device is: 1211fa34c09e10ba48381586b7c3883d

Here's the most important part...this patch has never been widely applied upstream...no idea why. it is missing from all the distros I named above as of late 2017/early 2018...I know because I tested them all on this laptop to see. (Arch, too, but that was longer ago.)

Can you mods have higher visibility upstream, and get this patched in the distributed kernel once and for all...I can't see how it would hurt a thing?

Thanks, and I hope this will help someone, somewhere...it drove me nuts for ages.

Post Reply

Return to “Hardware /Configuration”