Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Auto connect wireless extender

Post Reply
Message
Author
User avatar
Web-Man
Forum Novice
Forum  Novice
Posts: 2
Joined: Fri May 18, 2018 2:46 am

Auto connect wireless extender

#1 Post by Web-Man » Fri Jun 15, 2018 6:34 am

Hi guys,
I have mxlinux on my laptop. My house has a 24h router with wify that im use on my latop.
But sometimes, in some days, i have to turn on my wify extender (to use on my television), and then my latop change to this wireless automaticly. (they have same name/password)
Anyone knows how to disable this, and doesnt made my connection disconnect and then connect again?

User avatar
Web-Man
Forum Novice
Forum  Novice
Posts: 2
Joined: Fri May 18, 2018 2:46 am

Re: Auto connect wireless extender

#2 Post by Web-Man » Mon Jul 09, 2018 6:55 am

bump :(

User avatar
Richard
Posts: 2151
Joined: Fri Dec 12, 2008 10:31 am

Re: Auto connect wireless extender

#3 Post by Richard » Mon Jul 09, 2018 7:01 am

Just a few thoughts on possibilities:
https://www.google.com/search?q=wireles ... refox-b-ab

I have an extender but haven't connected it. Guess it's time to see what it does.

Might need to change
In the Router IP address field, enter an unused IP address for the LAN
network of your new router.
Last edited by Richard on Mon Jul 09, 2018 7:21 am, edited 1 time in total.
MX171: Lenovo T430: Intel Ivy Bridge i5-3320M, 8GB RAM, 4.18.0-2-amd64, 119GB SSD
MX171: EeePC 1005HA: Dual Core Atom N270, 1GB RAM, 4.9.0-8-686, 150GB HDD
Thunar/Doublecmd, LibO613, Dropbox, Firefox, CherryTree, Vbox. LinuxCounter #208633

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22710
Joined: Wed Jul 19, 2006 6:13 am

Re: Auto connect wireless extender

#4 Post by Jerry3904 » Mon Jul 09, 2018 7:05 am

You can perhaps do it this way:
  • Launch Network Connections
  • Highlight the wifi extender you do not want
  • Click the Edit button in upper right
  • Click on the General tab
  • Uncheck "Automatically connect to this when it is available"
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2070
Joined: Wed Apr 11, 2018 5:09 pm

Re: Auto connect wireless extender

#5 Post by fehlix » Mon Jul 09, 2018 7:26 am

Web-Man wrote:
Fri Jun 15, 2018 6:34 am
...But sometimes, in some days, i have to turn on my wify extender (to use on my television), and then my latop change to this wireless automaticly. (they have same name/password) ...
If I understand you correctly. After you have turned on the wifi extender you do have two access point listed within network connection list.
Having both the identical names (SSID) the network manager just autoconnects to the other one.
What I would do:
Either change the SSIDs (the names) so both do have differend SSIDs and you can better distinguish.
Or/and turn of autoconnect wihin network manager of the one you do not want to switch to.
Just right-click on the connection icon within the taskbar and edit connection to disable autoconnect.
EDIT: oops jerry is back;=)
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “Hardware /Configuration”