Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Solved - for now - - laptop wont boot - again

Message
Author
rasat
Forum Novice
Forum  Novice
Posts: 57
Joined: Tue Dec 19, 2017 1:19 pm

Re: laptop wont boot - again

#11 Post by rasat » Thu Jun 07, 2018 5:33 am

When I said grub, its about the kernel. Last time I managed still to login with 4.13 by using systemd. Changed to antix-4.9-64bit and worked fine. In last update (6 June) something changed.

EDIT
After several boots with different options, I managed to fix the problem. [Solved]

gonzo01
Forum Novice
Forum  Novice
Posts: 23
Joined: Tue Jul 11, 2017 11:27 pm

Re: laptop wont boot - again

#12 Post by gonzo01 » Thu Jun 07, 2018 10:11 pm

"Are you updating the live system before install?"

No

Just tried booting from LinuxLite 4.0-64bit

Booted fine

tried to access laptop's SSD - got message "Failed to Mount rootMX17

Error mounting /dev/sda1 at /media/linux rootMX17:mount (2) system call failed. Structure needs cleaning"

How do I do that?

Thanks

gonzo01
Forum Novice
Forum  Novice
Posts: 23
Joined: Tue Jul 11, 2017 11:27 pm

Re: laptop wont boot - again

#13 Post by gonzo01 » Thu Jun 07, 2018 11:35 pm

from linuxlite ran gparted and repaired SSD

installed Linuxlite but had ssd boot problems

reinstalled MXLinux 17.1

booted from SSD without problems

now updating system

--------------

rebooted from SSD ok after system "upgrade"

on Shutdown hangs on

"Stopping Light Display Manager: lightdm.
Stopping Avahi mDNS/DNS-SD Daemon: avahi-daemon.

-----------------------

How do I set GRUB to boot into Safe Mode?

thanks

runs fine

rasat
Forum Novice
Forum  Novice
Posts: 57
Joined: Tue Dec 19, 2017 1:19 pm

Re: laptop wont boot - again

#14 Post by rasat » Fri Jun 08, 2018 2:20 pm

gonzo01:
> How do I set GRUB to boot into Safe Mode?

Select "Advanced options for MX 17 Horizont". It also gives different kernel options (4.14 and 4.13) and systemd.

User avatar
fehlix
Forum Regular
Forum Regular
Posts: 639
Joined: Wed Apr 11, 2018 5:09 pm

Re: laptop wont boot - again

#15 Post by fehlix » Fri Jun 08, 2018 6:00 pm

gonzo01 wrote:
Thu Jun 07, 2018 11:35 pm
How do I set GRUB to boot into Safe Mode?
You might try one of those boot parameters or all together:
nomodeset failsafe xorg=safe
Within grub-menu press E for edit. navigate with the arrow-key (up.down, rigth , left)
to the line starting with 'linux'.
At the end of that line add: nomodeset failsafe xorg=safe
Remember GRUB does have a us-keyboard layout.

gonzo01
Forum Novice
Forum  Novice
Posts: 23
Joined: Tue Jul 11, 2017 11:27 pm

Re: laptop wont boot - again

#16 Post by gonzo01 » Fri Jun 08, 2018 11:53 pm

thanks fehlix

I've tried MX 17.1, Mint 18.3 and 19beta, puppy ans others

All fail to ShutDown or Reboot - just hang during process.

MX boots fine, but without Shutdown its not satisfactory.

Not an MX poble (or Mint etc) - its probably the kernel. Will try again later. For now just want to use the new laptop.

Linux lxle_16.04.4_64 works fine from a Live disk, USB thumbdrive install and a Hard drive (SSD) install.

Will stick with it for now, until I get MX working 100%

Thanks to all for assistance.

Will mark this thread "Unsolved" for now

cheapybob
Forum Novice
Forum  Novice
Posts: 7
Joined: Tue Nov 15, 2016 2:28 am

Re: UNSOLVED - closed for now - laptop wont boot - again

#17 Post by cheapybob » Sat Jun 09, 2018 12:25 am

I have a Dell XPS 15 Laptop with that CPU. It is very picky about kernels and with some it needs additional boot cheatcodes.

When booting do you get a black screen with cursor in upper left?

Does yours have the dual Intel/Nvidia graphics? If so try i915_preliminary_hw_support=1

You also might try acpi_osi=! acpi_osi=Windows

I suppose you could google those strings.

MX-17.1 is working on mine. The UEFI was the only problem. I am able to shutdown.

AntiX 17.1 is working on it but with a different kernel. Its not turned on at the moment.

gonzo01
Forum Novice
Forum  Novice
Posts: 23
Joined: Tue Jul 11, 2017 11:27 pm

Re: Solved - for now - - laptop wont boot - again

#18 Post by gonzo01 » Wed Jun 13, 2018 9:57 pm

Solved - for now - reinstalled MX 16 XFCE alongside MX 17

using MX 16 without ANY of the aforementioned boot/shutdown/wireless problems

Thanks for all of the replies

Post Reply

Return to “Hardware /Configuration”