Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Keyboard layout - Portuguese Brazil PT-BR

Message
Author
User avatar
timelf
Forum Novice
Forum  Novice
Posts: 14
Joined: Mon Jun 04, 2018 6:25 am

Re: Keyboard layout - Portuguese Brazil PT-BR

#11 Post by timelf » Mon Jun 04, 2018 10:28 am

hi, here is

$ setxkbmap -query
rules: evdev
model: pc105
layout: br,br
variant: nativo,nodeadkeys
options: grp:toggle,terminate:ctrl_alt_bksp,grp_led:scroll

User avatar
timelf
Forum Novice
Forum  Novice
Posts: 14
Joined: Mon Jun 04, 2018 6:25 am

Re: Keyboard layout - Portuguese Brazil PT-BR

#12 Post by timelf » Mon Jun 04, 2018 10:41 am

here:

$ setxkbmap -query
rules: evdev
model: pc105
layout: br,br
variant: nativo,nodeadkeys
options: grp:toggle,terminate:ctrl_alt_bksp,grp_led:scroll

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1734
Joined: Wed Apr 11, 2018 5:09 pm

Re: Keyboard layout - Portuguese Brazil PT-BR

#13 Post by fehlix » Mon Jun 04, 2018 10:48 am

timelf wrote:
Mon Jun 04, 2018 10:28 am

$ setxkbmap -query
rules: evdev
model: pc105
layout: br,br
variant: nativo,nodeadkeys
options: grp:toggle,terminate:ctrl_alt_bksp,grp_led:scroll
I think the nativo is wrong Just change either to only one ABNT like this:

Code: Select all

 setxkbmap   -layout 'br' -variant '' ; setxkbmap -query 
rules:      evdev
model:      pc105
layout:     br
or have both ABNT + ABNT-2 like this

Code: Select all

setxkbmap   -layout 'br,br' -variant ',nodeadkeys' ; setxkbmap -query 
rules:      evdev
model:      pc105
layout:     br,br
variant:    ,nodeadkeys
I verfied and can write charckters like this à ã ç using ABNT.
The layout I verfied looks like this:
Image

--fehlix :puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
timelf
Forum Novice
Forum  Novice
Posts: 14
Joined: Mon Jun 04, 2018 6:25 am

Re: Keyboard layout - Portuguese Brazil PT-BR

#14 Post by timelf » Mon Jun 04, 2018 11:24 am

fehlix wrote:
Mon Jun 04, 2018 10:48 am
timelf wrote:
Mon Jun 04, 2018 10:28 am

$ setxkbmap -query
rules: evdev
model: pc105
layout: br,br
variant: nativo,nodeadkeys
options: grp:toggle,terminate:ctrl_alt_bksp,grp_led:scroll
I think the nativo is wrong Just change either to only one ABNT like this:

Code: Select all

 setxkbmap   -layout 'br' -variant '' ; setxkbmap -query 
rules:      evdev
model:      pc105
layout:     br
or have both ABNT + ABNT-2 like this

Code: Select all

setxkbmap   -layout 'br,br' -variant ',nodeadkeys' ; setxkbmap -query 
rules:      evdev
model:      pc105
layout:     br,br
variant:    ,nodeadkeys
I verfied and can write charckters like this à ã ç using ABNT.
The layout I verfied looks like this:
Image

--fehlix :puppy:
WOW ! You did it ! Well done. Now I can write çãà ... And yes this is the ABNT2 layout...

I hope MX team can now fix it right away because many friends here are considering MX 17...

Best regards.

Tim

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1734
Joined: Wed Apr 11, 2018 5:09 pm

Re: Keyboard layout - Portuguese Brazil PT-BR

#15 Post by fehlix » Mon Jun 04, 2018 11:50 am

timelf wrote:
Mon Jun 04, 2018 11:24 am
I hope MX team can now fix it right away because many friends here are considering MX 17...
Well, Excuse me Sir ! :confused:
The above commandline "trick" is just short variant of something what is already in the system.
The quick variant of the command:

Code: Select all

setxkbmap   -layout 'br,br' -variant ',nodeadkeys'
Is just the same as you can do within the menu already: You just need to do this:
For Portuguese-Brazil ABNT keyboard choose
within Settings -> Keyboard
-> deselect "use system default"
-> Add
Layout Portuguese(Brazil)
Variant: -- (none)

For Portuguese-Brazil ABNT-2 keyboard choose within Settings -> Keyboard
-> deselect "use system default"
-> Add
Layout Portugues(Brazil)
Variant: nodeadkeys

Surely, I feel it is always quicker to do it the cli-way :happybday:
And yes, let your friends know that they can write with
Portuguese-Brazil ABNT keyboard layout in MX Linux!
Thanks
:puppy:
--fehlix
PS: Would you mind mark the thread as [Solved] within the Subject line of your first post. Thanks.

EDIT: Just verified, if you boot from LiveUSB/CD with latest MX17.1 and choose Portuguese(Brazil) language,
you keyboard will get properly set to ABNT layout already! Addionally, after upgrade within the LiveSystem you can choose from lastest MX installer additonall keyboard laytouts already. :puppy:
--fehlix
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
timelf
Forum Novice
Forum  Novice
Posts: 14
Joined: Mon Jun 04, 2018 6:25 am

Re: Keyboard layout - Portuguese Brazil PT-BR

#16 Post by timelf » Mon Jun 04, 2018 12:41 pm

fehlix wrote:
Mon Jun 04, 2018 11:50 am
timelf wrote:
Mon Jun 04, 2018 11:24 am
I hope MX team can now fix it right away because many friends here are considering MX 17...
Well, Excuse me Sir ! :confused:
The above commandline "trick" is just short variant of something what is already in the system.
The quick variant of the command:

Code: Select all

setxkbmap   -layout 'br,br' -variant ',nodeadkeys'
Is just the same as you can do within the menu already: You just need to do this:
For Portuguese-Brazil ABNT keyboard choose
within Settings -> Keyboard
-> deselect "use system default"
-> Add
Layout Portuguese(Brazil)
Variant: -- (none)

For Portuguese-Brazil ABNT-2 keyboard choose within Settings -> Keyboard
-> deselect "use system default"
-> Add
Layout Portugues(Brazil)
Variant: nodeadkeys

Surely, I feel it is always quicker to do it the cli-way :happybday:
And yes, let your friends know that they can write with
Portuguese-Brazil ABNT keyboard layout in MX Linux!
Thanks
:puppy:
--fehlix
PS: Would you mind mark the thread as [Solved] within the Subject line of your first post. Thanks.

EDIT: Just verified, if you boot from LiveUSB/CD with latest MX17.1 and choose Portuguese(Brazil) language,
you keyboard will get properly set to ABNT layout already! Addionally, after upgrade within the LiveSystem you can choose from lastest MX installer additonall keyboard laytouts already. :puppy:
--fehlix
Pal,

Promise you, before posting here, I've used my tools...

There is some bug in that GUI to switch languages and keyboard...

How I can select just the layout and NO variant in that GUI ?

User avatar
timelf
Forum Novice
Forum  Novice
Posts: 14
Joined: Mon Jun 04, 2018 6:25 am

Re: Keyboard layout - Portuguese Brazil PT-BR

#17 Post by timelf » Mon Jun 04, 2018 12:48 pm

I figure out what to do...

It os not a bug, it is a bad GUI... inducts in error...

Solved anyway.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1734
Joined: Wed Apr 11, 2018 5:09 pm

Re: Keyboard layout - Portuguese Brazil PT-BR

#18 Post by fehlix » Mon Jun 04, 2018 12:57 pm

timelf wrote:
Mon Jun 04, 2018 12:41 pm
How I can select just the layout and NO variant in that GUI ?
Well, it's simpler than it appears:
Just don't select a variant! Just highlight only "Portuguese(Brazil)", without any variant selected!
Thats it! I must admit first time, I have seen this long time ago, I have also not seen,
that just clicking the Header-Menu-line is already the selection!
--fehlix
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
timelf
Forum Novice
Forum  Novice
Posts: 14
Joined: Mon Jun 04, 2018 6:25 am

Re: Keyboard layout - Portuguese Brazil PT-BR

#19 Post by timelf » Mon Jun 04, 2018 2:56 pm

fehlix wrote:
Mon Jun 04, 2018 12:57 pm
timelf wrote:
Mon Jun 04, 2018 12:41 pm
How I can select just the layout and NO variant in that GUI ?
Well, it's simpler than it appears:
Just don't select a variant! Just highlight only "Portuguese(Brazil)", without any variant selected!
Thats it! I must admit first time, I have seen this long time ago, I have also not seen,
that just clicking the Header-Menu-line is already the selection!
--fehlix
Indeed. Exactly. ;)

Post Reply

Return to “Hardware /Configuration”