Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Epson Printer Frustration - Installed, Seen .. Not working!

Message
Author
linwinux

Re: Epson Printer Frustration - Installed, Seen .. Not working!

#11 Post by linwinux » Wed May 16, 2018 2:32 am

This is the singular one item that has prevented me from recommending Linux to others in the past. I don't know what Mint does differently from MX, but with Mint I don't have these printer problems at all. Scanners & Plotters, yes, always a problem with all Linux distros, but the printer issues should have been resolved Linux wide by now, all these many many years later. Yup, I'm frustrated alright, because this is the straw that broke the camel's back. I can't recommend an OS where people have to figure out if systemd or not ... and why or why not ... which not even the manual explains properly. I can't recommend an OS where "creative printer drivers" which only permit black & white printing are being used ... while the manufacturer provides actual working drivers for most of their hundreds of printer models. This has absolutely nothing to do with "what's best for the OS" and everything with, IMO, lacking the common sense to do what makes MX user friendly to the masses ... even experienced users.

And don't even start with that "MX isn't meant for new or inexperienced users" because I have 10 years of Linux experience and have yet to find a popular well received distro that causes me to waste hours of my time in order to do one of the most basic things there is ... printing out a color page of whatever. Everyone here who's read posts of mine already knows that I could care less what troubles one has to go through to get things working 100% right, with fiddling & patience. To me, Linux is about providing everyone else an awesome user experience, which I can make happen with my own, easy to understand, help files.
But I'm not a coder or a developer, so I can't do anything about things that just won't work as they should, right from the get-go.

I believe, but can't test this unless I re-install MX, that the WF-2010 printer quite possibly works with the deleted driver. Once that default driver was deleted, no more possibility for a working printer. Once I installed the manufacturer drivers, these more than likely ran into some kind of conflict between existing driver remnants on the System and whatever those drivers installed, so no working printer. If I power down the printer and then back on again, I receive cups error message notifications. Can't help that and can't fix it. Using the printer from the browser doesn't work either ... all of the MX Linux on-screen references point to a 9 pin dot matrix printer which I can't change. This is a color inkjet printer !!! This is beyond frustrating. Why won't MX use systemd if it works on other distros? Why won't MX *NOT* install default drivers for hardware which has supplied drivers by the manufacturers? To me, this simply makes no sense !!!

I'm going to boot into a live system now. Then I'm going to do some partition re-sizing, followed by installing Mint in order to have a triple-boot working. I'll report back what progress I've made, but don't know when. it may be a few days. Obviously I'll have to re-write some of my help pages for Mint instead, major bummer. :frown: This printer issue is simply not acceptable at all. There has to be an easier way !!!

.

User avatar
stsoh
Forum Regular
Forum Regular
Posts: 393
Joined: Sun Aug 20, 2017 10:11 am

Re: Epson Printer Frustration - Installed, Seen .. Not working!

#12 Post by stsoh » Wed May 16, 2018 3:42 am

maybe this will help u setup printer in network:
https://www.linux.com/learn/linux-101-printing
printer setup, you need to open up your web browser and point it to http://localhost:631.
Here are the steps:
-Click the Add Printer button. http://localhost:631/admin
-Enter the name, location, and description of the printer.
-Select the device.
-Enter the device URI (this instructs the backends where the printer is located).
-Select the Manufacturer of your printer (escpr, instead of splix).
-Select the Model of your printer.
-Configure any general settings for your printer.
MX-17.1_x64 Horizon, G41M-P33 Combo(MS-7592), Pentium E5400 (min/max: 1203/2700 MHz), 8Gb RAM (800 MT/s),
Intel 4 Series Integrated Graphics, Realtek PCIe Fast RTL8101/2/6E, PCI Gigabit RTL8169 Ethernets.

linwinux

Re: Epson Printer Frustration - Installed, Seen .. Not working!

#13 Post by linwinux » Wed May 16, 2018 4:24 am

Thanks, but I tried all of that already. I can't get around the printer getting recognized as a 9 pin dot matrix no matter what I do ... even though it displays as the correct name & model ... Epson WF-2010. My mistake was taken for granted that in this day and age most standard things would work out of the box with zero fiddling. What I should have done ... my bad ... was to check the printer install immediately after installing MX for the first time. But when you're "spoiled" with four working systems in the home office which includes working printers, it's easy just to ignore some things which are actually quite important. Like I said, that's on me.

That whole systemd thing is really irritating to me though. If so many distros use it, why not MX? There's no real viable explantion that I could find ... one that makes total sense and has a person left saying "Oh, duh, yeah, I get why systemd is crap!" That's an issue on my personal setup with my vpn provider. If systemd works, why not use it? No really, in plain english ... WHY NOT? The printer is on me though ... possibly ... if the initial drivers would have worked. But again, to me that's just plain ridiculous to provide "non-perfect drivers" built into the OS, while the manufacturer drivers can be downloaded so easily.
Anyone who's ever had Mint or another distro which permits you to pre-install the correct drivers before plugging in the hardware, is going to have the same problem with MX.

I just finished dowloading Mint & Manjaro ISO images, plan on utilizing those next in order to see which is best for older machines. That's what I need, a Linux distro which allows me to provide Linux to the masses, regardless if the new user is experienced, or not. Mark Shuttleworth (Ubuntu) had the right attitude (initially), let's show the World "ubuntu" (google it) by not only showing it what Linux can do, but by developing it for everyone! Believe it or not, but I read the meaning of Ubuntu and a lot about Mark Shuttleworth back then, and that's what convinced me to try Linux one more time ... which ultimately caused me to make the switch to Linux full time. Anyway, I create my own help documentation so providing Linux to others is not a problem, but the hardware has to work out of the box without conflicts, or be able to use manufacturer provided installable drivers, without potentially creating a later conflict.
Provided manufacturer drivers should never be conflicting (IMO).

I simply do not care about my *PERSONAL* Linux desires which is something that appears to be quite misunderstood in this forum. I never have a problem getting issues with Linux resolved for myself, and/or looking/working how I want "my" Linux to be at some point. What I do care about very much though, is being able to help other less fortunate / technically inclined people to become involved with Linux, so they can, as my wife and I and dozens of others whome we know have done, enjoy all that Linux has to offer with zero regrets.

.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1709
Joined: Wed Apr 11, 2018 5:09 pm

Re: Epson Printer Frustration - Installed, Seen .. Not working!

#14 Post by fehlix » Wed May 16, 2018 4:49 am

@linwinux : You are complaining a lot. I do respect your feelings and understand your frustrations.
But if you realy want to get help I' suggest you start from scratch and perhaps go to
Guide on How to ask for Help: viewtopic.php?p=255062#p255062
and show us the exact steps, commands and error-logs etc. You need to stay focused otherwise you would waste (at least my) time. :needcoffee:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22452
Joined: Wed Jul 19, 2006 6:13 am

Re: Epson Printer Frustration - Installed, Seen .. Not working!

#15 Post by Jerry3904 » Wed May 16, 2018 5:44 am

+1

If you now don't like the MX approach to systemd, don't like the Forum, don't like the hardware recognition, and don't like...I can't even remember what else now...oh yes, that we don't cater to the unfortunate masses as you would like, then it sounds like you should consider moving on.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
wulf
Forum Regular
Forum Regular
Posts: 109
Joined: Mon Jan 22, 2018 9:56 am

Re: Epson Printer Frustration - Installed, Seen .. Not working!

#16 Post by wulf » Wed May 16, 2018 6:17 am

I don't know if this is of any help, but at the time I installed MX, I had a Ricoh windows printer that wouldn't run for love nor money on Linux. After reading recommendations on the forum here, I bought a second-hand HP USB printer. I installed HPLIP from the repo's, plugged-in, and everything just worked...

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6052
Joined: Wed Jul 12, 2006 2:10 am

Re: Epson Printer Frustration - Installed, Seen .. Not working!

#17 Post by Eadwine Rose » Wed May 16, 2018 6:24 am

I'd even consider buying a new HP printer. I have seen them come by on sale for not even €40 at times. *shrug*
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1709
Joined: Wed Apr 11, 2018 5:09 pm

Re: Epson Printer Frustration - Installed, Seen .. Not working!

#18 Post by fehlix » Wed May 16, 2018 6:50 am

I've used to recommend HP printer. But I switched to Brother now, as they are far less expensive replacing toner or ink. A new set of HP printer-cartriges costs often more than a new printer.
Brother's can be easy installed and do always run fax/print/scanner, without any issues. Most refills work without any issue too. I wouldn't go back to HP anymore! :puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
richb
Administrator
Posts: 17096
Joined: Wed Jul 12, 2006 2:17 pm

Re: Epson Printer Frustration - Installed, Seen .. Not working!

#19 Post by richb » Wed May 16, 2018 6:55 am

I really like the HP GUI and printer control from the HP website. Does Brother have similar resources?
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1709
Joined: Wed Apr 11, 2018 5:09 pm

Re: Epson Printer Frustration - Installed, Seen .. Not working!

#20 Post by fehlix » Wed May 16, 2018 7:08 am

richb wrote:
Wed May 16, 2018 6:55 am
I really like the HP GUI and printer control from the HP website. Does Brother have similar resources?
Right, the HP Gui is nice. Brother's are well maintainable with default linux printer control and/or CUPS's interface. For installing I've recently posted here a little do-it-all-and-quick installerscript, which always worked for the last 6 Wifi/Net/usb-Brother's I've installed for me and relatives.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “Hardware /Configuration”