Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

SOLVED - Mouse not working after update

Post Reply
Message
Author
User avatar
markasn
Forum Novice
Forum  Novice
Posts: 2
Joined: Tue Apr 03, 2018 4:36 pm

SOLVED - Mouse not working after update

#1 Post by markasn » Tue Apr 03, 2018 5:16 pm

After a first time update everything was working. In the same session a newer kernel was added. Following that a new desktop was added from a task. After that task was installed the left mouse button stopped working while the right-click continued to work. After rebooting the left mouse still did not work even on the login screen. Only the right-click is working. Any ideas?
Last edited by markasn on Wed Apr 04, 2018 9:35 am, edited 2 times in total.

User avatar
richb
Administrator
Posts: 17213
Joined: Wed Jul 12, 2006 2:17 pm

Re: Mouse not working after update

#2 Post by richb » Tue Apr 03, 2018 5:26 pm

More details would be helpful:

1. What new desktop, just a background image or a different desktop manager than xfce?
2. Wireless mouse, USB or PS2?
3. Please post inxi -F and enclose in code brackets.
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

User avatar
markasn
Forum Novice
Forum  Novice
Posts: 2
Joined: Tue Apr 03, 2018 4:36 pm

Re: Mouse not working after update

#3 Post by markasn » Wed Apr 04, 2018 9:32 am

Found out it was a faulty mouse. :popcorn:

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6099
Joined: Wed Jul 12, 2006 2:10 am

Re: SOLVED - Mouse not working after update

#4 Post by Eadwine Rose » Wed Apr 04, 2018 11:54 am

Isn't it annoying that stuff ALWAYS breaks when you just upgraded?

I have had it happen with my internet. I had installed the new system, went away to do whatever, came back and the internet was down. :eek:
nononononono

Thank goodness windows had the same issue, turns out it was one of those very rare times my provider's signal went tits up. Took till late in the afternoon before it got fixed.


I spent that time well by the way. My late mate's computer needed a thorough clean, so I went to his girl (who has the thing) and took stuff apart and such ;)
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

User avatar
uncle mark
Forum Veteran
Forum Veteran
Posts: 4982
Joined: Sat Nov 11, 2006 10:42 pm

Re: Mouse not working after update

#5 Post by uncle mark » Wed Apr 04, 2018 12:03 pm

markasn wrote:Found out it was a faulty mouse. :popcorn:
That was my first thought. Since the right click worked, it obviously wasn't a connection issue, and even if you'd somehow changed it into a "left hand" config, the left button should have done something.

Many users forget that computers operate on both a software and hardware level. Hardware failures are sometimes the most obvious -- and easiest to fix -- if you're open to the possibility.
Desktop: Custom build Asus/AMD/nVidia -- MEPIS 11
Laptop: Acer Aspire 5250 -- MX-15
Assorted junk: assorted Linuxes

Post Reply

Return to “Hardware /Configuration”