Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Intel 82815 Driver

Post Reply
Message
Author
User avatar
Nyxx
Forum Novice
Forum  Novice
Posts: 4
Joined: Sun Apr 01, 2018 12:36 pm

Intel 82815 Driver

#1 Post by Nyxx » Sun Apr 01, 2018 1:14 pm

Hi there,
I'm a new menber of this forum.
I tryed to install MX-17 in an old laptot to give it a new life.
Mx is light and bauty so I like to use this disto, but I have some treble:
1) Display resolution settigs show only 640x480.
2) Firefox and Pale Moon doesnt't start, so I must use another PC to write in this forum.

If I open Synaptic show the intel grafic card drivers are installed, if I open terminal in Root, and send command xrandr -q it answer:
xrandr: failed to get size of gamma for output default. Screen 0 minimun 640 x 480, current 640 x 480, maximun 640 x 480 default connected 640x480+0+0 0mm x 0mm.
I tried to insert manually the resolution but doesn't work, I tried to follow some other tread with similar issue without resoult.

Someone can help me step by step to solve tis issue?

Thanks

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4493
Joined: Wed Jul 12, 2006 4:05 pm

Re: Intel 82815 Driver

#2 Post by timkb4cq » Sun Apr 01, 2018 5:31 pm

We need a bit more information to know where to start. Normally I would ask to run inxi -F in a terminal and paste it back here - but since you can't connect that would be difficult.
Can you give us the full make & model off the plate on the back of your laptop so we can look up the hardware?
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
Nyxx
Forum Novice
Forum  Novice
Posts: 4
Joined: Sun Apr 01, 2018 12:36 pm

Re: Intel 82815 Driver

#3 Post by Nyxx » Mon Apr 02, 2018 4:03 am

Hi Timkb4ck, thanks for your reply.
In the backplate there is only write Acer 610 series, but I have other information:
Acer Travelmate 613TXV, it's a PIII 1000, 128 Mb ram ( now 512Mb ) , intel 82815, Hard disk: DJSA-220 20Gb, monitor: 14.1".

User avatar
Nyxx
Forum Novice
Forum  Novice
Posts: 4
Joined: Sun Apr 01, 2018 12:36 pm

Re: Intel 82815 Driver

#4 Post by Nyxx » Mon Apr 02, 2018 4:37 am

This is the inxi -F file, I copied it in a usb key, then here.

root@Davide-MX-Linux:/home/davide# inxi -F
System:
Host: Davide-MX-Linux Kernel: 4.13.0-1-686-pae i686 bits: 32
Desktop: Xfce 4.12.3
Distro: MX-17_386 Horizon December 15, 2017
Machine:
Type: Other-vm? System: ACER product: TravelMate 610 v: -1
serial: 9141Q01BHI143031E8T
Mobo: ACER model: TravelMate 610 serial: 9141Q01BHI143031E8T
BIOS: Phoenix LTD v: V1.0 R01-B6 date: 08/10/01
Battery:
ID-1: BATA charge: 0 Wh condition: 0/3.2 Wh
CPU:
Topology: Single Core model: Pentium III (Coppermine)
type: UP L2 cache: 256 KB
Speed: 700 MHz min/max: 700/1000 MHz Core speed (MHz):
1: 700
Graphics:
Card-1: Intel 82815 Graphics Controller (CGC) driver: N/A
Display Server: x11 (X.Org 1.19.2)
driver: fbdev,modesetting,vesa resolution: 640x480~60Hz
OpenGL:
renderer: Gallium 0.4 on llvmpipe (LLVM 3.9 128 bits)
v: 3.3 Mesa 13.0.6
Audio:
Card-1: Intel 82801BA/BAM AC97 Audio Controller
driver: snd_intel8x0
Sound Server: ALSA v: k4.13.0-1-686-pae
Network:
Card-1: Intel 82801BA/BAM/CA/CAM Ethernet Controller
driver: e100
IF: eth0 state: down mac: 00:00:e2:54:a0:c1
Card-2: Realtek RTL8188CUS 802.11n WLAN Adapter type: USB
driver: rtl8192cu
IF: wlan0 state: up mac: 00:13:ef:6a:1e:98
IF-ID-1: irda0 state: down mac: 00:00:00:00
Drives:
HDD Total Size: 18.63 GiB used: 5.11 GiB (27.4%)
ID-1: /dev/sda model: IC25N020ATDA04-0 size: 18.63 GiB
Partition:
ID-1: / size: 16.21 GiB used: 5.10 GiB (31.5%) fs: ext4
dev: /dev/sda1
ID-2: swap-1 size: 2.00 GiB used: 8.8 MiB (0.4%) fs: swap
dev: /dev/sda2
Sensors:
System Temperatures: cpu: 42.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 154 Uptime: 20 min Memory: 496.1 MiB
used: 188.3 MiB (38.0%) Shell: bash inxi: 2.9.08
root@Davide-MX-Linux:/home/davide# sudo /etc/modprobe.d

User avatar
chrispop99
Forum Guide
Forum Guide
Posts: 2516
Joined: Tue Jan 27, 2009 3:07 pm

Re: Intel 82815 Driver

#5 Post by chrispop99 » Mon Apr 02, 2018 6:50 am

I'm afraid that your machine is a bit too old to run MX really well. The reason the web browsers won't start is that your Pentium 3 CPU does not support the SSE2 flag, and that is a requirement for most modern browsers. The other limitation is the small amount of RAM you have; 1GB is really the minimum for comfortable working. antiX would be a better choice for your machine.

If you still want to try to get MX to work, and you have another machine available, have a look at the Wiki here:

https://mxlinux.org/wiki/system/boot-pa ... LiveCD/USB

for some things to try to get the graphics working.

If no luck, post back with what you have tried, and we will try to get you up and running.

Chris
Test machines:
32-bit non-PAE - Thinkpad T41, 1.6GHz Pentium M, 1GB RAM.
32-bit PAE - DELL Latitude D610, 1.73GHz Pentium M, 2GB RAM.
64-bit - Lenovo T61, 2GHz Core 2 Duo, 2GB RAM
64-bit - Gigabyte Z77P-D3, Intel i3-3220, GeForce 8400 GS, 4GB PC3-12800.

User avatar
Nyxx
Forum Novice
Forum  Novice
Posts: 4
Joined: Sun Apr 01, 2018 12:36 pm

Re: Intel 82815 Driver

#6 Post by Nyxx » Mon Apr 02, 2018 9:05 am

Hi chrispop99,
I know my laptop is very old, and I know firefox and othe browser doesn't work, for this I install Pale Moon non SSE2, start but it crash in a couple of minute.
I tried to follow your suggestion with an Antix live, but same problem than Mx in internet browser and for display resolution.
I Antix doesn't work, I don't know what do anymore.
If someone help me to solve just the graphic issue, I will happy, otherwise I put it on the trush :bawling: .

NGIB
Forum Regular
Forum Regular
Posts: 463
Joined: Sat Apr 05, 2014 12:12 pm

Re: Intel 82815 Driver

#7 Post by NGIB » Mon Apr 02, 2018 9:08 am

It's probably time to retire that hardware. You can find used laptops very reasonably priced...
Life's tough, it's tougher if you're stupid...

caprea
Forum Regular
Forum Regular
Posts: 139
Joined: Sat Aug 23, 2014 7:01 am

Re: Intel 82815 Driver

#8 Post by caprea » Mon Apr 02, 2018 9:10 am

I think you have to deinstall the adobe-flashplugin.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 10163
Joined: Sun Dec 16, 2007 1:17 pm

Re: Intel 82815 Driver

#9 Post by dolphin_oracle » Mon Apr 02, 2018 9:33 am

for the video, try searching for

20-intel.conf

in this forum. you should find instructions for forcing use of the "intel" video driver rather than "modsetting". You are almost certainly not very well supported and it looks like you are getting a limited resolution due to either vesa or fbdev being the backend for the display driver in X.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 23107
Joined: Wed Jul 19, 2006 6:13 am

Re: Intel 82815 Driver

#10 Post by Jerry3904 » Mon Apr 02, 2018 9:44 am

Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

Post Reply

Return to “Hardware /Configuration”