Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

move /home to RAID 0 array [SOLVED]

Post Reply
Message
Author
User avatar
stroudmw
Forum Novice
Forum  Novice
Posts: 39
Joined: Fri Jun 23, 2017 2:13 am

move /home to RAID 0 array [SOLVED]

#1 Post by stroudmw » Wed Jan 31, 2018 4:54 am

I have just done a fresh install of MX-17 32 bit on an old HP ProLiant ML110 desktop.
I did the install to an old 40GiB hard drive. I have 2x250GiB hard drives that I have configured to be a RAID 0 array.
I would like to move my /home directory to the RAID 0 array, but I don't know how.
This is what I've done so far:

Code: Select all

sudo apt install mdadm

Code: Select all

sudo mdadm --create /dev/md0 --verbose --level=0 --raid-devices=2 /dev/sdb1 /dev/sdc1

Code: Select all

sudo mkfs.ext4 /dev/md0

Code: Select all

 cat /proc/mdstat
gives me this:

Code: Select all

Personalities : [raid0] 
md0 : active raid0 sdc1[1] sdb1[0]
      488132608 blocks super 1.2 512k chunks
      
unused devices: <none>
however,

Code: Select all

sudo mdadm --assemble -scan
gives me this:

Code: Select all

mdadm: No arrays found in config file or automatically
Can somebody please point me on the right track on how to do this? Thank you!
Last edited by stroudmw on Thu Feb 01, 2018 9:47 am, edited 1 time in total.

User avatar
stroudmw
Forum Novice
Forum  Novice
Posts: 39
Joined: Fri Jun 23, 2017 2:13 am

Re: move /home to RAID 0 array

#2 Post by stroudmw » Wed Jan 31, 2018 5:01 am

I forgot to mention, the contents of my /etc/fstab are as follows:

Code: Select all

# /etc/fstab: static file system information
#
# Created by make-fstab on Wed Jan 31 09:54:44 SAST 2018

# <file system>                            <mount point>                               <type>     <options>                       <dump/pass>

#-> /dev/sda1  label=rootMX17
UUID=8ebf0ba6-f9e3-4995-b30b-04e4e652d592  /                                           ext4       defaults                        1 1
#-> /dev/sda2  label=MXswap
UUID=e67031c1-c398-4fcb-af2e-27e0bf55e4b2  swap                                        swap       defaults                        0 0

User avatar
stroudmw
Forum Novice
Forum  Novice
Posts: 39
Joined: Fri Jun 23, 2017 2:13 am

Re: move /home to RAID 0 array

#3 Post by stroudmw » Wed Jan 31, 2018 5:15 am

Code: Select all

$ inxi -F
System:    Host: liberator Kernel: 4.13.0-1-686-pae i686 bits: 32 Desktop: Xfce 4.12.3
           Distro: MX-17_386 Horizon December 15, 2017
Machine:   Device: desktop System: HP product: ProLiant ML110 G2 serial: N/A
           Mobo: Wistron model: M81IXA v: 1 serial: N/A BIOS: HP v: 1.14 S date: 12/08/2005
CPU:       Single core Intel Pentium 4 (-MT-) cache: 1024 KB
           clock speeds: max: 3199 MHz 1: 3199 MHz 2: 3199 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Rage XL PCI
           Display Server: x11 (X.Org 1.19.2 )
           drivers: ati (unloaded: modesetting,fbdev,vesa) FAILED: mach64
           Resolution: 1024x768@60.00hz
           OpenGL: renderer: Gallium 0.4 on llvmpipe (LLVM 3.9, 128 bits) version: 3.3 Mesa 13.0.6
Network:   Card-1: Realtek RTL8169 PCI Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: down mac: 00:08:54:00:10:30
           Card-2: Intel 82541GI Gigabit Ethernet Controller driver: e1000
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: 00:13:21:7c:7a:01
Drives:    HDD Total Size: 1040.2GB (0.7% used)
           ID-1: /dev/sda model: ST3250410AS size: 250.1GB
           ID-2: /dev/sdb model: ST3250410AS size: 250.1GB
           ID-3: /dev/sdc model: ST340014A size: 40.0GB
           ID-4: USB /dev/sdd model: S2_Portable size: 500.1GB
Partition: ID-1: / size: 35G used: 4.8G (15%) fs: ext4 dev: /dev/sdc1
           ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sdc2
RAID:      Device-1: /dev/md0 - active raid: 0 components: online: sdb1 sda1
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 171 Uptime: 4 min Memory: 288.3/3413.7MB Client: Shell (bash) inxi: 2.3.54 

User avatar
stroudmw
Forum Novice
Forum  Novice
Posts: 39
Joined: Fri Jun 23, 2017 2:13 am

Re: move /home to RAID 0 array [SOLVED]

#4 Post by stroudmw » Wed Jan 31, 2018 8:12 am


Post Reply

Return to “Hardware /Configuration”