Page 2 of 2

Re: HPLIP 3.17.x

Posted: Fri Jan 12, 2018 8:54 am
by rasat
> HP says the 125a only needs 3.14.3: https://developers.hp.com/hp-linux-imag ... lugin.html

Thank you. I got my 125a to work by running hp-setup in terminal which downloaded the required plugin.

Re: HPLIP 3.17.x

Posted: Mon Jan 29, 2018 8:52 pm
by VegasAngle
Stevo wrote:
rasat wrote:Thanks. I found out that the repo I used before, does not help.
https://wiki.debian.org/DebianExperimental
That usually does more harm than good.

HP says the 125a only needs 3.14.3: https://developers.hp.com/hp-linux-imag ... lugin.html

Do you mean you have the 25a?

These printers also require that you download and install a proprietary plugin from HP to work, as far as I gather.
How do I force a download, can't make the popup appear that tells me i need the proprietary plugin from HP. Just upgraded from 15...

Re: HPLIP 3.17.x

Posted: Mon Jan 29, 2018 10:19 pm
by Stevo
Does running hp-setup in the terminal do anything?

Re: HPLIP 3.17.x

Posted: Tue Jan 30, 2018 2:52 pm
by rasat
hp-setup opens "HP Device Manager - Setup" dialog box. With my printer HP LaserJet Pro MFP M125a, it did a good job.

Re: HPLIP 3.17.x

Posted: Wed May 02, 2018 3:26 pm
by alexjack
Stevo wrote:To bring this to a conclusion, solved the problem with the backports since 3.17.7-2. A real face-palm moment--it just needs a non-parallel build, but the switch to debhelper 10 made parallel builds the default.
Hi all, I have a similar issue. As a short time linux user, I have just moved to MX17 (which is great) from Windows 7 and have bought a HP Officejet 5230 because the linux support looks good. The HP site tell me that I need minimum HPLIP 3.17.9. 3.16.11 seems to be the default in Stretch stable. I see from above that there is a way to get a newer version on HPLIP. The only problem is that I don't understand the message above.

Can anyone help me out with some simpler instructions? This is my last thing to sort out, then it's fully over to linux!

Re: HPLIP 3.17.x

Posted: Wed May 02, 2018 3:32 pm
by alexjack
alexjack wrote:
Stevo wrote:To bring this to a conclusion, solved the problem with the backports since 3.17.7-2. A real face-palm moment--it just needs a non-parallel build, but the switch to debhelper 10 made parallel builds the default.
Hi all, I have a similar issue. As a short time linux user, I have just moved to MX17 (which is great) from Windows 7 and have bought a HP Officejet 5230 because the linux support looks good. The HP site tell me that I need minimum HPLIP 3.17.9. 3.16.11 seems to be the default in Stretch stable. I see from above that there is a way to get a newer version on HPLIP. The only problem is that I don't understand the message above.

Can anyone help me out with some simpler instructions? This is my last thing to sort out, then it's fully over to linux!
...just to add, I looked at the manual install instructions for HPLIP on the HP website. They only go up to Debian 6, so a bit worried to try that out and possibly jigger my system.

Re: HPLIP 3.17.x

Posted: Wed May 02, 2018 7:24 pm
by Stevo
We have 3.17.10 in our test repo, and we would prefer you install and test that. It's very easy to do with the MX Package Installer. Just install "hplip".

Re: HPLIP 3.17.x

Posted: Thu May 03, 2018 10:45 am
by Richard
Upgraded to hplip-3.17.10 via test repo for my HP P1102w printer.
Downloaded the firmware plugin and it prints as expected.

Actually, updated then tried to print when it demanded that I (re)install the plugin.
Followed the prompts to install the plugin and printed the pending page.

Seems to me like some of the weird, interface quirks are gone in this version.

Re: HPLIP 3.17.x

Posted: Thu May 03, 2018 4:27 pm
by alexjack
Stevo wrote:We have 3.17.10 in our test repo, and we would prefer you install and test that. It's very easy to do with the MX Package Installer. Just install "hplip".
Many thanks Stevo. Worked like a charm. Scanning and printing seem to be working properly. And, now I know where to go for other packages from testing :happy: