Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

HPLIP 3.17.x

Message
Author
rasat
Forum Novice
Forum  Novice
Posts: 70
Joined: Tue Dec 19, 2017 1:19 pm

Re: HPLIP 3.17.x

#11 Post by rasat » Fri Jan 12, 2018 8:54 am

> HP says the 125a only needs 3.14.3: https://developers.hp.com/hp-linux-imag ... lugin.html

Thank you. I got my 125a to work by running hp-setup in terminal which downloaded the required plugin.

VegasAngle
Forum Novice
Forum  Novice
Posts: 5
Joined: Sat Jan 28, 2017 7:51 pm

Re: HPLIP 3.17.x

#12 Post by VegasAngle » Mon Jan 29, 2018 8:52 pm

Stevo wrote:
rasat wrote:Thanks. I found out that the repo I used before, does not help.
https://wiki.debian.org/DebianExperimental
That usually does more harm than good.

HP says the 125a only needs 3.14.3: https://developers.hp.com/hp-linux-imag ... lugin.html

Do you mean you have the 25a?

These printers also require that you download and install a proprietary plugin from HP to work, as far as I gather.
How do I force a download, can't make the popup appear that tells me i need the proprietary plugin from HP. Just upgraded from 15...

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16272
Joined: Fri Dec 15, 2006 8:07 pm

Re: HPLIP 3.17.x

#13 Post by Stevo » Mon Jan 29, 2018 10:19 pm

Does running hp-setup in the terminal do anything?

rasat
Forum Novice
Forum  Novice
Posts: 70
Joined: Tue Dec 19, 2017 1:19 pm

Re: HPLIP 3.17.x

#14 Post by rasat » Tue Jan 30, 2018 2:52 pm

hp-setup opens "HP Device Manager - Setup" dialog box. With my printer HP LaserJet Pro MFP M125a, it did a good job.

alexjack
Forum Novice
Forum  Novice
Posts: 9
Joined: Wed May 02, 2018 3:11 pm

Re: HPLIP 3.17.x

#15 Post by alexjack » Wed May 02, 2018 3:26 pm

Stevo wrote:To bring this to a conclusion, solved the problem with the backports since 3.17.7-2. A real face-palm moment--it just needs a non-parallel build, but the switch to debhelper 10 made parallel builds the default.
Hi all, I have a similar issue. As a short time linux user, I have just moved to MX17 (which is great) from Windows 7 and have bought a HP Officejet 5230 because the linux support looks good. The HP site tell me that I need minimum HPLIP 3.17.9. 3.16.11 seems to be the default in Stretch stable. I see from above that there is a way to get a newer version on HPLIP. The only problem is that I don't understand the message above.

Can anyone help me out with some simpler instructions? This is my last thing to sort out, then it's fully over to linux!

alexjack
Forum Novice
Forum  Novice
Posts: 9
Joined: Wed May 02, 2018 3:11 pm

Re: HPLIP 3.17.x

#16 Post by alexjack » Wed May 02, 2018 3:32 pm

alexjack wrote:
Stevo wrote:To bring this to a conclusion, solved the problem with the backports since 3.17.7-2. A real face-palm moment--it just needs a non-parallel build, but the switch to debhelper 10 made parallel builds the default.
Hi all, I have a similar issue. As a short time linux user, I have just moved to MX17 (which is great) from Windows 7 and have bought a HP Officejet 5230 because the linux support looks good. The HP site tell me that I need minimum HPLIP 3.17.9. 3.16.11 seems to be the default in Stretch stable. I see from above that there is a way to get a newer version on HPLIP. The only problem is that I don't understand the message above.

Can anyone help me out with some simpler instructions? This is my last thing to sort out, then it's fully over to linux!
...just to add, I looked at the manual install instructions for HPLIP on the HP website. They only go up to Debian 6, so a bit worried to try that out and possibly jigger my system.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16272
Joined: Fri Dec 15, 2006 8:07 pm

Re: HPLIP 3.17.x

#17 Post by Stevo » Wed May 02, 2018 7:24 pm

We have 3.17.10 in our test repo, and we would prefer you install and test that. It's very easy to do with the MX Package Installer. Just install "hplip".

User avatar
Richard
Posts: 2069
Joined: Fri Dec 12, 2008 10:31 am

Re: HPLIP 3.17.x

#18 Post by Richard » Thu May 03, 2018 10:45 am

Upgraded to hplip-3.17.10 via test repo for my HP P1102w printer.
Downloaded the firmware plugin and it prints as expected.

Actually, updated then tried to print when it demanded that I (re)install the plugin.
Followed the prompts to install the plugin and printed the pending page.

Seems to me like some of the weird, interface quirks are gone in this version.
MX171: Lenovo T430: Intel DualCore i5-3320M, 8 GB RAM, 4.18.7-antix.1-amd64-smp, 119GB SSD
MX171: AA1-ZG5/EeePC-1005HA: DualCore N270, 1 GB RAM, 4.9.126-antix.1-686-smp-pae, 150GB HDD
Doublecmd84, LibO61, Dropbx, PMoon, CherryT,Vbox. LinuxCounter #208633

alexjack
Forum Novice
Forum  Novice
Posts: 9
Joined: Wed May 02, 2018 3:11 pm

Re: HPLIP 3.17.x

#19 Post by alexjack » Thu May 03, 2018 4:27 pm

Stevo wrote:We have 3.17.10 in our test repo, and we would prefer you install and test that. It's very easy to do with the MX Package Installer. Just install "hplip".
Many thanks Stevo. Worked like a charm. Scanning and printing seem to be working properly. And, now I know where to go for other packages from testing :happy:

Post Reply

Return to “Hardware /Configuration”