Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] TP-Link TL-WN722N poor usb wifi performance

Message
Author
dr-kart
Forum Regular
Forum Regular
Posts: 126
Joined: Sun Oct 22, 2017 8:12 pm

[SOLVED] TP-Link TL-WN722N poor usb wifi performance

#1 Post by dr-kart » Mon Dec 25, 2017 1:45 pm

On my MX17x64 I had noticed bit performance decrease in bandwidth since I still got manjaro installed on other partition to compare in case. Did not pay much attention though. Today another test - warthunder online game - proved I might have an issue. Namely connection wasn't stable with ping varying from 40 up to 500 ms. Which isn't the case with arch. Tested on different game's servers.

Kernel: 4.14.8-antix.1-amd64-smp
inxi -N

Code: Select all

Network:   Card: Atheros AR9271 802.11n driver: ath9k_htc
modinfo ath9k_htc

Code: Select all

filename:       /lib/modules/4.14.8-antix.1-amd64-smp/kernel/drivers/net/wireless/ath/ath9k/ath9k_htc.ko
firmware:       ath9k_htc/htc_9271-1.4.0.fw
firmware:       ath9k_htc/htc_7010-1.4.0.fw
description:    Atheros driver 802.11n HTC based wireless devices
...
name:           ath9k_htc
vermagic:       4.14.8-antix.1-amd64-smp SMP preempt mod_unload modversions 
parm:           debug:Debugging mask (uint)
parm:           nohwcrypt:Disable hardware encryption (int)
parm:           btcoex_enable:Enable wifi-BT coexistence (int)
parm:           ps_enable:Enable WLAN PowerSave (int)
parm:           use_dev_fw:Use development FW version (int)
mandatory tweak in my case:
/etc/modprobe.d/ath9k_htc.conf

Code: Select all

options ath9k_htc nohwcrypt=1
just in case even added to /etc/NetworkManager/NetworkManager.conf

Code: Select all

[device]    
wifi.scan-rand-mac-address=no
apt-cache policy firmware-atheros

Code: Select all

firmware-atheros:
  Installed: 20170823-1mx17+1
  Candidate: 20170823-1mx17+1
  Version table:
 *** 20170823-1mx17+1 500
        500 http://mxrepo.com/mx/repo stretch/non-free amd64 Packages
        500 http://mxrepo.com/mx/repo stretch/non-free i386 Packages
        100 /var/lib/dpkg/status
     20161130-3 500
...
* Debian backports tab has firmware-atheros (20170823-1~bpo9+1) marked as available to update. :confused: But I failed to update it via mx-packageinstaller
Last edited by dr-kart on Tue Dec 26, 2017 6:58 pm, edited 1 time in total.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4352
Joined: Wed Jul 12, 2006 4:05 pm

Re: TP-Link TL-WN722N usb wifi performance

#2 Post by timkb4cq » Mon Dec 25, 2017 2:02 pm

It's not an update. The debian-backports atheros firmware is exactly version the same as comes installed in MX-17.

If the wifi is more stable under Manjaro, it would make sense to compare the settings and package versions in that distro so we can see where they differ.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

dr-kart
Forum Regular
Forum Regular
Posts: 126
Joined: Sun Oct 22, 2017 8:12 pm

Re: TP-Link TL-WN722N usb wifi performance

#3 Post by dr-kart » Mon Dec 25, 2017 2:52 pm

manjaro looks pretty much the same here.

Code: Select all

Network:   Card: Qualcomm Atheros AR9271 802.11n driver: ath9k_htc

Code: Select all

filename:       /lib/modules/4.14.8-1-MANJARO/kernel/drivers/net/wireless/ath/ath9k/ath9k_htc.ko.xz
firmware:       ath9k_htc/htc_9271-1.4.0.fw
firmware:       ath9k_htc/htc_7010-1.4.0.fw
description:    Atheros driver 802.11n HTC based wireless devices
license:        Dual BSD/GPL
author:         Atheros Communications
srcversion:     83D534D14C5654C0D7069FE
...
depends:        mac80211,ath9k_hw,ath9k_common,ath,cfg80211,usbcore,led-class
intree:         Y
name:           ath9k_htc
vermagic:       4.14.8-1-MANJARO SMP preempt mod_unload modversions 
parm:           debug:Debugging mask (uint)
parm:           nohwcrypt:Disable hardware encryption (int)
parm:           btcoex_enable:Enable wifi-BT coexistence (int)
parm:           ps_enable:Enable WLAN PowerSave (int)
parm:           use_dev_fw:Use development FW version (int)
Don't know what else I need to look at.
debian-backports atheros firmware is exactly version the same as comes installed in MX-17
I see the same version dates. But why I wasn't able to install backported one? That's weird.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9298
Joined: Sun Dec 16, 2007 1:17 pm

Re: TP-Link TL-WN722N usb wifi performance

#4 Post by dolphin_oracle » Mon Dec 25, 2017 2:58 pm

you may want to post the log at /var/log/mxpi.log and mxpi.log.old . there may be clues present.

I actually just tried it, and apt see our package in the mx repo has a newer version, so you get that.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

dr-kart
Forum Regular
Forum Regular
Posts: 126
Joined: Sun Oct 22, 2017 8:12 pm

Re: TP-Link TL-WN722N usb wifi performance

#5 Post by dr-kart » Mon Dec 25, 2017 3:05 pm

@dolphin_oracle Oh I see, thank you!
mxpi.log says that the size is not valid.

dr-kart
Forum Regular
Forum Regular
Posts: 126
Joined: Sun Oct 22, 2017 8:12 pm

Re: [SOLVED] TP-Link TL-WN722N poor usb wifi performance

#6 Post by dr-kart » Tue Dec 26, 2017 7:04 pm

:idea: Culprit is found.
it is current network manager!
I just tried to use ceni instead. And everything is ok now.
Seems like NM needs to be updated/fixed.

User avatar
richb
Administrator
Posts: 17047
Joined: Wed Jul 12, 2006 2:17 pm

Re: [SOLVED] TP-Link TL-WN722N poor usb wifi performance

#7 Post by richb » Tue Dec 26, 2017 7:08 pm

Works fine for me.
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

dr-kart
Forum Regular
Forum Regular
Posts: 126
Joined: Sun Oct 22, 2017 8:12 pm

Re: [SOLVED] TP-Link TL-WN722N poor usb wifi performance

#8 Post by dr-kart » Tue Dec 26, 2017 7:13 pm

NM does work. But not perfect if you have wifi via ath9k module at least. I can confirm that I have performance issue with it so far. Ceni is ok.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22420
Joined: Wed Jul 19, 2006 6:13 am

Re: [SOLVED] TP-Link TL-WN722N poor usb wifi performance

#9 Post by Jerry3904 » Tue Dec 26, 2017 7:15 pm

I am using that module on my testing machine, and NM works fine here as well.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
richb
Administrator
Posts: 17047
Joined: Wed Jul 12, 2006 2:17 pm

Re: [SOLVED] TP-Link TL-WN722N poor usb wifi performance

#10 Post by richb » Tue Dec 26, 2017 7:35 pm

I have a TP Link card installed in my computer, not a dongle, using the ath9k module. But I am using the standard 4.13 kernel and atheros driver.
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

Post Reply

Return to “Hardware /Configuration”