Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Realtek RTL8723BE : No scan results

Message
Author
Mich-C
Forum Novice
Forum  Novice
Posts: 26
Joined: Tue Nov 21, 2017 1:11 pm

UPDATE 2018

#11 Post by Mich-C » Sun May 27, 2018 4:55 pm

Hi guys I'm still here :)
I reinstalled MXlinux and I faced this problem again but this time I can't solve it! even applying the same instructions and using the same .conf file...
Now I installed version 17.1 (at the time I think it was 16) I thought this problem was solved by developers... anyway I ask for your help again

At the moment I am using an external usb wi-fi card to access internet

iwlist scan

Code: Select all

 iwlist scan
wlan1     Scan completed :
          Cell 01 - Address: C8:D1:5E:09:04:B8
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=53/70  Signal level=-57 dBm  
                    Encryption key:on
                    ESSID:"InfostradaWiFi-001219"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000003de28cb277
                    Extra: Last beacon: 57514ms ago
                    IE: Unknown: 0015496E666F737472616461576946692D303031323139
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 03010B
                    IE: Unknown: 2A0104
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1A0E1117FF000000010000000000000000000000000C0000000000
                    IE: Unknown: 3D160B070700000000000000000000000000000000000000
                    IE: Unknown: 3E0100
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 0B050002107A12
                    IE: Unknown: 7F0101
                    IE: Unknown: DD07000C4304000000
                    IE: Unknown: 0706495420010D10
                    IE: Unknown: DD1E00904C330E1117FF000000010000000000000000000000000C0000000000
                    IE: Unknown: DD1A00904C340B070700000000000000000000000000000000000000

wlan0     No scan results

lo        Interface doesn't support scanning.
sudo iplink set wlan0 up

Code: Select all

iplink command not found, 
iwconfig

Code: Select all

wlan1     IEEE 802.11  ESSID:"InfostradaWiFi-001219"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: C8:D1:5E:09:04:B8   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry short  long limit:2   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=55/70  Signal level=-55 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:504  Invalid misc:1146   Missed beacon:0

wlan0     IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          
lo        no wireless extensions.
Linux headers/ build essentials seems already installed on MXlinux so this time I quickly done this
  • downloaded the wifi driver from both these 2 sources ( rtlwifi_new-rock.new_btcoex https://github.com/lwfinger/rtlwifi_new ... new_btcoex and https://github.com/lwfinger/rtlwifi_new)
  • opened terminal in the downloaded folders
  • sudo make

    Code: Select all

    make -C /lib/modules/4.15.0-1-amd64/build M=/home/michele/Documenti/rtlwifi_new-rock.new_btcoex modules
    make[1]: ingresso nella directory "/usr/src/linux-headers-4.15.0-1-amd64"
      CC [M]  /home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.o
    In file included from /home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.c:26:0:
    /home/michele/Documenti/rtlwifi_new-rock.new_btcoex/wifi.h:43:2: error: #error "This branch is abandoned. Please do not use"
     #error "This branch is abandoned. Please do not use"
      ^~~~~
    /home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.c: In function ‘_rtl_init_deferred_work’:
    /home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.c:602:2: error: implicit declaration of function ‘setup_timer’ [-Werror=implicit-function-declaration]
      setup_timer(&rtlpriv->works.watchdog_timer,
      ^~~~~~~~~~~
    cc1: some warnings being treated as errors
    /usr/src/linux-headers-4.15.0-1-common/scripts/Makefile.build:321: set di istruzioni per l'obiettivo "/home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.o" non riuscito
    make[4]: *** [/home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.o] Errore 1
    /usr/src/linux-headers-4.15.0-1-common/Makefile:1523: set di istruzioni per l'obiettivo "_module_/home/michele/Documenti/rtlwifi_new-rock.new_btcoex" non riuscito
    make[3]: *** [_module_/home/michele/Documenti/rtlwifi_new-rock.new_btcoex] Errore 2
    Makefile:146: set di istruzioni per l'obiettivo "sub-make" non riuscito
    make[2]: *** [sub-make] Errore 2
    Makefile:8: set di istruzioni per l'obiettivo "all" non riuscito
    make[1]: *** [all] Errore 2
    make[1]: uscita dalla directory "/usr/src/linux-headers-4.15.0-1-amd64"
    Makefile:57: set di istruzioni per l'obiettivo "all" non riuscito
    make: *** [all] Errore 2
    
  • sudo make install

    Code: Select all

    make -C /lib/modules/4.15.0-1-amd64/build M=/home/michele/Documenti/rtlwifi_new-rock.new_btcoex modules
    make[1]: ingresso nella directory "/usr/src/linux-headers-4.15.0-1-amd64"
      CC [M]  /home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.o
    In file included from /home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.c:26:0:
    /home/michele/Documenti/rtlwifi_new-rock.new_btcoex/wifi.h:43:2: error: #error "This branch is abandoned. Please do not use"
     #error "This branch is abandoned. Please do not use"
      ^~~~~
    /home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.c: In function ‘_rtl_init_deferred_work’:
    /home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.c:602:2: error: implicit declaration of function ‘setup_timer’ [-Werror=implicit-function-declaration]
      setup_timer(&rtlpriv->works.watchdog_timer,
      ^~~~~~~~~~~
    cc1: some warnings being treated as errors
    /usr/src/linux-headers-4.15.0-1-common/scripts/Makefile.build:321: set di istruzioni per l'obiettivo "/home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.o" non riuscito
    make[4]: *** [/home/michele/Documenti/rtlwifi_new-rock.new_btcoex/base.o] Errore 1
    /usr/src/linux-headers-4.15.0-1-common/Makefile:1523: set di istruzioni per l'obiettivo "_module_/home/michele/Documenti/rtlwifi_new-rock.new_btcoex" non riuscito
    make[3]: *** [_module_/home/michele/Documenti/rtlwifi_new-rock.new_btcoex] Errore 2
    Makefile:146: set di istruzioni per l'obiettivo "sub-make" non riuscito
    make[2]: *** [sub-make] Errore 2
    Makefile:8: set di istruzioni per l'obiettivo "all" non riuscito
    make[1]: *** [all] Errore 2
    make[1]: uscita dalla directory "/usr/src/linux-headers-4.15.0-1-amd64"
    Makefile:57: set di istruzioni per l'obiettivo "all" non riuscito
    make: *** [all] Errore 2
    
  • sudo modprobe -rv rtl8723be (don't know what -rv stands for)

    Code: Select all

    rmmod rtl8723be
    rmmod rtl_pci
    rmmod rtl8723_common
    rmmod btcoexist
    rmmod rtlwifi
    
  • activated the second antenna with "sudo modprobe -v rtl8723be ant_sel=2"

    Code: Select all

    insmod /lib/modules/4.15.0-1-amd64/kernel/drivers/net/wireless/realtek/rtlwifi/rtlwifi.ko 
    insmod /lib/modules/4.15.0-1-amd64/kernel/drivers/net/wireless/realtek/rtlwifi/rtl_pci.ko 
    insmod /lib/modules/4.15.0-1-amd64/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723com/rtl8723-common.ko 
    insmod /lib/modules/4.15.0-1-amd64/kernel/drivers/net/wireless/realtek/rtlwifi/btcoexist/btcoexist.ko 
    insmod /lib/modules/4.15.0-1-amd64/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/rtl8723be.ko fwlps=N ips=N swlps=N swenc=Y disable_watchdog=Y ant_sel=2 msi=1 ant_sel=2
    
  • edit the etc/modprobe.d/rtl8723be.conf file like @asinoro wrote a few months ago (It worked perfectly at the time, now no... :eek: )
rebooting the laptop in these days I noticed that sometimes the wifi card detects connections, but when I try to connect to my wifi something fails, I don't have any error message but from that point I can't see any connection anymore...
Last edited by Mich-C on Sun May 27, 2018 5:30 pm, edited 3 times in total.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22217
Joined: Wed Jul 19, 2006 6:13 am

Re: Realtek RTL8723BE : No scan results

#12 Post by Jerry3904 » Sun May 27, 2018 5:09 pm

I can't help with that, but I did enclose all your [*] inside list tags so it all showed correctly
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

Alt
Forum Novice
Forum  Novice
Posts: 75
Joined: Wed Jan 27, 2016 1:28 am

Re: Realtek RTL8723BE : No scan results

#13 Post by Alt » Sat Jun 02, 2018 8:52 am

Few days ago I had problem with RTL8723BE on Lenovo IdeaPad 100 under xUbuntu 18.04.
It just refused to connect to particular router (it accepts password but can't actually connect until NetworkManager gives up). WPA2-encrypted Android WiFi hotspots worked just fine.
I tried probably each available option with no result. I looked at router logs and found something like (deauth *MAC* reason 7).
Then accidentally googled this patch. I read their discussion and tried different kernels.
v4.17-rc7 didn't work, 4.8 worked perfectly (I left it for now), 4.9 was able to connect, 4.10 didn't (just as the person reported on previous link).
I decided to try to merge this patch into custom kernel.
To my great surprise "rtlwifi: rtl8821ae: Fix connection lost problem correctly" patch was already in that kernel (4.15.18)! It used some different value which worked for some people (original patch didn't work for ARM systems).
So we have few options to try
0) Use Debian (or Antix) 4.9 kernel
1) Try wicd instead of NetworkManager (there were some positive reports)
2)
a) recompile kernel with value from original patch (attached to post, maybe Stevo or Anti will try to build it before my test) ;
rtl8821ae-keep-alive-not-set-connection-lost.patch.tar
b) recompile kernel with reverting 4.10 changes (needs investigation)
You do not have the required permissions to view the files attached to this post.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15958
Joined: Fri Dec 15, 2006 8:07 pm

Re: Realtek RTL8723BE : No scan results

#14 Post by Stevo » Sat Jun 02, 2018 1:58 pm

Shouldn't that fix also be in the 4.16 kernels we have available, then?

Alt
Forum Novice
Forum  Novice
Posts: 75
Joined: Wed Jan 27, 2016 1:28 am

Re: Realtek RTL8723BE : No scan results

#15 Post by Alt » Sat Jun 02, 2018 2:14 pm

I've seen this fix applied at 4.15 but it didn't help me. And I'm probably not the only one. Don't have high hopes but still want to try "original 16-bit (unaligned)" value. So I made that patch but didn't test it yet.

Mich-C
Forum Novice
Forum  Novice
Posts: 26
Joined: Tue Nov 21, 2017 1:11 pm

Re: Realtek RTL8723BE : No scan results

#16 Post by Mich-C » Sun Jun 03, 2018 12:26 pm

Many thanks for the help @Alt.
I solved the problem a few days ago. My kernel is the stock mxlinux kernel (4.15.0-1-amd64)
I Installed the driver again from the second source I linked (so instead of this https://github.com/lwfinger/rtlwifi_new ... new_btcoex I used this https://github.com/lwfinger/rtlwifi_new)
Then I created again the missing rtl8723be.conf file in etc/modprobe.d/
options rtl8723be fwlps=N ips=N swlps=N swenc=Y disable_watchdog=Y ant_sel=1 msi=1
This time worked the first antenna, (I remebmer that when using mxlinux 16 things worked with the second one)
TIP: disconnect from any network before turning off wifi (I do this through the hardware button) and reboot the pc between each step

--------------------
Now I have another little problem, I want to disable bluetooth autostart. I read that there are many way to disable it, for example you can do it keeping the bluetooth service running in background and sucking cpu :confused: Can anyone give me an advice?
Also Bluetooth is a bit problematic on pc with this rtl8723be

Sorry for the english of this post :cat:
Last edited by Mich-C on Mon Jun 04, 2018 2:14 pm, edited 1 time in total.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 5966
Joined: Wed Jul 12, 2006 2:10 am

Re: Realtek RTL8723BE : No scan results

#17 Post by Eadwine Rose » Sun Jun 03, 2018 12:28 pm

No worries Mich-C, you are trying and that is great! :number1:
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

Mich-C
Forum Novice
Forum  Novice
Posts: 26
Joined: Tue Nov 21, 2017 1:11 pm

Re: Realtek RTL8723BE : No scan results

#18 Post by Mich-C » Sun Jun 03, 2018 1:05 pm

Hahaha! Thanks a lot Eadwine ;)

Alt
Forum Novice
Forum  Novice
Posts: 75
Joined: Wed Jan 27, 2016 1:28 am

Re: Realtek RTL8723BE : No scan results

#19 Post by Alt » Sun Jun 03, 2018 1:27 pm

Mich-C wrote:
Sun Jun 03, 2018 12:26 pm
Now I have another little problem, I want to disable bluetooth autostart. I read that there are many way to disable it, for example you can do it keeping the bluetooth service running in background and sucking cpu :confused: Can anyone give me an advice?
I recently discovered how to do this for blueman-applet

Manually:
Plugins > PowerManager > Configuration > Auto Power-on

Terminal:

Code: Select all

gsettings set org.blueman.plugins.powermanager auto-power-on false
You can check if device available with

Code: Select all

hcitool dev
As for driver (rtlwifi_new), it's a good idea to try it alone (with old & new values) before recompiling/installing kernel. Hope I'll try all options soon.
P.S. Actually it replaces original kernel modules

Code: Select all

/lib/modules/*kernel_version*/kernel/drivers/net/wireless/realtek/rtlwifi/
and if it works better than build-in drivers, I don't know how to make it future-proof (specific-kernel-version-package? dkms-package?), also we need only 2/12 drivers.

Alt
Forum Novice
Forum  Novice
Posts: 75
Joined: Wed Jan 27, 2016 1:28 am

Re: Realtek RTL8723BE : No scan results

#20 Post by Alt » Mon Jun 04, 2018 8:21 am

So I tried RTL8723BE on Lenovo IdeaPad 100 (both xUbuntu 18.04 & MX Live 17.1 May)

1) Options above - connection can't be established
2) Patched kernel with different value - connection can't be established
3) rtlwifi_new (without any patches) - connected immediately

It would be awesome to have dkms package of rtlwifi_new.
Alternatively, I can try to replace them in the kernel tree.

Few concerns:
1) Makefile backups & replaces original kernel mobules, don't know how it works with dkms
2) We need only rtl8723be and probably rtl8821ae, I don't know how rest of the cards will behave. Also (not sure about that) more modules could make kernel installing/dkms update longer.
Still I'd package them all, it's good to have alternative if you can easily uninstall it.

Post Reply

Return to “Hardware /Configuration”