Welcome!

Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17 RC1 release info here
  • MX-16.1 release info here
  • antiX-17 release info here
    New users
    • Please read this first, and don't forget to add system and hardware information to posts!
    • Read Forum Rules

[SOLVED] Realtek RTL8723BE : No scan results

Message
Author
Mich-C
Forum Novice
Forum  Novice
Posts: 14
Joined: Tue Nov 21, 2017 1:11 pm

[SOLVED] Realtek RTL8723BE : No scan results

#1 Postby Mich-C » Tue Nov 21, 2017 1:30 pm

Hi guys! New user here! I hope I posted in the right section and that my English is good enough ;)

So, My HP laptop has this Wi-Fi card: Realtek RTL8723BE and I can't connect to Intenet :(

iwlist scan

Code: Select all

eth0      Interface doesn't support scanning.

wlan0     No scan results

lo        Interface doesn't support scanning.



sudo iplink set wlan0 up


iwconfig

Code: Select all

eth0      no wireless extensions.

wlan0     IEEE 802.11  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
         
lo        no wireless extensions.




I followeded several guides like this one, commands are always the same--->https://coderew.com/how-to-solve-rtl-wifi-issues-ubuntu/

I extracted the drivers and tryed to use "make" and "make install"
make

Code: Select all

make -C /lib/modules/4.7.0-0.bpo.1-amd64/build M=/home/michele/Scrivania/rtl new modules
make[1]: ingresso nella directory "/usr/src/linux-headers-4.7.0-0.bpo.1-amd64"
arch/x86/Makefile:148: CONFIG_X86_X32 enabled but no binutils support
/usr/src/linux-headers-4.7.0-0.bpo.1-common/Makefile:682: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler
make[3]: ***  Nessuna regola per generare l'obiettivo "new".  Arresto.
Makefile:150: set di istruzioni per l'obiettivo "sub-make" non riuscito
make[2]: *** [sub-make] Errore 2
Makefile:8: set di istruzioni per l'obiettivo "all" non riuscito
make[1]: *** [all] Errore 2
make[1]: uscita dalla directory "/usr/src/linux-headers-4.7.0-0.bpo.1-amd64"
Makefile:58: set di istruzioni per l'obiettivo "all" non riuscito
make: *** [all] Errore 2


sudo make install

Code: Select all

make -C /lib/modules/4.7.0-0.bpo.1-amd64/build M=/home/michele/Scrivania/rtl new modules
make[1]: ingresso nella directory "/usr/src/linux-headers-4.7.0-0.bpo.1-amd64"
arch/x86/Makefile:148: CONFIG_X86_X32 enabled but no binutils support
/usr/src/linux-headers-4.7.0-0.bpo.1-common/Makefile:682: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler
make[3]: ***  Nessuna regola per generare l'obiettivo "new".  Arresto.
Makefile:150: set di istruzioni per l'obiettivo "sub-make" non riuscito
make[2]: *** [sub-make] Errore 2
Makefile:8: set di istruzioni per l'obiettivo "all" non riuscito
make[1]: *** [all] Errore 2
make[1]: uscita dalla directory "/usr/src/linux-headers-4.7.0-0.bpo.1-amd64"
Makefile:58: set di istruzioni per l'obiettivo "all" non riuscito
make: *** [all] Errore 2


sudo modprobe -rv rtl8723be

Code: Select all

rmmod rtl8723be
rmmod rtl_pci
rmmod rtlwifi
rmmod mac80211
rmmod rtl8723_common
rmmod btcoexist


I tryed to activate the second antenna
sudo modprobe -v rtl8723be ant_sel=2

Code: Select all

insmod /lib/modules/4.7.0-0.bpo.1-amd64/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/4.7.0-0.bpo.1-amd64/kernel/drivers/net/wireless/realtek/rtlwifi/rtlwifi.ko
insmod /lib/modules/4.7.0-0.bpo.1-amd64/kernel/drivers/net/wireless/realtek/rtlwifi/rtl_pci.ko
insmod /lib/modules/4.7.0-0.bpo.1-amd64/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723com/rtl8723-common.ko
insmod /lib/modules/4.7.0-0.bpo.1-amd64/kernel/drivers/net/wireless/realtek/rtlwifi/btcoexist/btcoexist.ko
insmod /lib/modules/4.7.0-0.bpo.1-amd64/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/rtl8723be.ko ant_sel=2


and also the first antenna (ant_sel=1) anyway the problem is still here: my laptop can't detect any wifi network :(

Thanks in advance
Last edited by Mich-C on Wed Nov 22, 2017 1:11 pm, edited 1 time in total.

User avatar
asinoro
Forum Regular
Forum Regular
Posts: 494
Joined: Mon Feb 22, 2016 12:26 pm

Re: Realtek RTL8723BE : No scan results

#2 Postby asinoro » Tue Nov 21, 2017 2:32 pm

If your case is solved edit [Solved] to your initial post title to help other users.
Don’t forget to Backup your system
Fix your Grub

Mich-C
Forum Novice
Forum  Novice
Posts: 14
Joined: Tue Nov 21, 2017 1:11 pm

Re: Realtek RTL8723BE : No scan results

#3 Postby Mich-C » Tue Nov 21, 2017 5:56 pm

asinoro wrote:Did you try also this?
https://www.dedoimedo.com/computers/ubu ... altek.html

there is no modprobe.d file in my etc folder :(

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5241
Joined: Sat Jul 15, 2006 10:40 am

Re: Realtek RTL8723BE : No scan results

#4 Postby anticapitalista » Tue Nov 21, 2017 5:58 pm

folder not file
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-15 "Killah P!" - lean and mean.
http://antix.mepis.org

Mich-C
Forum Novice
Forum  Novice
Posts: 14
Joined: Tue Nov 21, 2017 1:11 pm

Re: Realtek RTL8723BE : No scan results

#5 Postby Mich-C » Tue Nov 21, 2017 6:14 pm

anticapitalista wrote:folder not file

ops sorry... there isn't the ''rtl...' file in the /etc/modprobe.d folder :(
anyway I think that something fails during the ''make'' command

Mich-C
Forum Novice
Forum  Novice
Posts: 14
Joined: Tue Nov 21, 2017 1:11 pm

Re: Realtek RTL8723BE : No scan results

#6 Postby Mich-C » Tue Nov 21, 2017 6:45 pm

I also tryed ndiswrapper.
I downloaded 2 drivers for my wi-fi card: one for win7 64bit and another for win10 64bit. I extracted these .exe files both on Windows and linux.
Anyway trying to import the win7 driver (.inf file ) ndiswrapper give me an error, and trying to import the win10 driver ndiswrapper shows folders as empty... :(
Getting this wi-fi working seems impossible in Linux

User avatar
asinoro
Forum Regular
Forum Regular
Posts: 494
Joined: Mon Feb 22, 2016 12:26 pm

Re: Realtek RTL8723BE : No scan results

#7 Postby asinoro » Wed Nov 22, 2017 3:46 am

Follow these steps from terminal.

Code: Select all

git clone https://github.com/lwfinger/rtlwifi_new

Code: Select all

sudo su

Code: Select all

apt-get install linux-headers-$(uname -r) build-essential git

Code: Select all

cd rtlwifi_new

Code: Select all

make clean

Code: Select all

make install

Code: Select all

modprobe rtl8723be

If there is still a problem look again at the link I gave you, have some more instructions at the end.
If your case is solved edit [Solved] to your initial post title to help other users.
Don’t forget to Backup your system
Fix your Grub

Mich-C
Forum Novice
Forum  Novice
Posts: 14
Joined: Tue Nov 21, 2017 1:11 pm

Re: Realtek RTL8723BE : No scan results

#8 Postby Mich-C » Wed Nov 22, 2017 11:46 am

asinoro wrote:Follow these steps from terminal.



Followed each step. Still got this error

make

Code: Select all

make -C /lib/modules/4.7.0-0.bpo.1-amd64/build M=/home/michele/Scrivania/rtl new/rtlwifi_new modules
make[1]: ingresso nella directory "/usr/src/linux-headers-4.7.0-0.bpo.1-amd64"
arch/x86/Makefile:148: CONFIG_X86_X32 enabled but no binutils support
/usr/src/linux-headers-4.7.0-0.bpo.1-common/Makefile:682: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler
make[3]: ***  Nessuna regola per generare l'obiettivo "new/rtlwifi_new".  Arresto.
Makefile:150: set di istruzioni per l'obiettivo "sub-make" non riuscito
make[2]: *** [sub-make] Errore 2
Makefile:8: set di istruzioni per l'obiettivo "all" non riuscito
make[1]: *** [all] Errore 2
make[1]: uscita dalla directory "/usr/src/linux-headers-4.7.0-0.bpo.1-amd64"
Makefile:58: set di istruzioni per l'obiettivo "all" non riuscito
make: *** [all] Errore 2


modinfo rtl8723be

Code: Select all

filename:       /lib/modules/4.7.0-0.bpo.1-amd64/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE   <wlanfae@realtek.com>
author:         PageHe   <page_he@realsil.com.cn>
alias:          pci:v000010ECd0000B723sv*sd*bc*sc*i*
depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
intree:         Y
vermagic:       4.7.0-0.bpo.1-amd64 SMP mod_unload modversions
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
parm:           ant_sel:Set to 1 or 2 to force antenna number (default 0)
 (int)




I can't follow the other steps reported in the link you sent me because I still don't have the "rtl8723be.conf" file

I don't think I need to manually create a wi-fi connection... :(

User avatar
asinoro
Forum Regular
Forum Regular
Posts: 494
Joined: Mon Feb 22, 2016 12:26 pm

Re: Realtek RTL8723BE : No scan results

#9 Postby asinoro » Wed Nov 22, 2017 12:19 pm

I don’t no what you did but with the same steps I install this drive in my laptop.

Code: Select all

modinfo rtl8723be
filename:       /lib/modules/4.2.0-0.bpo.1-amd64/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE   <wlanfae@realtek.com>
author:         PageHe   <page_he@realsil.com.cn>
alias:          pci:v000010ECd0000B723sv*sd*bc*sc*i*
depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
intree:         Y
vermagic:       4.2.0-0.bpo.1-amd64 SMP mod_unload modversions
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)

You make this txt file at /etc/modprobe.d and you name it rtl8723be.conf where you put first
options rtl8723be fwlps=N ips=N
and it looks
/etc/modprobe.d/rtl8723be.conf
Somebody suggested that worked this.
options rtl8723be ips=N fwlps=N swlps=N swenc=Y disable_watchdog=Y ant_sel=2 msi=1

https://github.com/lwfinger/rtlwifi_new/issues/88
If your case is solved edit [Solved] to your initial post title to help other users.
Don’t forget to Backup your system
Fix your Grub

Mich-C
Forum Novice
Forum  Novice
Posts: 14
Joined: Tue Nov 21, 2017 1:11 pm

Re: Realtek RTL8723BE : No scan results

#10 Postby Mich-C » Wed Nov 22, 2017 1:09 pm

asinoro wrote:I don’t no what you did but with the same steps I install this drive in my laptop.

Code: Select all

modinfo rtl8723be
filename:       /lib/modules/4.2.0-0.bpo.1-amd64/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE   <wlanfae@realtek.com>
author:         PageHe   <page_he@realsil.com.cn>
alias:          pci:v000010ECd0000B723sv*sd*bc*sc*i*
depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
intree:         Y
vermagic:       4.2.0-0.bpo.1-amd64 SMP mod_unload modversions
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)

You make this txt file at /etc/modprobe.d and you name it rtl8723be.conf where you put first
options rtl8723be fwlps=N ips=N
and it looks
/etc/modprobe.d/rtl8723be.conf
Somebody suggested that worked this.
options rtl8723be ips=N fwlps=N swlps=N swenc=Y disable_watchdog=Y ant_sel=2 msi=1

https://github.com/lwfinger/rtlwifi_new/issues/88

Hi asinoro, you're a genius! Many Many thanks :D
I finally solved this problem manually adding that file... I searched a lot on Internet forums and the solution was always "compile and install the driver".

P.S. Now i'm tryng to reinstall grub because something went wrong during the MX installation alongside Window, anyway I will follow the guide in your signature! ;)


Return to “Hardware /Configuration”

Who is online

Users browsing this forum: No registered users and 3 guests