Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

HP Laserjet Pro M125nw stopped working

Message
Author
jerry525
Forum Novice
Forum  Novice
Posts: 72
Joined: Sat Jun 07, 2014 10:39 am

HP Laserjet Pro M125nw stopped working

#1 Post by jerry525 » Sun Aug 27, 2017 10:29 am

Hello, my printer has been working fine but has recently stopped. I get print error message; "There was a problem processing the document". I've tried deleting the printer then installing again, reinstalling hplip but no joy. The scanner works fine & I can use it as a copier so I don't think the printer is faulty.
Can anyone help please?

User avatar
mw1649
Forum Novice
Forum  Novice
Posts: 53
Joined: Fri Jan 02, 2015 3:17 am

Re: HP Laserjet Pro M125nw stopped working

#2 Post by mw1649 » Mon Aug 28, 2017 3:44 am

Do you know if you ran updates prior to the problem arising?

In my experience, on more than one occasion HPLIP updates have caused issues with different HP printers.

What I now do is lock the HPLIP version (via Synaptic) on a working install.

Try reverting to an older version of HPLIP or maybe a newer update might fix the problem.

Mike
TOSHIBA Satellite Pro C850
Distro: MX-15_x64 Fusion 24 December 2015
Dual core Intel Core i3-2350M
Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Intel 7 Series/C210 Series Family High Definition Audio Controller

jerry525
Forum Novice
Forum  Novice
Posts: 72
Joined: Sat Jun 07, 2014 10:39 am

Re: HP Laserjet Pro M125nw stopped working

#3 Post by jerry525 » Mon Aug 28, 2017 4:58 am

Thanks Mike, yes I'm pretty sure it was due to updates.
How do I install an older version of HPlip?

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6057
Joined: Wed Jul 12, 2006 2:10 am

Re: HP Laserjet Pro M125nw stopped working

#4 Post by Eadwine Rose » Mon Aug 28, 2017 11:13 am

Have you checked to see if the printer is enabled?

Under print settings - configure printers (in the menu) you can see your printer. Right click on it and check if there is a checkmark next to enabled. If not, click on it to enable the printer.
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

jerry525
Forum Novice
Forum  Novice
Posts: 72
Joined: Sat Jun 07, 2014 10:39 am

Re: HP Laserjet Pro M125nw stopped working

#5 Post by jerry525 » Tue Aug 29, 2017 4:13 am

Yes thanks, printer is enabled.
How do I install an older hplip package?

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22474
Joined: Wed Jul 19, 2006 6:13 am

Re: HP Laserjet Pro M125nw stopped working

#6 Post by Jerry3904 » Tue Aug 29, 2017 7:08 am

Please see Section 5.3.2 of the Users Manual.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

jerry525
Forum Novice
Forum  Novice
Posts: 72
Joined: Sat Jun 07, 2014 10:39 am

Re: HP Laserjet Pro M125nw stopped working

#7 Post by jerry525 » Tue Aug 29, 2017 7:43 am

I followed the manual but it installs the latest version even when I force it.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22474
Joined: Wed Jul 19, 2006 6:13 am

Re: HP Laserjet Pro M125nw stopped working

#8 Post by Jerry3904 » Tue Aug 29, 2017 8:30 am

what is the output of

Code: Select all

apt-cache policy hplip
Also: you have to pin the lower package (next section in the Manual) or it will be immediately upgraded again.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4375
Joined: Wed Jul 12, 2006 4:05 pm

Re: HP Laserjet Pro M125nw stopped working

#9 Post by timkb4cq » Tue Aug 29, 2017 2:00 pm

Hplip in MX-15 / MX-16 main hasn't been been updated since May.
The version in the testing repository (which you shouldn't leave active) was last updated July 9
So if this was due to a recent update, it's likely not the hplip package that's responsible.

If you're running version 3.16.11 then you have the version in the MX main repositories.
If you're running version 3.17.6 then you have the version in the MX testing repositories.
If you're running version 3.14.6 then you have the version in the debian repositories.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

jerry525
Forum Novice
Forum  Novice
Posts: 72
Joined: Sat Jun 07, 2014 10:39 am

Re: HP Laserjet Pro M125nw stopped working

#10 Post by jerry525 » Wed Aug 30, 2017 6:11 am

Jerry3904 wrote:what is the output of

Code: Select all

apt-cache policy hplip
Also: you have to pin the lower package (next section in the Manual) or it will be immediately upgraded again.

Code: Select all

$ apt-cache policy hplip
hplip:
  Installed: 3.16.11+repack0-1mx15+1
  Candidate: 3.16.11+repack0-1mx15+1
  Version table:
 *** 3.16.11+repack0-1mx15+1 0
        500 http://mxrepo.com/mx/repo/ mx15/main amd64 Packages
        100 /var/lib/dpkg/status
     3.16.10+repack0-1mx15+1 0
        500 http://mxrepo.com/mx/repo/ mx16/main amd64 Packages
     3.14.6-1+deb8u1 0
        500 http://ftp.us.debian.org/debian/ jessie/main amd64 Packages

Post Reply

Return to “Hardware /Configuration”