Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Thinkpad data request.

Post Reply
Message
Author
User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 2088
Joined: Mon Nov 21, 2011 5:50 pm

Thinkpad data request.

#1 Post by Gordon Cooper » Wed Nov 07, 2018 9:41 pm

The update to Thinkpad documentation (promised two months ago) is nearly finished. I still lack specification data for several versions and
will be very grateful if those of you using the following could open the terminal, run inxi -Fxxx, and post the results to this Forum thread.

Thinkpad Model info' needed : T22, T23, T41, X130e, W520, 100s, s21e, A58, T42, T431s, T450, T520s, T560, X131e.

Acknowledge that some of this info may already be in the forum, but a search on the word Thinkpad generates several thousand
blocks of information and I may have missed a few.
Thanks,
Gordon.
Last edited by Gordon Cooper on Thu Nov 08, 2018 2:31 pm, edited 2 times in total.
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9575
Joined: Sun Dec 16, 2007 1:17 pm

Re: Thinkpad data request.

#2 Post by dolphin_oracle » Wed Nov 07, 2018 10:19 pm

T530

Code: Select all

System:    Host: littlebyte Kernel: 4.17.0-3-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0 Desktop: Xfce 4.12.3 
           tk: Gtk 2.24.31 info: xfce4-panel wm: xfwm4 dm: LightDM 1.18.3 
           Distro: MX-17.1_x64 Horizon March 14  2018 base: Debian GNU/Linux 9 (stretch) 
Machine:   Type: Laptop System: LENOVO product: 2392APU v: ThinkPad T530 serial: <root required> Chassis: 
           type: 10 serial: <root required> 
           Mobo: LENOVO model: 2392APU v: 0B98401 Pro serial: <root required> UEFI: LENOVO v: G4ET98WW (2.58 ) 
           date: 11/26/2013 
Battery:   ID-1: BAT0 charge: 35.6 Wh condition: 35.6/47.5 Wh (75%) volts: 12.2/10.8 model: SANYO 45N1001 
           type: Li-ion serial:   934 status: Full 
CPU:       Topology: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 
           L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20753 
           Speed: 1197 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1197 2: 1196 3: 1198 4: 1199 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0166 
           Display: x11 server: X.Org 1.19.2 driver: intel resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 3.3 Mesa 13.0.6 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
           Sound Server: ALSA v: k4.17.0-3-amd64 
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e v: 3.2.6-k port: 5080 
           bus ID: 00:19.0 chip ID: 8086:1502 
           IF: eth0 state: down mac: 3c:97:0e:ef:2e:76 
           Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel port: efa0 
           bus ID: 03:00.0 chip ID: 8086:0085 
           IF: wlan0 state: up mac: e0:9d:31:2e:b7:d0 
Drives:    Local Storage: total: 1.14 TiB used: 306.11 GiB (26.3%) 
           ID-1: /dev/sda vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB speed: 6.0 Gb/s 
           serial: 1822E13FB9F2 rev: 020 scheme: GPT 
           ID-2: /dev/sdb vendor: Seagate model: ST1000LM048-2E7172 size: 931.51 GiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: WDEGE89N rev: SDM1 scheme: GPT 
Partition: ID-1: / size: 34.20 GiB used: 8.30 GiB (24.3%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 32.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 215 Uptime: 14m Memory: 7.62 GiB used: 982.9 MiB (12.6%) Init: SysVinit v: 2.88 
           runlevel: 5 default: 5 Compilers: gcc: 6.3.0 alt: 6 Shell: bash v: 4.4.12 running in: xfce4-terminal 
           inxi: 3.0.25 
I can post a s21e tomorrow (I left it at work).
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 2088
Joined: Mon Nov 21, 2011 5:50 pm

Re: Thinkpad data request.

#3 Post by Gordon Cooper » Wed Nov 07, 2018 10:27 pm

Thanks dolphin
G.
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
male
Forum Regular
Forum Regular
Posts: 294
Joined: Thu Jan 23, 2014 8:38 am

Re: Thinkpad data request.

#4 Post by male » Thu Nov 08, 2018 4:35 am

x40

Code: Select all

System:    Host: helium Kernel: 4.9.0-8-686 i686 (32 bit gcc: 6.3.0)
           Desktop: Openbox 3.6.1 dm: lightdm Distro: BunsenLabs GNU/Linux 9.5 (Helium)
Machine:   Device: laptop System: IBM product: 2371H8G v: ThinkPad X40 Chassis: type: 10
           Mobo: IBM model: 2371H8G BIOS: IBM v: 1UETD3WW (2.08 ) date: 12/21/2006
Battery    BAT0: charge: 0.9 Wh 97.8% condition: 0.9/27.4 Wh (3%) volts: 16.4/14.4
           model: Panasonic IBM-92P1000 Li-ion serial: 477 status: Full cycles: 0
CPU:       Single core Intel Pentium M (-UP-) cache: 2048 KB
           flags: (sse sse2) bmips: 2790 speed/min/max: 1400/600/1400 MHz
Graphics:  Card: Intel 82852/855GM Integrated Graphics Device bus-ID: 00:02.0 chip-ID: 8086:3582
           Display Server: X.Org 1.19.2 drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1024x768@50.01hz
           GLX Renderer: Mesa DRI Intel 852GM/855GM x86/MMX/SSE2
           GLX Version: 1.3 Mesa 13.0.6 Direct Rendering: Yes
Audio:     Card Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
           driver: snd_intel8x0 ports: 1c00 18c0 bus-ID: 00:1f.5 chip-ID: 8086:24c5
           Sound: Advanced Linux Sound Architecture v: k4.9.0-8-686
Network:   Card-1: Intel PRO/Wireless 2200BG [Calexico2] Network Connection
           driver: ipw2200 v: 1.2.2kmprq bus-ID: 02:02.0 chip-ID: 8086:4220
           IF: wlp2s2 state: down mac: <filter>
           Card-2: 3Com 3cCFE575CT CardBus [Cyclone]
           driver: 3c59x port: 3000 bus-ID: 03:00.0 chip-ID: 10b7:5257
           IF: enp3s0 state: unknown speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 60.1GB (15.8% used)
           ID-1: /dev/sda model: MXSSD1MNANO size: 60.1GB serial: 110105411 temp: 0C
Partition: ID-1: / size: 11G used: 2.7G (27%) fs: ext4 dev: /dev/sda7
           ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 44.0C mobo: 36.0C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 115 Uptime: 6 min Memory: 249.0/1503.2MB
           Init: systemd v: 232 runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.121 running in x-terminal-emul) inxi: 2.3.5 
Male is the capital of the Maldives and its wonderful people.

Kulmbacher
Forum Novice
Forum  Novice
Posts: 77
Joined: Fri Apr 27, 2018 2:47 pm

Re: Thinkpad data request.

#5 Post by Kulmbacher » Thu Nov 08, 2018 6:04 am

T520

Code: Select all

System:    Host: mx Kernel: 4.9.0-8-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3 
           Distro: MX-17.1_x64 Horizon March 14  2018 
Machine:   Type: Laptop System: LENOVO product: 42405CG v: ThinkPad T520 serial: <root required> 
           Mobo: LENOVO model: 42405CG serial: <root required> UEFI [Legacy]: LENOVO v: 8AET51WW (1.31 ) 
           date: 08/08/2011 
Battery:   ID-1: BAT0 charge: 36.3 Wh condition: 37.1/47.5 Wh (78%) 
CPU:       Topology: Dual Core model: Intel Core i5-2430M bits: 64 type: MT MCP L2 cache: 3072 KiB 
           Speed: 881 MHz min/max: 800/3000 MHz Core speeds (MHz): 1: 881 2: 808 3: 977 4: 897 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915 v: kernel 
           Display: x11 server: X.Org 1.19.2 driver: intel resolution: 1366x768~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 13.0.6 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.9.0-8-amd64 
Network:   Device-1: Intel Centrino Wireless-N 1000 [Condor Peak] driver: iwlwifi 
           IF: wlan0 state: up mac: 74:e5:0b:53:b0:16 
Drives:    Local Storage: total: 822.98 GiB used: 607.67 GiB (73.8%) 
           ID-1: /dev/mmcblk0 model: N/A size: 29.82 GiB 
           ID-2: /dev/sda vendor: SanDisk model: SDSSDA240G size: 223.57 GiB 
           ID-3: /dev/sdb vendor: Intel model: SSDMAEMC080G2 size: 74.53 GiB 
           ID-4: /dev/sdc type: USB vendor: Intenso model: Rainbow Line size: 29.30 GiB 
           ID-5: /dev/sdd vendor: Seagate model: ST9500420AS size: 465.76 GiB 
Partition: ID-1: / size: 16.52 GiB used: 6.05 GiB (36.6%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 54.68 GiB used: 11.33 GiB (20.7%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 219 Uptime: 3h 07m Memory: 7.58 GiB used: 1.09 GiB (14.4%) Shell: bash inxi: 3.0.25 

User avatar
Hierax_ca
Forum Regular
Forum Regular
Posts: 132
Joined: Sun Nov 08, 2015 6:46 pm

Re: Thinkpad data request.

#6 Post by Hierax_ca » Sun Nov 11, 2018 7:32 pm

Gordon Cooper wrote:
Wed Nov 07, 2018 9:41 pm
Thinkpad Model info' needed : ... W520
I've posted info on a W520 in the other thread:
- viewtopic.php?f=101&t=39270&p=461189#p461189

Works great with MX as long as Graphic card in the BIOS isn't set to Optimus: "Graphics worked fine with the open source drivers and also with the proprietary NVidia 384.130 (I didn't try the backports one because I remember some YouTubers having major issues with the 390.xx and skipping it for a newer one). However, to get the proprietary drivers working you have to make sure that the BIOS setting (F1 or ThinkVantage button on Boot --> Config --> Display --> Graphic Device) has the display NOT set to Optimus mode or it won't boot properly, you can use" Integrated Graphics" for the Intel or "Discrete Graphics" for the NVidia, Optimus works fine with Windows but not Linux."

but here's the inxi again:

Code: Select all

System:    Host: Thinkpad-W520-Linux-MX-17 Kernel: 4.9.126-antix.1-amd64-smp x86_64 bits: 64 compiler: gcc 
           v: 6.3.0 Desktop: Xfce 4.12.3 tk: Gtk 2.24.31 info: xfce4-panel wm: xfwm4 dm: LightDM 1.18.3 
           Distro: MX-17.1_x64 Horizon December 15  2017 base: Debian GNU/Linux 9 (stretch) 

Machine:   Type: Laptop System: LENOVO product: 42844YU v: ThinkPad W520 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: LENOVO model: 42844YU serial: <filter> UEFI [Legacy]: LENOVO v: 8BET56WW (1.36 ) 
           date: 01/19/2012 

Battery:   ID-1: BAT0 charge: 60.0 Wh condition: 36.7/86.6 Wh (42%) volts: 12.5/11.1 model: LGC 42T4969 
           type: Li-ion serial: <filter> status: Charging 

CPU:       Topology: Quad Core model: Intel Core i7-2860QM bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 
           L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 39883 
           Speed: 868 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 868 2: 800 3: 2129 4: 1273 5: 2131 6: 800 
           7: 2074 8: 1277 

Graphics:  Device-1: NVIDIA GF106GLM [Quadro 2000M] vendor: Lenovo driver: nvidia v: 384.130 bus ID: 01:00.0 
           chip ID: 10de:0dda 
           Display: x11 server: X.Org 1.19.2 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: Quadro 2000M/PCIe/SSE2 v: 4.5.0 NVIDIA 384.130 direct render: Yes 

Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Lenovo 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
           Device-2: NVIDIA GF106 High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0be9 
           Sound Server: ALSA v: k4.9.126-antix.1-amd64-smp 

Network:   Device-1: Intel 82579LM Gigabit Network driver: e1000e v: 3.2.6-k port: 6040 bus ID: 00:19.0 
           chip ID: 8086:1502 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi v: kernel bus ID: 03:00.0 
           chip ID: 8086:4238 
           IF: wlan0 state: up mac: <filter> 

Drives:    Local Storage: total: 4.55 TiB used: 17.11 GiB (0.4%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000LX001-1RG174 size: 1.82 TiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: MBR 
           ID-2: /dev/sdb vendor: Seagate model: ST2000LX001-1RG174 size: 1.82 TiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: MBR 
           ID-3: /dev/sdc vendor: Samsung model: SSD 850 EVO mSATA 1TB size: 931.51 GiB speed: 3.0 Gb/s 
           serial: <filter> rev: 1B6Q scheme: MBR 

Partition: ID-1: / size: 908.02 GiB used: 17.11 GiB (1.9%) fs: ext4 dev: /dev/sdc1 
           ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdc2 

Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A gpu: nvidia temp: 46 C 
           Fan Speeds (RPM): cpu: 2526 

Info:      Processes: 295 Uptime: N/A Memory: 23.50 GiB used: 505.8 MiB (2.1%) Init: SysVinit v: 2.88 
           runlevel: 5 default: 5 Compilers: gcc: 6.3.0 alt: 6 Shell: bash v: 4.4.12 running in: xfce4-terminal 
           inxi: 3.0.24
MX-14.4/16.1 (32-bit) Thinkpad 600x*;
MX-17.1 (32-bit): Thinkpad A31p, T43p, T60p;
MX-17.1 (64-bit): Thinkpad x60t*, x61t*, x61s, T61p, T601pF, x200, x200t*, x301*, T500, W500, W700(ds), W701, x220, x220t*, W520.

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 2088
Joined: Mon Nov 21, 2011 5:50 pm

Re: Thinkpad data request.

#7 Post by Gordon Cooper » Sun Nov 11, 2018 7:52 pm

Re W520. Many thanks Hierax, don't know how I missed it in the thread. Finished assembling it all over last weekend and should be up for review this week.
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

Post Reply

Return to “Hardware /Configuration”