Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

hwmon_device

Post Reply
Message
Author
tradonal
Forum Novice
Forum  Novice
Posts: 80
Joined: Mon Sep 25, 2017 11:43 am

hwmon_device

#1 Post by tradonal » Wed Feb 14, 2018 12:22 pm

hello all

I am french, subject translated by google
How to interpret this?
is there a modification to do?
thank you

Code: Select all

$ grep -i hwmon /var/log/dmesg*
/var/log/dmesg:[    2.359219] (NULL device *): hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
/var/log/dmesg:[   10.816188] k8temp 0000:00:18.3: hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
/var/log/dmesg.0:[    2.398841] (NULL device *): hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
/var/log/dmesg.0:[   12.180493] k8temp 0000:00:18.3: hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
hwmon_device_register() est obsolète. S'il vous plaît convertir le pilote à utiliser
hwmon_device_register_with_info() ? commande ?

User avatar
rokytnji.1
Forum Regular
Forum Regular
Posts: 752
Joined: Sun Apr 13, 2014 9:06 pm

Re: hwmon_device

#2 Post by rokytnji.1 » Wed Feb 14, 2018 3:07 pm

You running nvidia graphics?

Code: Select all

inxi -Fxz
Post the above readout in code tags please so more info means better help.

User avatar
rokytnji.1
Forum Regular
Forum Regular
Posts: 752
Joined: Sun Apr 13, 2014 9:06 pm

Re: hwmon_device

#3 Post by rokytnji.1 » Wed Feb 14, 2018 3:10 pm

The reason I mentioned the above
Please convert the driver

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16272
Joined: Fri Dec 15, 2006 8:07 pm

Re: hwmon_device

#4 Post by Stevo » Wed Feb 14, 2018 3:21 pm

It looks like a harmless warning in the kernel k8temp module. To get rid of it, you would have to patch the kernel source like this patch: https://github.com/s3k0/hwmon_device_re ... ster.patch

and then rebuild the kernel.

Which kernel are you running? (uname -r)

tradonal
Forum Novice
Forum  Novice
Posts: 80
Joined: Mon Sep 25, 2017 11:43 am

Re: hwmon_device

#5 Post by tradonal » Fri Feb 16, 2018 6:19 pm

hello all
I will expose more precisely to answer you
-) Here are the requested exits

You running nvidia graphics?
No, radeon

Code: Select all

root@mx1:/# inxi
CPU~Single core AMD Sempron 3000+ (-UP-) speed/max~1000/1800 MHz Kernel~4.10.1-antix.1-486-smp i686 Up~1:41 Mem~373.7/1255.5MB HDD~60.0GB(37.2% used) Procs~179 Client~Shell inxi~2.3.56  

root@mx1:/# inxi -Fxz
System:    Host: mx1 Kernel: 4.10.1-antix.1-486-smp i686 bits: 32 gcc: 4.9.3
           Desktop: Xfce 4.12.2 (Gtk 2.24.25) Distro: MX-16-RC1_386 Metamorphosis 24 November 2016
           
Machine:   Device: laptop System: Hewlett-Packard product: Pavilion zv6000 (PZ989EA#UUG) v: F.08 serial: <filter>
           Mobo: Hewlett-Packard model: 3085 v: 42.24 serial: <filter>
           BIOS: Hewlett-Packard v: F.08 date: 03/22/2005
           
CPU:       Single core AMD Sempron 3000+ (-UP-) arch: K8 rev.0 cache: 128 KB
           flags: (nx pae sse sse2) bmips: 1989 speed/max: 1000/1800 MHz
           
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS480M [Mobility Radeon Xpress 200]
           bus-ID: 01:05.0
           Display Server: X.Org 1.16.4 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x800@60.12hz
           OpenGL: renderer: Gallium 0.4 on ATI RS480 version: 2.1 Mesa 12.0.3 Direct Render: Yes
           
Audio:     Card Advanced Micro Devices [AMD/ATI] IXP SB400 AC'97 Audio Controller
           driver: snd_atiixp bus-ID: 00:14.5
           Sound: Advanced Linux Sound Architecture v: k4.10.1-antix.1-486-smp
           
Network:   Card-1: Broadcom Limited BCM4306 802.11b/g Wireless LAN Controller
           driver: b43-pci-bridge bus-ID: 03:02.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
           driver: 8139too v: 0.9.28 port: a000 bus-ID: 03:06.0
           IF: eth0 state: down mac: <filter>
           
Drives:    HDD Total Size: 60.0GB (37.2% used)
           ID-1: /dev/sda model: IC25N060ATMR04 size: 60.0GB temp: 33C
           
Partition: ID-1: / size: 31G used: 19G (67%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.10GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
           
Sensors:   System Temperatures: cpu: 50.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
           
Info:      Processes: 179 Uptime: 1:44 Memory: 375.9/1255.5MB
           Init: systemd runlevel: 5 Gcc sys: 4.9.2 Client: Shell (bash 4.3.301) inxi: 2.3.56 
root@mx1:/# 
peux être que ces divers sorties pourront aider

Code: Select all

root@mx1:/# sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +32.0°C  (crit = +82.0°C)

k8temp-pci-00c3
Adapter: PCI adapter
Core0 Temp:   +41.0°C  

Code: Select all

root@mx1:/# modinfo k8temp 
filename:       /lib/modules/4.10.1-antix.1-486-smp/kernel/drivers/hwmon/k8temp.ko
license:        GPL
description:    AMD K8 core temperature monitor
author:         Rudolf Marek <r.marek@assembler.cz>
alias:          pci:v00001022d00001103sv*sd*bc*sc*i*
depends:        
intree:         Y
vermagic:       4.10.1-antix.1-486-smp SMP mod_unload modversions 486

Code: Select all

root@mx1:/# dmesg | grep -i k8
[   14.527789] k8temp 0000:00:18.3: hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
[   15.015883] powernow_k8: fid 0xa (1800 MHz), vid 0x6
[   15.015958] powernow_k8: fid 0x2 (1000 MHz), vid 0x10
[   15.016311] powernow_k8: Found 1 AMD Sempron(tm) Processor 3000+ (1 cpu cores) (version 2.20.00)

root@mx1:/# dmesg | grep -i 0000:00:18.3
[    0.134909] pci 0000:00:18.3: [1022:1103] type 00 class 0x060000
[   14.527789] k8temp 0000:00:18.3: hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().

root@mx1:/# lspci -vvd 1022:1103
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
	Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Kernel driver in use: k8temp

root@mx1:/# 
It looks like a harmless warning in the kernel k8temp module. To get rid of it, you would have to patch the kernel source like this patch: https://github.com/s3k0/hwmon_device_re ... ster.patch

and then rebuild the kernel.
I just noticed this my pci id 1022: 1103 on my pc is for Host bridge
athttps://pci-ids.ucw.cz/read/PC/1022/1103 is K8 NorthBridge

thx all

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16272
Joined: Fri Dec 15, 2006 8:07 pm

Re: hwmon_device

#6 Post by Stevo » Fri Feb 16, 2018 7:06 pm

Perhaps you can add a newer antiX 486 kernel to see if they have updated the driver code to get rid of the message, but it's a harmless warning in my opinion.

tradonal
Forum Novice
Forum  Novice
Posts: 80
Joined: Mon Sep 25, 2017 11:43 am

Re: hwmon_device

#7 Post by tradonal » Wed Feb 21, 2018 1:45 pm

re,
with this kernel ~ 3.16.0-4-586 i686 and boot with init=/lib/systemd/systemd
no k8temp and hwmon

Code: Select all

root@mx1:/
# dmesg | grep -i k8temp
root@mx1:/
# dmesg | grep -i hwmon
root@mx1:/
just for info the difference between the two boot
Kernel~4.10.1-antix.1-486-smp i686

Code: Select all

root@mx1:/# inxi
CPU~Single core AMD Sempron 3000+ (-UP-) speed/max~1000/1800 MHz Kernel~4.10.1-antix.1-486-smp i686 Up~1:41 Mem~373.7/1255.5MB HDD~60.0GB(37.2% used) Procs~179 Client~Shell inxi~2.3.56  
Kernel~3.16.0-4-586 i686

Code: Select all

root@mx1:/# inxi
CPU~Single core AMD Sempron 3000+ (-UP-) speed/max~1000/1800 MHz Kernel~3.16.0-4-586 i686 Up~24 min Mem~333.5/1261.1MB HDD~60.0GB(41.4% used) Procs~139 Client~Shell inxi~2.3.56 
Kernel~4.10.1-antix.1-486-smp i686

Code: Select all

root@mx1:/# inxi -Fxz
System:    Host: mx1 Kernel: 4.10.1-antix.1-486-smp i686 bits: 32 gcc: 4.9.3
           Desktop: Xfce 4.12.2 (Gtk 2.24.25) Distro: MX-16-RC1_386 Metamorphosis 24 November 2016
           
Machine:   Device: laptop System: Hewlett-Packard product: Pavilion zv6000 (PZ989EA#UUG) v: F.08 serial: <filter>
           Mobo: Hewlett-Packard model: 3085 v: 42.24 serial: <filter>
           BIOS: Hewlett-Packard v: F.08 date: 03/22/2005
           
CPU:       Single core AMD Sempron 3000+ (-UP-) arch: K8 rev.0 cache: 128 KB
           flags: (nx pae sse sse2) bmips: 1989 speed/max: 1000/1800 MHz
           
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS480M [Mobility Radeon Xpress 200]
           bus-ID: 01:05.0
           Display Server: X.Org 1.16.4 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x800@60.12hz
           OpenGL: renderer: Gallium 0.4 on ATI RS480 version: 2.1 Mesa 12.0.3 Direct Render: Yes
           
Audio:     Card Advanced Micro Devices [AMD/ATI] IXP SB400 AC'97 Audio Controller
           driver: snd_atiixp bus-ID: 00:14.5
           Sound: Advanced Linux Sound Architecture v: k4.10.1-antix.1-486-smp
           
Network:   Card-1: Broadcom Limited BCM4306 802.11b/g Wireless LAN Controller
           driver: b43-pci-bridge bus-ID: 03:02.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
           driver: 8139too v: 0.9.28 port: a000 bus-ID: 03:06.0
           IF: eth0 state: down mac: <filter>
           
Drives:    HDD Total Size: 60.0GB (37.2% used)
           ID-1: /dev/sda model: IC25N060ATMR04 size: 60.0GB temp: 33C
           
Partition: ID-1: / size: 31G used: 19G (67%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.10GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
           
Sensors:   System Temperatures: cpu: 50.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
           
Info:      Processes: 179 Uptime: 1:44 Memory: 375.9/1255.5MB
           Init: systemd runlevel: 5 Gcc sys: 4.9.2 Client: Shell (bash 4.3.301) inxi: 2.3.56 
Kernel~3.16.0-4-586 i686

Code: Select all

# inxi -Fxz
System:    Host: mx1 Kernel: 3.16.0-4-586 i686 bits: 32 gcc: 4.8.4
           Desktop: Xfce 4.12.2 (Gtk 2.24.25) Distro: MX-16-RC1_386 Metamorphosis 24 November 2016
           
Machine:   Device: laptop System: Hewlett-Packard product: Pavilion zv6000 (PZ989EA#UUG) v: F.08 serial: <filter>
           Mobo: Hewlett-Packard model: 3085 v: 42.24 serial: <filter>
           BIOS: Hewlett-Packard v: F.08 date: 03/22/2005
           
CPU:       Single core AMD Sempron 3000+ (-UP-) arch: K8 rev.0 cache: 128 KB
           flags: (nx pae sse sse2) bmips: 1989 speed/max: 1000/1800 MHz
           
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS480M [Mobility Radeon Xpress 200]
           bus-ID: 01:05.0
           Display Server: X.Org 1.16.4 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x800@60.12hz
           OpenGL: renderer: Gallium 0.4 on ATI RS480 version: 2.1 Mesa 12.0.3 Direct Render: Yes
           
Audio:     Card Advanced Micro Devices [AMD/ATI] IXP SB400 AC'97 Audio Controller
           driver: snd_atiixp bus-ID: 00:14.5
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-586
           
Network:   Card-1: Broadcom Limited BCM4306 802.11b/g Wireless LAN Controller
           driver: b43-pci-bridge bus-ID: 03:02.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
           driver: 8139too v: 0.9.28 port: a000 bus-ID: 03:06.0  
           IF: eth0 state: down mac: <filter>
           
Drives:    HDD Total Size: 60.0GB (41.4% used)
           ID-1: /dev/sda model: IC25N060ATMR04 size: 60.0GB temp: 25C
           
Partition: ID-1: / size: 31G used: 22G (75%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.10GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
           
Sensors:   System Temperatures: cpu: 36.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
           
Info:      Processes: 140 Uptime: 30 min Memory: 337.9/1261.1MB
           Init: systemd runlevel: 5 Gcc sys: 4.9.2 Client: Shell (bash 4.3.301) inxi: 2.3.56 
Kernel~4.10.1-antix.1-486-smp i686

Code: Select all

root@mx1:/# sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +32.0°C  (crit = +82.0°C)

k8temp-pci-00c3
Adapter: PCI adapter
Core0 Temp:   +41.0°C  
Kernel~3.16.0-4-586 i686

Code: Select all

root@mx1:/# sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +34.0°C  (crit = +82.0°C)

k8temp-pci-00c3
Adapter: PCI adapter
Core0 Temp:   +38.0°C  
Kernel~4.10.1-antix.1-486-smp i686

Code: Select all

root@mx1:/# modinfo k8temp 
filename:       /lib/modules/4.10.1-antix.1-486-smp/kernel/drivers/hwmon/k8temp.ko
license:        GPL
description:    AMD K8 core temperature monitor
author:         Rudolf Marek <r.marek@assembler.cz>
alias:          pci:v00001022d00001103sv*sd*bc*sc*i*
depends:        
intree:         Y
vermagic:       4.10.1-antix.1-486-smp SMP mod_unload modversions 486
Kernel~3.16.0-4-586 i686

Code: Select all

root@mx1:/#  modinfo k8temp 
filename:       /lib/modules/3.16.0-4-586/kernel/drivers/hwmon/k8temp.ko
license:        GPL
description:    AMD K8 core temperature monitor
author:         Rudolf Marek <r.marek@assembler.cz>
alias:          pci:v00001022d00001103sv*sd*bc*sc*i*
depends:        
intree:         Y
vermagic:       3.16.0-4-586 mod_unload modversions 586TSC 
Kernel~4.10.1-antix.1-486-smp i686

Code: Select all

root@mx1:/# dmesg | grep -i k8
[   14.527789] k8temp 0000:00:18.3: hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
[   15.015883] powernow_k8: fid 0xa (1800 MHz), vid 0x6
[   15.015958] powernow_k8: fid 0x2 (1000 MHz), vid 0x10
[   15.016311] powernow_k8: Found 1 AMD Sempron(tm) Processor 3000+ (1 cpu cores) (version 2.20.00)

root@mx1:/# dmesg | grep -i 0000:00:18.3
[    0.134909] pci 0000:00:18.3: [1022:1103] type 00 class 0x060000
[   14.527789] k8temp 0000:00:18.3: hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().

root@mx1:/# lspci -vvd 1022:1103
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
	Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Kernel driver in use: k8temp
root@mx1:/# 
Kernel~3.16.0-4-586 i686

Code: Select all

root@mx1:/# dmesg | grep -i k8
[   17.568035] powernow_k8: fid 0xa (1800 MHz), vid 0x6
[   17.568171] powernow_k8: fid 0x2 (1000 MHz), vid 0x10
[   17.569825] powernow_k8: Found 1 AMD Sempron(tm) Processor 3000+ (1 cpu cores) (version 2.20.00)

root@mx1:/# dmesg | grep -i 0000:00:18.3
[    0.175866] pci 0000:00:18.3: [1022:1103] type 00 class 0x060000

root@mx1:/# lspci -vvd 1022:1103
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
	Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Kernel driver in use: k8temp
What do you think ? thank you

Post Reply

Return to “Hardware /Configuration”