Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] gufw firewall cannot be installed

Help for Current Versions of MX
User avatar
Stevo
Developer
Posts: 20096
Joined: Fri Dec 15, 2006 8:07 pm

Re: gufw firewall cannot be installed

#11

Post by Stevo » Thu Aug 08, 2019 3:48 pm

Code: Select all

2.24.2-1~bpo9+1
It also looks like stretch-backports now has the newest version, and somehow got mixed up in this.

Since these updates always fix security holes, one solution would be to rebuild the backports version for the main MX repo, which will be seen as the highest version. But dang, that's a pretty heavy build.

Edit: stretch-backports-sloppy actually has the current version as buster-backports, 2.24.3-1, so I'll rebuild those.

User avatar
Stevo
Developer
Posts: 20096
Joined: Fri Dec 15, 2006 8:07 pm

Re: gufw firewall cannot be installed

#12

Post by Stevo » Fri Aug 09, 2019 2:24 pm

We've pushed a newer set of webkit 2.24.3 packages into main that should replace that one from stretch-backports and allow you to reinstall gufw now. Can you update those and try to reinstall it now?

User avatar
pemartins
Forum Novice
Forum  Novice
Posts: 70
Joined: Fri Nov 09, 2018 5:15 am

Re: gufw firewall cannot be installed

#13

Post by pemartins » Fri Aug 09, 2019 3:13 pm

Thank you for all the help and I apologize for all the trouble.

@Stevo can you help me doing that? I made a sudo apt update && sudo apt dist-upgrade but nothing was updated, all I got new was a weird warning about a package:

Code: Select all

The following packages have been kept back:
  libjavascriptcoregtk-4.0-18
and while trying to install gufw I still get the error:

Code: Select all

$ sudo apt install gufw
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gufw : Depends: gir1.2-webkit2-4.0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

edit: and if I try sudo apt-get update instead, I get the warning about two packages instead:

Code: Select all

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libjavascriptcoregtk-4.0-18 libwebkit2gtk-4.0-37
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

User avatar
Stevo
Developer
Posts: 20096
Joined: Fri Dec 15, 2006 8:07 pm

Re: gufw firewall cannot be installed

#14

Post by Stevo » Fri Aug 09, 2019 3:46 pm

Have you tried a straight upgrade instead of dist-upgrade?

Have you disabled stretch-backports if it's enabled? check the result of

Code: Select all

inxi -r
What's the result of

Code: Select all

apt policy libjavascriptcoregtk-4.0-18
For my updated system today, the new lib version and gufw are happy together:

Code: Select all

$ apt policy libjavascriptcoregtk-4.0-18 gufw
libjavascriptcoregtk-4.0-18:
  Installed: 2.24.3-1~mx17+1
  Candidate: 2.24.3-1~mx17+1
  Version table:
 *** 2.24.3-1~mx17+1 500
        500 file:/var/lib/local-apt-repository ./ Packages
        500 http://la.mxrepo.com/mx/repo stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     2.18.6-1~deb9u1 500
        500 http://ftp.us.debian.org/debian stretch/main amd64 Packages
gufw:
  Installed: 17.04.1-1.1
  Candidate: 17.04.1-1.1
  Version table:
 *** 17.04.1-1.1 500
        500 http://ftp.us.debian.org/debian stretch/main amd64 Packages
        500 http://ftp.us.debian.org/debian stretch/main i386 Packages
        100 /var/lib/dpkg/status
You can see the new webkit2gtk package is available in my local apt repository from where I test installed it first, and then in the main MX repo, in case anyone is wondering what that odd source is.

User avatar
pemartins
Forum Novice
Forum  Novice
Posts: 70
Joined: Fri Nov 09, 2018 5:15 am

Re: gufw firewall cannot be installed

#15

Post by pemartins » Fri Aug 09, 2019 3:57 pm

Here are the outputs:

Code: Select all

$ inxi -r
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/antix.list 
           1: deb https://mirrors.evowise.com/mxlinux-packages/antix/stretch/ stretch main
           Active apt repos in: /etc/apt/sources.list.d/brave-browser-release-trusty.list 
           1: deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ trusty main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://ftp.pt.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://ftp.pt.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           3: deb-src http://ftp.pt.debian.org/debian/ stretch main contrib non-free
           4: deb http://deb.debian.org/debian/ stretch-backports main
           Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
           1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb https://mirrors.evowise.com/mxlinux-packages/mx/repo/ stretch main non-free
           Active apt repos in: /etc/apt/sources.list.d/spotify.list 
           1: deb http://repository.spotify.com/ stable non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list 

Code: Select all

$ apt policy libjavascriptcoregtk-4.0-18
libjavascriptcoregtk-4.0-18:
  Installed: 2.18.6-1~deb9u1.0
  Candidate: 2.24.3-1~mx17+1
  Version table:
     2.24.3-1~mx17+1 500
        500 https://mirrors.evowise.com/mxlinux-packages/mx/repo stretch/main amd64 Packages
     2.24.2-1~bpo9+1 100
        100 http://deb.debian.org/debian stretch-backports/main amd64 Packages
 *** 2.18.6-1~deb9u1.0 100
        100 /var/lib/dpkg/status
     2.18.6-1~deb9u1 500
        500 http://ftp.pt.debian.org/debian stretch/main amd64 Packages
and I also checked it for the other package mentioned at apt-get update:

Code: Select all

$ apt policy libwebkit2gtk-4.0-37
libwebkit2gtk-4.0-37:
  Installed: 2.18.6-1~deb9u1.0
  Candidate: 2.24.3-1~mx17+1
  Version table:
     2.24.3-1~mx17+1 500
        500 https://mirrors.evowise.com/mxlinux-packages/mx/repo stretch/main amd64 Packages
     2.24.2-1~bpo9+1 100
        100 http://deb.debian.org/debian stretch-backports/main amd64 Packages
 *** 2.18.6-1~deb9u1.0 100
        100 /var/lib/dpkg/status
     2.18.6-1~deb9u1 500
        500 http://ftp.pt.debian.org/debian stretch/main amd64 Packages

User avatar
Stevo
Developer
Posts: 20096
Joined: Fri Dec 15, 2006 8:07 pm

Re: gufw firewall cannot be installed

#16

Post by Stevo » Fri Aug 09, 2019 4:20 pm

You still have stretch-backports enabled at all times. This is against their and our advice. Please disable it and "sudo apt update".

OK, let's see if aptitude can fix this. It has some degree of smarts. Install aptitude if you need to, and run

Code: Select all

sudo aptitude install gufw


Odds are that it will say it can't at first, but don't worry, since it can try different solutions. Just hit the "N" key to go to the next try. Read what it proposes carefully. You want the solution that will upgrade the webkit2gtk packages to our new 2.24.3 version and also install gufw. If you aren't sure what it's saying, copy and paste it here. Keep hitting "N" if you can't get a good solution, or aptitude gives up.

User avatar
pemartins
Forum Novice
Forum  Novice
Posts: 70
Joined: Fri Nov 09, 2018 5:15 am

Re: gufw firewall cannot be installed

#17

Post by pemartins » Fri Aug 09, 2019 4:38 pm

This is the repo I should disable, the one highlighted in blue, right?:

https://i.imgur.com/JbfWL1J.png

It's one of those things that I have no idea about, at some point by some reason it got activated, also in a previous thread I was advised to also uncheck a multimedia repo I had active.


Better safe than sorry, so which one should I choose?

Code: Select all

$ sudo aptitude install gufw
The following NEW packages will be installed:
  gir1.2-javascriptcoregtk-4.0{a} gir1.2-soup-2.4{a} gir1.2-webkit2-4.0{a} gufw 
The following packages will be upgraded:
  libjavascriptcoregtk-4.0-18 libwebkit2gtk-4.0-37{b} 
2 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 17.5 MB of archives. After unpacking 9,037 kB will be used.
The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libgstreamer-plugins-bad1.0-0 (< 1.10.5) but 1:1.10.4-dmo2 is installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:  
1)     gir1.2-webkit2-4.0 [Not Installed]                   
2)     gufw [Not Installed]                                 
3)     libjavascriptcoregtk-4.0-18 [2.18.6-1~deb9u1.0 (now)]
4)     libwebkit2gtk-4.0-37 [2.18.6-1~deb9u1.0 (now)]       



Accept this solution? [Y/n/q/?] 

User avatar
Stevo
Developer
Posts: 20096
Joined: Fri Dec 15, 2006 8:07 pm

Re: gufw firewall cannot be installed

#18

Post by Stevo » Fri Aug 09, 2019 6:16 pm

That solution does nothing, so hit "N" to try the next one.

Code: Select all

 libwebkit2gtk-4.0-37 : Depends: libgstreamer-plugins-bad1.0-0 (< 1.10.5) but 1:1.10.4-dmo2 is installed
And here we see that deb-multimedia (dmo) has also "infected" your system with a bogus higher version of libgstreamer-plugins-bad1.0-0, yet another example of why we warn against using it. You'll want your aptitude solution to also "downgrade" that package to the stock Stretch 1.10.4-1 version.

We added a GUI for managing repos to make disabling them quite easy, and you'll find it in MX Tools.

TinyCritter
Forum Novice
Forum  Novice
Posts: 15
Joined: Sun May 26, 2019 8:12 pm

Re: gufw firewall cannot be installed

#19

Post by TinyCritter » Fri Aug 09, 2019 11:31 pm

Hey guys - thought I'd post here to avoid making a new thread about the same thing: After the most recent update, I noticed that gufw was completely missing (the shortcut/launcher to it on my side panel couldn't find the program, which was a bit puzzling). I found this thread a couple minutes later, and ended up using sudo aptitude install gufw - I don't have a screenshot or text paste of it at the moment, but the first solution offered didn't do anything, so I hit 'n' for the next one, which downgraded I think 4-ish packages, and successfully reinstalled it. (I'm a total linux newbie as of right now, so a lot of what I'm saying might be vague and unhelpful, haha).

Immediately afterwards, the MX updater lit up, and this time I remembered to at least copy the text:

Code: Select all

  full upgrade
  Reading package lists...
  Building dependency tree...
  Reading state information...
  Calculating upgrade...
  The following packages were automatically installed and are no longer required:
     gir1.2-javascriptcoregtk-4.0 (2.24.3-1~mx17+1)
     gir1.2-soup-2.4 (2.56.0-2+deb9u2)
     libenchant1c2a (1.6.0-11+b1)
     libjavascriptcoregtk-4.0-18 (2.24.3-1~mx17+1)
     ufw (0.35-4)
  Use 'apt autoremove' to remove them.
  The following packages will be REMOVED:
     gir1.2-webkit2-4.0 (2.24.3-1~mx17+1)
     gufw (17.04.1-1.1)
     libwebkit2gtk-4.0-37 (2.24.3-1~mx17+1)
  The following packages will be upgraded:
     gir1.2-javascriptcoregtk-4.0 (2.18.6-1~deb9u1 => 2.24.3-1~mx17+1)
     libjavascriptcoregtk-4.0-18 (2.18.6-1~deb9u1 => 2.24.3-1~mx17+1)
  2 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
  Need to get 4,936 kB of archives.
  After this operation, 46.4 MB disk space will be freed.
it seems like it wants to remove gufw completely via the update process, which is what I'm assuming happened last time I updated (without paying enough attention, as it were :/) and which I ended up having to downgrade a couple things for afterwards in order to reinstall it.

I'm wondering if there's an easy solution to this - again I'm pretty clueless when it come to linux in general, so any help would be appreciated. :)

User avatar
pemartins
Forum Novice
Forum  Novice
Posts: 70
Joined: Fri Nov 09, 2018 5:15 am

Re: gufw firewall cannot be installed

#20

Post by pemartins » Sat Aug 10, 2019 12:43 am

So in my scenario which would be the best option? I hit "n" every time so I could list them all here:

Code: Select all

$ sudo aptitude install gufw
The following NEW packages will be installed:
  gir1.2-javascriptcoregtk-4.0{a} gir1.2-soup-2.4{a} gir1.2-webkit2-4.0{a} gufw 
The following packages will be upgraded:
  libjavascriptcoregtk-4.0-18 libwebkit2gtk-4.0-37{b} 
2 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 17.5 MB of archives. After unpacking 9,037 kB will be used.
The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libgstreamer-plugins-bad1.0-0 (< 1.10.5) but 1:1.10.4-dmo2 is installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:  
1)     gir1.2-webkit2-4.0 [Not Installed]                   
2)     gufw [Not Installed]                                 
3)     libjavascriptcoregtk-4.0-18 [2.18.6-1~deb9u1.0 (now)]
4)     libwebkit2gtk-4.0-37 [2.18.6-1~deb9u1.0 (now)]       



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Remove the following packages:                       
1)     libwebkit2gtk-4.0-37 [2.18.6-1~deb9u1.0 (now)]     
2)     libyelp0 [3.22.0-1 (now, oldstable)]               
3)     yelp [3.22.0-1 (now, oldstable)]                   
4)     zenity [3.22.0-1+b1 (now, oldstable)]              

     Keep the following packages at their current version:
5)     gir1.2-webkit2-4.0 [Not Installed]                 
6)     gufw [Not Installed]                               



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Install the following packages:                             
1)     gir1.2-javascriptcoregtk-4.0 [2.18.6-1~deb9u1 (oldstable)]
2)     gir1.2-webkit2-4.0 [2.18.6-1~deb9u1 (oldstable)]          

     Keep the following packages at their current version:       
3)     libjavascriptcoregtk-4.0-18 [2.18.6-1~deb9u1.0 (now)]     
4)     libwebkit2gtk-4.0-37 [2.18.6-1~deb9u1.0 (now)]            



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

      Install the following packages:                                              
1)      libass5 [1:0.13.4-2 (oldstable)]                                           
2)      libde265-0 [1.0.2-2+b2 (oldstable)]                                        
3)      libopencv-calib3d2.4v5 [2.4.9.1+dfsg1-2 (oldstable)]                       
4)      libopencv-features2d2.4v5 [2.4.9.1+dfsg1-2 (oldstable)]                    
5)      libopencv-flann2.4v5 [2.4.9.1+dfsg1-2 (oldstable)]                         
6)      libopencv-highgui2.4-deb0 [2.4.9.1+dfsg1-2 (oldstable)]                    
7)      libopencv-objdetect2.4v5 [2.4.9.1+dfsg1-2 (oldstable)]                     
8)      libopencv-video2.4v5 [2.4.9.1+dfsg1-2 (oldstable)]                         
9)      libx265-95 [2.1-2+b2 (oldstable)]                                          

      Downgrade the following packages:                                            
10)     gstreamer1.0-plugins-bad [1:1.10.4-dmo2 (now) -> 1.10.4-1 (oldstable)]     
11)     libgstreamer-plugins-bad1.0-0 [1:1.10.4-dmo2 (now) -> 1.10.4-1 (oldstable)]



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Remove the following packages:                                               
1)     cheese [3.22.1-1+b1 (now, oldstable)]                                      
2)     gnome-video-effects [0.4.1-3 (now, oldstable)]                             
3)     gradio [7.0-0mx17 (mx, now)]                                               
4)     gstreamer1.0-plugins-bad [1:1.10.4-dmo2 (now)]                             
5)     libcheese-gtk25 [3.22.1-1+b1 (now, oldstable)]                             
6)     libcheese8 [3.22.1-1+b1 (now, oldstable)]                                  

     Downgrade the following packages:                                            
7)     libgstreamer-plugins-bad1.0-0 [1:1.10.4-dmo2 (now) -> 1.10.4-1 (oldstable)]



Accept this solution? [Y/n/q/?] 
I assume it's the following, but nevertheless I'll wait for feedback before doing it:

Code: Select all

      Install the following packages:                                              
1)      libass5 [1:0.13.4-2 (oldstable)]                                           
2)      libde265-0 [1.0.2-2+b2 (oldstable)]                                        
3)      libopencv-calib3d2.4v5 [2.4.9.1+dfsg1-2 (oldstable)]                       
4)      libopencv-features2d2.4v5 [2.4.9.1+dfsg1-2 (oldstable)]                    
5)      libopencv-flann2.4v5 [2.4.9.1+dfsg1-2 (oldstable)]                         
6)      libopencv-highgui2.4-deb0 [2.4.9.1+dfsg1-2 (oldstable)]                    
7)      libopencv-objdetect2.4v5 [2.4.9.1+dfsg1-2 (oldstable)]                     
8)      libopencv-video2.4v5 [2.4.9.1+dfsg1-2 (oldstable)]                         
9)      libx265-95 [2.1-2+b2 (oldstable)]                                          

      Downgrade the following packages:                                            
10)     gstreamer1.0-plugins-bad [1:1.10.4-dmo2 (now) -> 1.10.4-1 (oldstable)]     
11)     libgstreamer-plugins-bad1.0-0 [1:1.10.4-dmo2 (now) -> 1.10.4-1 (oldstable)]

Post Reply

Return to “MX Help”